Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 49479 - new ndiswrapper released 0.8
Summary: new ndiswrapper released 0.8
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Mobile Herd (OBSOLETE)
Depends on:
Reported: 2004-04-30 02:47 UTC by Torbjörn Svensson
Modified: 2004-12-29 06:22 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

ndiswrapper-0.8_rc1.ebuild (ndiswrapper-0.8_rc1.ebuild,1.91 KB, text/plain)
2004-05-31 01:59 UTC, teedog
ndiswrapper-0.8.ebuild (ndiswrapper-0.8.ebuild,1.90 KB, text/plain)
2004-07-02 22:11 UTC, teedog

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjörn Svensson 2004-04-30 02:47:35 UTC
When will ndiswrapper 0.7 hit gentoo? If this is a mistake, please correct it :)

Reproducible: Always
Steps to Reproduce:

Portage 2.0.50-r6 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3_pre20040420-r0, 2.6.5)
System uname: 2.6.5 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.20GHz
Gentoo Base System version 1.4.10
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=pentium4 -O3 -pipe"
CONFIG_PROTECT="/etc /opt/glftpd/etc /usr/X11R6/lib/X11/xkb
/usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X aalib alsa avi berkdb crypt cups dvd encode foomaticdb gdbm gif gnome gtk
gtk2 imlib java jpeg kde libg++ libwww mad mikmod mmx motif mpeg ncurses nls
oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang
spell sse ssl svga tcltk tcpd truetype x86 xml xml2 xmms xv zlib"
Comment 1 Dick Marinus 2004-05-15 06:21:33 UTC
I've just tried a version bump and it seems to merge + run fine
Comment 2 Mark Flanagan 2004-05-26 15:47:50 UTC
Version bump worked fine here as well - please bump this and stick it in
Comment 3 teedog 2004-05-31 01:59:17 UTC
Created attachment 32369 [details]

Updated ebuild to the latest v0.8-rc1.	Compiled fine on my end.
Comment 4 Daniel Webert 2004-06-10 06:04:45 UTC
the full 0.8 is released - plz bump
Comment 5 Christian Bartels 2004-06-17 06:31:13 UTC
i still get an sandbox violation like with every other version of ndiswrapper, too, but with sandboxing disabled it emerges fine.
Comment 6 Mark Flanagan 2004-06-27 11:35:21 UTC
Please? this is a simple version bump, does it really take that long?

Comment 7 teedog 2004-07-02 22:11:57 UTC
Created attachment 34689 [details]
Comment 8 Alexander M. Turek 2004-07-04 06:18:40 UTC
teedog's ndiswrapper 0.8 ebuild worked fine on my machine. Please merge it with the official portage tree.
Comment 9 Peter Johanson (RETIRED) gentoo-dev 2004-07-07 20:19:48 UTC
Okay, just added an ebuild for 0.8.

teedog's ebuild needed fixing to get the modules.d file to actually install, it pointed to a non-existant file in the ${FILESDIR}. Some other minor enhancements were added too. Please test and report back success/failure.
Comment 10 Kristian 2004-07-08 14:21:29 UTC
well it RUNS fine for me to, but i'm using software suspend ( on 2.6.7-gentoo-r7/8. so i unload yenta_socket and pcmcia_core before i suspend. when i reinsert them with 0.6-r1 no problem, but 0.8 locks up the whole box. if it has been loaded i have to reboot.
what i do when i call hibernate:
modprobe -r ndiswrapper
cardctl eject
modprobe -r yenta_socket
modprobe -r pcmcia_core

they all work clean

on resume
modprobe pcmcia_core
modprobe yenta_socket

i didn't test yet which of the last two is responsible for the crash. i guess its yenta_socket. i don't have to hibernate, just removing and reinserting them is enough.
Comment 11 Henrik Brix Andersen 2004-12-29 06:22:36 UTC
Closing due to lack of feedback.