Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 494280 - net-fs/nfs-utils-1.2.9 with net-fs/autofs-? - remote shares mounted as noexec
Summary: net-fs/nfs-utils-1.2.9 with net-fs/autofs-? - remote shares mounted as noexec
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2013-12-14 23:18 UTC by Alexander Stein
Modified: 2013-12-16 19:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Stein 2013-12-14 23:18:15 UTC
Starting with 1.2.9 my NFS client only get mounts where noexec is active, despite this line in my /etc/autofs/auto.nfs:
home            -rw,nosuid,nodev,noauto,exec
Having /home mounted with noexec have a script in ~/.kde4/Autostart breaks KDE, but that seems to be another bug.
Server is running a 3.11.2-hardened if that might be important.

Reproducible: Always

Steps to Reproduce:
1. Install =net-fs/nfs-utils-1.2.9
2. Restart nfsd /reboot NFS server
3. Mount NFS share on client
Actual Results:  
NFS mount has noexec flag.

Expected Results:  
NFS mount shall have exec (or no noexec) if exec is specified as mount option.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-12-16 12:24:04 UTC
1) Please post your `emerge --info net-fs/nfs-utils' output in a comment.
2) Does mounting work all right if you use fstab or a simple mount command?
Comment 2 Alexander Stein 2013-12-16 18:32:26 UTC
(In reply to Jeroen Roovers from comment #1)
> 1) Please post your `emerge --info net-fs/nfs-utils' output in a comment.

Here we go:
Portage 2.2.7 (hardened/linux/amd64, gcc-4.7.3, glibc-2.16.0, 3.11.2-hardened x86_64)
                        System Settings
System uname: Linux-3.11.2-hardened-x86_64-AMD_Sempron-tm-_Processor_3200+-with-gentoo-2.2
KiB Mem:     2545992 total,    501184 free
KiB Swap:     506040 total,    506040 free
Timestamp of tree: Mon, 16 Dec 2013 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo local java
CFLAGS="-march=native -O2 -pipe -mno-tls-direct-seg-refs"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mno-tls-direct-seg-refs"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/local /var/lib/layman/java"
USE="acl acpi amd64 bash-completion berkdb bzip2 bzlib caps cgi cli cracklib crypt cups cxx dbus dri fam fastcgi fbcon fontconfig gd gdbm git glib hardened hinotify iconv imap ipv6 jpeg justify kerberos logrotate mmx modules mudflap multilib multiuser ncurses network-cron nls nptl openmp pam pam_krb5 pam_ssh pax_kernel pcre perl png python readline samba screen session sse sse2 ssl subversion sysfs tcpd threads truetype unicode urandom vim-syntax vorbis xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-fs/nfs-utils-1.2.9 was built with the following:
USE="caps ipv6 kerberos libmount (multilib) nfsidmap nfsv4 tcpd uuid -nfsdcld -nfsv41 (-selinux)" ABI_X86="64"

> 2) Does mounting work all right if you use fstab or a simple mount command?

Unfortunatly I can't reproduce this problem anymore after upgrading to net-fs/nfs-utils-1.2.9. I tried that to investigate the KDE side, but everything worked fine :-/

BTW: net-fs/autofs-5.0.7-r4 is installed client-side
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-12-16 19:33:44 UTC
If even you cannot reproduce it, there is no apparent bug to fix.