Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493920 - app-emulation/emul-linux-x86-soundlibs-20131008-r2[-pulseaudio,abi_x86_32] should not install alsa modules for pulseaudio
Summary: app-emulation/emul-linux-x86-soundlibs-20131008-r2[-pulseaudio,abi_x86_32] sh...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Multilib team
Depends on:
Reported: 2013-12-11 09:49 UTC by Andrei Slavoiu
Modified: 2015-06-02 08:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2013-12-11 09:49:08 UTC
!!! existing preserved libs:
>>> package: app-emulation/emul-linux-x86-soundlibs-20131008-r2
 *  - /usr/lib32/
 *  - /usr/lib32/
 *      used by /usr/lib32/alsa-lib/ (app-emulation/emul-linux-x86-soundlibs-20131008-r2)
 *      used by /usr/lib32/alsa-lib/ (app-emulation/emul-linux-x86-soundlibs-20131008-r2)
 *      used by /usr/lib32/alsa-lib/ (app-emulation/emul-linux-x86-soundlibs-20131008-r2)

Reproducible: Always

Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
                        System Settings
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem:     8102020 total,    424176 free
KiB Swap:    6194356 total,   5563496 free
Timestamp of tree: Mon, 09 Dec 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo local
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x"
CFLAGS="-O2 -march=native -pipe -ggdb"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="7zip X a52 aac aacplus aalib accessibility acl acpi ads aiglx aio akonadi alsa amd64 amr amrnb amrwb analitza apache2 asf aspell attica avahi bash-completion berkdb branding bzip2 caps cdda cdr chdir cli client clucene consolekit corefonts cracklib crypt css curl cxx dbus dcc_video declarative dga dlz dmi doc dot dri dts dvd dvdr egl emboss encode exif expat faac faad fam farstream fbcondecor ffmpeg firefox flac fontconfig fortran g3dvl gcj gd gdbm gif git gles gles2 glew glib glibc-omitfp glitz glut gmp gnokii gnutls gpm graphviz gsm gstreamer havekernel history htmlhandbook iconv icu id3tag idn imagemagick imlib ipv6 irc jabber jadetex javascript jingle jpeg jpeg2k kde kdehiddenvisibility kdepim kdrive kerberos kig-scripting kipi lcms ldap libcaca libnotify llvm llvm-shared-libs lm_sensors lzma lzo mad marble mdnsresponder-compat mjpeg mmx mng modules mp3 mp4 mpeg mpi mplayer mudflap multilib ncurses nettle network nls nowlistening nptl ntlm_unsupported_patch ogg openal opencl opencore-amr openexr opengl openmp openvg opus pam pango pch pcntl pcre pcsc-lite pdf perforce phonon plasma png policykit povray ppds prison qemu qemu-ifup qt3support qt4 qthelp r600-llvm-compiler rdesktop rdp readline reports rtmp samba sasl schroedinger sdl semantic-desktop session shared-dricore slang snmp speex spell spice sql sqlite sqlite3 sse sse2 sse3 sse4_1 ssl ssse3 startup-notification statistics svg symlink system-libvncserver tcpd telepathy theora threads tidy tiff truetype udev udisks unicode upcall upnp upower usb vaapi vdpau video visualization vnc vorbis webkit winbind wmf x264 xattr xcb xcomposite xinerama xml xmp xv xvid xvmc yahoo zeroconf zip zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ro en eo" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm i386 ppc x86_64" QEMU_USER_TARGETS="arm i386 ppc x86_64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="r600 radeon modesetting vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-emulation/emul-linux-x86-soundlibs-20131008-r2 was built with the following:
USE="alsa development -pulseaudio" ABI_X86="32"
Comment 1 Ben Kohler gentoo-dev 2013-12-11 14:10:49 UTC
Probably dupe of bug 493256, right now disabling pulseaudio on this PREBUILT package is very hacky and ends up with some broken features.  It's a known limitation that will hopefully be fixed soon when we get soundlibs totally migrated to the new multilib setup.
Comment 2 Andrei Slavoiu 2013-12-11 14:24:24 UTC
Can't these files be removed in src_prepare()? Something like:

if use abi_x86_32 && ! use pulseaudio; then
    rm -f {$S}/usr/lib32/alsa-lib/*pulse*.so

If anything tried to load those files it would fail anyway as they have undefined symbols.
Comment 3 eroen 2013-12-11 16:24:30 UTC
(In reply to Andrei Slavoiu from comment #2)
> Can't these files be removed in src_prepare()?
> If anything tried to load those files it would fail anyway as they have
> undefined symbols.

That's almost true, currently it will still work if the pulseaudio libraries have been installed earlier and are kept around by preserve-libs.

The pulseaudio flag is a hack, and was introduced as a workaround to avoid the unhappy dependencies of the actual pulseaudio package. I would prefer it if either a library-only installation of pulseaudio was supported, or the emul- package installed the prebuilt pulseaudio libraries if the pulseaudio flag is disabled. In my opinion, removing the modules from the emul- package just makes things (slightly) worse than they currently are.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-06-02 08:33:44 UTC
The emul-linux-x86 packages have been removed.