Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493740 - dev-ruby/rake-0.9.6 - /usr/lib64/ruby/2.0.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
Summary: dev-ruby/rake-0.9.6 - /usr/lib64/ruby/2.0.0/rubygems.rb:15:in `require': cann...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-09 10:31 UTC by Andrey Tykhonov
Modified: 2016-04-27 19:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,19.36 KB, text/plain)
2013-12-09 10:31 UTC, Andrey Tykhonov
Details
build.log (493740.log,10.23 KB, text/plain)
2014-08-22 15:42 UTC, Andrey Aleksandrovich
Details
emerge-info.txt (emerge-info.txt,7.59 KB, text/plain)
2016-04-27 19:45 UTC, Toralf Förster
Details
dev-ruby:rake-11.1.2:20160427-184943.log (dev-ruby:rake-11.1.2:20160427-184943.log,2.92 KB, text/plain)
2016-04-27 19:46 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,240.05 KB, text/plain)
2016-04-27 19:46 UTC, Toralf Förster
Details
environment (environment,159.39 KB, text/plain)
2016-04-27 19:46 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Tykhonov 2013-12-09 10:31:56 UTC
Created attachment 364996 [details]
build.log

I'm experiencing the following error while "emerge -uND world":

/usr/lib64/ruby/2.0.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
        from /usr/lib64/ruby/2.0.0/rubygems.rb:15:in `<top (required)>'
        from <internal:gem_prelude>:1:in `require'
        from <internal:gem_prelude>:1:in `<compiled>'
 * ERROR: dev-ruby/rake-0.9.6::gentoo failed (install phase):
 *   Unable to generate gemspec file.
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4639:  Called ruby-ng_src_install
 *   environment, line 4305:  Called _ruby_each_implementation 'each_ruby_install'
 *   environment, line  478:  Called _ruby_invoke_environment 'ruby20' 'each_ruby_install'
 *   environment, line  530:  Called each_ruby_install
 *   environment, line  831:  Called each_fakegem_install
 *   environment, line  804:  Called ruby_fakegem_install_gemspec
 *   environment, line 4486:  Called die
 * The specific snippet of code:
 *       fi ) || die "Unable to generate gemspec file.";


The file with full log is attached.
Comment 1 Hans de Graaff gentoo-dev 2013-12-15 09:03:01 UTC
This file is provided by dev-ruby/rubygems. Is that already installed when this happens? It should be, but let's check that first.
Comment 2 Andrey Aleksandrovich 2014-08-22 15:42:21 UTC
Created attachment 383402 [details]
build.log

Similar problem when emerging =media-video/mkvtoolnix-6.6.0
However, 'emerge -1av dev-lang/ruby' solves it.
Comment 3 Hans de Graaff gentoo-dev 2014-08-22 16:12:32 UTC
(In reply to Andrey Aleksandrovich from comment #2)
> Created attachment 383402 [details]
> build.log
> 
> Similar problem when emerging =media-video/mkvtoolnix-6.6.0
> However, 'emerge -1av dev-lang/ruby' solves it.

Can you confirm that you did not have any version of ruby installed yet before emerging this, and that it was pulled in as part of this emerge action?

I suspect the issue is with the fact that we need to use PDEPEND to pull in the additional ruby components (because we need to have ruby installed first).
Comment 4 Thomas Capricelli 2014-11-17 00:03:56 UTC
I had the problem today with "emerge -uND world" and dev-ruby/rake-10.3.2 :


---------------------------------------------------------------------
% cat /var/tmp/portage/dev-ruby/rake-10.3.2/temp/build.log
 * Package:    dev-ruby/rake-10.3.2
 * Repository: gentoo
 * Maintainer: ruby@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux ruby_targets_ruby21 userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Running unpack phase for all ...
 * Unpacking .gem file... ...
 [ ok ]
 * Uncompressing metadata ...
 [ ok ]
 * Unpacking data.tar.gz ...
 [ ok ]
 * Running prepare phase for all ...
 * Running source copy phase for ruby21 ...
 * Running prepare phase for ruby21 ...
 * Running compile phase for all ...
 * Running install phase for ruby21 ...
/usr/lib64/ruby/2.1.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
        from /usr/lib64/ruby/2.1.0/rubygems.rb:15:in `<top (required)>'
        from <internal:gem_prelude>:1:in `require'
        from <internal:gem_prelude>:1:in `<compiled>'
 * ERROR: dev-ruby/rake-10.3.2::gentoo failed (install phase):
 *   Unable to generate gemspec file.
---------------------------------------------------------------------

Checking previous comments, i checked : 

dev-lang/ruby-2.1.5 (last ~amd64) is currently installed
no dev-ruby/rubygems is installed
virtual/rubygems is installed (both "6" and "(~)7")


I fixed the stuff by issuing : emerge -C virtual/rubygems
Comment 5 Norman Rieß 2015-01-20 08:35:13 UTC
(In reply to Hans de Graaff from comment #3)
> (In reply to Andrey Aleksandrovich from comment #2)
> > Created attachment 383402 [details]
> > build.log
> > 
> > Similar problem when emerging =media-video/mkvtoolnix-6.6.0
> > However, 'emerge -1av dev-lang/ruby' solves it.
> 
> Can you confirm that you did not have any version of ruby installed yet
> before emerging this, and that it was pulled in as part of this emerge
> action?
> 
> I suspect the issue is with the fact that we need to use PDEPEND to pull in
> the additional ruby components (because we need to have ruby installed
> first).

I can confirm this. On a bare system this happened when emerging media-video/mkvtoolnix-6.6.0.
The suggested emerge -1v dev-lang/ruby pulled a whole bunch of other ruby dependencies as new packages which where not pulled when emerging mkvtoolix.
Comment 6 Toralf Förster gentoo-dev 2016-04-27 19:45:58 UTC
Created attachment 432322 [details]
emerge-info.txt

>>> Install rake-11.1.2 into /var/tmp/portage/dev-ruby/rake-11.1.2/image/ category dev-ruby
 * Running install phase for ruby20 ...
/usr/lib64/ruby/2.0.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
	from /usr/lib64/ruby/2.0.0/rubygems.rb:15:in `<top (required)>'
	from <internal:gem_prelude>:1:in `require'
	from <internal:gem_prelude>:1:in `<compiled>'
Comment 7 Toralf Förster gentoo-dev 2016-04-27 19:46:01 UTC
Created attachment 432324 [details]
dev-ruby:rake-11.1.2:20160427-184943.log
Comment 8 Toralf Förster gentoo-dev 2016-04-27 19:46:04 UTC
Created attachment 432326 [details]
emerge-history.txt
Comment 9 Toralf Förster gentoo-dev 2016-04-27 19:46:06 UTC
Created attachment 432328 [details]
environment