Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 49364 - xine-lib-1-rc4 breaks audio in WMV files.
Summary: xine-lib-1-rc4 breaks audio in WMV files.
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on: 51028
Blocks:
  Show dependency tree
 
Reported: 2004-04-29 02:34 UTC by David Flogeras
Modified: 2004-05-16 08:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Flogeras 2004-04-29 02:34:02 UTC
Since upgrading to xine-lib-1-rc3-r3 (and xine-ui-0.9.23-r2) everytime I play a WMV file, the audio comes out as static (video seems fine).  I dont think it is the CODEC, since Kaboodle plays the same files perfectly; just to be sure, I re-emerged win32codecs but it did not fix it.

I have confirmed this behaviour on two machines (Athlon XP 1800+, Pentium Centrino Laptop).  Some stats below for the AMD machine:


2.6.5-gentoo-r1 #2 Sat Apr 24 16:28:40 ADT 2004 i686 AMD Athlon(TM) XP1800+ AuthenticAMD GNU/Linux

gcc (GCC) 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7)

CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -falign-functions=4 -mfpmath=sse"
Comment 1 Carlos Vendramini 2004-04-30 00:21:23 UTC
I'm recompiling faad2, ffmpeg and now Xine to try resolve this issue. I'm having the same problem with xine-lib-1-rc4.
Comment 2 Carlos Vendramini 2004-04-30 02:31:40 UTC
Below the transcription of my mail to xine-users-mailinglist

"Hi
 
I'm using xine-lib-1-rc4 installed via Gentoo Portage at a machine with Kernel 2.6.5 (alsa enabled 
into kernel). The frontend is Gxine. Real Player streaming are ok.
 
The question is that when I try access windos media content the video is fine but sound seems as a 
sound of static, just the noise..
 
Example here:
 
Windows Media: mms://wmsao6.terra.com.br/mibdotnet/00/08/98/89813.wmv?url=51241741153115R16079
 
Real Media: rtsp://realsao2.terra.com.br/mibdotnet/00/08/95/89592.rm?url=39361741153115
 
Another example:
 
Windows Media: mmsh://wmsao2.terra.com.br/mibtvterra?url=44321741153115R16079
 
Real Media: rtsp://realsao3.terra.com.br/encoder/tvterra.rm?URL=57341741153115
 
 
 
Any ideaas???
 
Thanks"
Comment 3 Carlos Vendramini 2004-04-30 07:06:21 UTC
reopenning this request
Comment 4 fbusse 2004-05-08 00:27:56 UTC
I've the same problem. Every xine-lib version >1_rc2 doesn't play any sound in Windows Media Files on my machine. mplayer works fine.
Even setting CFLAGS="-O1" doesn't help.

Portage 2.0.50-r6 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.6.5)
Comment 5 fbusse 2004-05-11 09:42:33 UTC
It's fixed in the current xine-lib CVS (at least it works for me now).
Comment 6 fbusse 2004-05-12 08:37:16 UTC
Carlos, could you please have a look at #50854 and let me know if it works for you?
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2004-05-15 03:56:28 UTC
closing with xine-lib-1_rc4-r1 wich is rc4a
Comment 8 David Flogeras 2004-05-16 08:37:03 UTC
works for me!