Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493068 - net-im/skype- with media-sound/pulseaudio-4.0 - sound output does not work
Summary: net-im/skype- with media-sound/pulseaudio-4.0 - sound output does ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
: 509196 (view as bug list)
Depends on:
Reported: 2013-12-01 21:03 UTC by Sven
Modified: 2014-08-30 13:00 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sven 2013-12-01 21:03:31 UTC

ever since I upgraded to pulseaudio 4.0 audio is basically broken. In the options, the testsound doesn't play, during a testcall I can't hear anything, and like after 3 testcalls I get a kind of distorted constant "beep" sound that lasts until I quit skype.

I also upgraded the emul* ebuilds and the pulseaudio ebuild to the latest multilib version, so that I'm sure that the pulseaudio 32bit lib matches the rest of my system. Still no improvement.

Reproducible: Always
Comment 1 Eugene Volchek 2013-12-02 12:49:58 UTC
Seme here. Downgrading Pulseaudio to v2.1 resolves the issue.
Comment 3 Sven 2013-12-02 17:54:18 UTC
The recommended solution in the link I posted is a bit funny: if you only adjust the desktop file, skype will still not if you run it from the command line or - as in my case - if the skype command is run automatically on every login.

The link claims, it's already fixed on Gentoo. I hope, the Gentoo dev didn't follow the brain-dead suggestion of adjusting the desktop file.
Comment 4 Sven 2013-12-02 19:33:50 UTC
Yep, the Gentoo skype maintainer adjusted the desktop file. So skype is broken for everybody that runs skype directly.
Comment 5 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2014-01-07 10:12:24 UTC
I've had this problem long enough to do serious sleuthing on it.

I found this solution works:


Try different values of MSEC.

Though, if the solution proposed in there solves your problem, you've got a dup of bug #473510

Though bug #473510 is only solved if you're using the menu/desktop link.

If you're like me, spawning Skype from the CLI, you'll need to manually set PULSE_LATENCY_MSEC yourself.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2014-04-30 22:47:01 UTC
*** Bug 509196 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2014-06-12 17:44:24 UTC
*** Bug 509196 has been marked as a duplicate of this bug. ***
Comment 8 shinydoofy 2014-06-18 22:00:34 UTC
With the bump from bug 513712 setting the environment variable doesn't seem to be needed anymore. You guys might try as well.
Comment 9 J. Roeleveld 2014-08-27 05:34:29 UTC
I believe this bug can be closed as it's for an older version.
Additionally, Skype versions before 4.3 can no longer connect.
(I received the email about this in Dutch, please let me know if you want a copy)