Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 492452 - sys-fs/eudev-1.3 + virtual/udev-208 + sys-apps/hwids-20130915.1: circular dependencies error
Summary: sys-fs/eudev-1.3 + virtual/udev-208 + sys-apps/hwids-20130915.1: circular dep...
Status: RESOLVED DUPLICATE of bug 492446
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-24 21:16 UTC by sphakka
Modified: 2013-11-25 03:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sphakka 2013-11-24 21:16:08 UTC
Can't upgrade to sys-fs/eudev-1.3 + virtual/udev-208 + sys-apps/hwids-20130915.1:

# emerge -uDNaq world

[ebuild     U  ] sys-fs/eudev-1.3 [1.1] USE="gudev hwdb keymap modutils openrc rule-generator -doc -introspection -kmod (-selinux) -static-libs {-test}" ABI_X86="(64%*) (-32) (-x32)" 1,641 kB
[ebuild     U  ]  sys-apps/hwids-20130915.1 [20130329] USE="udev" 1,535 kB
[nomerge       ]  sys-apps/util-linux-2.22.2  USE="cramfs crypt ncurses nls static-libs suid udev unicode -ddate -old-linux -perl (-selinux) -slang {-test}"
[ebuild  N     ]   virtual/udev-208  USE="gudev kmod -introspection (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 3,175 kB

 * Error: circular dependencies:

(virtual/udev-208::gentoo, ebuild scheduled for merge) depends on
 (sys-fs/eudev-1.3::gentoo, ebuild scheduled for merge) (runtime)
  (sys-apps/hwids-20130915.1::gentoo, ebuild scheduled for merge) (runtime)
   (virtual/udev-208::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- virtual/udev-208 (Change USE: -kmod)

Reproducible: Always




Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-r1-x86_64-AMD_Turion-tm-_64_X2-with-gentoo-2.2
KiB Mem:     3984592 total,    718064 free
KiB Swap:    3148736 total,   3148736 free
Timestamp of tree: Sun, 24 Nov 2013 16:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo enlightenment xmw proaudio g-ctan unsupported portage-aeskulap
Installed sets: @xfce
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/"
INSTALL_MASK="/usr/lib/systemd/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/enlightenment /var/lib/layman/xmw /var/lib/layman/pro-audio /var/portage/overlay/g-ctan /var/portage/overlay/unsupported /var/portage/overlay/portage-aeskulap"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 amr apng bash-completion berkdb bittorrent bluetooth branding bzip2 cairo calendar caps cdda cddb cdr cli consolekit cracklib crypt cups curl cvs cxx dbus directfb djvu dts dvd dvdr ebook emacs embedded emboss enchant encode exif fam fbcon ffmpeg firefox flac fortran gdbm gif git gnutls gpm h323 http hunspell iconv infinality ipv6 jabber jack jpeg kontact kpathsea ladspa lame laptop latex lcms ldap libnotify libsamplerate lxde mad matroska mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib musepack mysql ncurses nls nptl nsplugin ntfs ntfsprogs ofx ogg opengl openmp openvg pam pango pcre pdf pgo png policykit ppds quicktime readline real rtmp samba sdl seamonkey session spell sql sqlite sse sse2 ssh ssl startup-notification svg system-jpeg system-sqlite tcpd threads tiff tordns truetype udev udisks unicode upower usb v4l v4l2 video vlc vorbis wavpack wifi wxwidgets x264 xcb xetex xml xv xvfb xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="crypt lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="nvidia modesetting vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Thibaud "thican" CANALE 2013-11-24 23:32:54 UTC
Same bugs, with blocked packages between eudev and udev, but I already have the kmod USE flag removed:

Calculating dependencies... done!
[nomerge       ] sys-fs/eudev-1.3  USE="modutils openrc rule-generator -doc -gudev -hwdb -introspection -keymap -kmod (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)"
[nomerge       ]  sys-fs/udev-init-scripts-26
[nomerge       ]   virtual/udev-208 [200] USE="-gudev -introspection -kmod (-selinux) -static-libs (-hwdb%) (-keymap%)" ABI_X86="(64%*) (-32) (-x32)"
[nomerge       ]    sys-fs/udev-208  USE="acl firmware-loader openrc -doc -gudev -introspection -kmod (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)"
[ebuild  N     ]     sys-apps/hwids-20130915.1  USE="udev" 1,535 kB
[ebuild     U  ]      virtual/udev-208 [200] USE="-gudev -introspection -kmod (-selinux) -static-libs (-hwdb%) (-keymap%)" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ]       sys-fs/udev-208  USE="acl firmware-loader openrc -doc -gudev -introspection -kmod (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 2,328 kB
[ebuild  N     ]        dev-util/gperf-3.0.4  961 kB
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.3)


  (sys-fs/eudev-1.3::gentoo, installed) pulled in by
    sys-fs/eudev required by @selected

  (sys-fs/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-208[abi_x86_64(-)]) required by (virtual/udev-208::gentoo, ebuild scheduled for merge)


Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.15-r3, 3.8.13-xxxx-grs-ipv6-64 x86_64)
=================================================================
System uname: Linux-3.8.13-xxxx-grs-ipv6-64-x86_64-Intel-R-_Core-TM-_i5-2300_CPU_@_2.80GHz-with-gentoo-2.2
KiB Mem:    16332808 total,    382784 free
KiB Swap:   16777212 total,  16759532 free
Timestamp of tree: Sun, 24 Nov 2013 16:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.ovh.net/gentoo-distfiles/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="a52 aac aalib acl acpi adns amd64 apache2 apm apng areas arts audiofile bash bash-completion bidi bzip2 cairo calendar caps cdda cddb cdio cdparanoia cdr cli cracklib crypt css cxx dri dts dvd dvdr encode exif ffmpeg flac fortran freetype ftp gbdm gcrypt gd gdbm geoip gif gimp gnutls gpg gstreamer httpd iconv idn ipv6 javascript jpeg ldap ldap-sasl lilo lm_sensors lua lzma mad markdown matroska mbox mdbox midi mmx modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl odbc ogg oggvorbis openal openmp openssl openvpn pam pcre pdf pdo perl php pmu png pygments python python3 readline sasl sdl session sql sse sse2 ssh ssl stream suid svg syslog tcl tcpd theora threads tiff unicode vcd videos vim-syntax vorbis xcb xml xv xvid xvmc zip zlib zsh zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="3.3 2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Ben Kohler gentoo-dev 2013-11-25 03:38:45 UTC

*** This bug has been marked as a duplicate of bug 492446 ***