Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490730 - =net-im/pidgin-2.10.7 crashed after ignoring a buddy in purple_buddy_get_group at blist.c:2639
Summary: =net-im/pidgin-2.10.7 crashed after ignoring a buddy in purple_buddy_get_grou...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-08 06:34 UTC by Raymond Jennings
Modified: 2019-04-20 10:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
backtrace from gdb (crashlog,6.70 KB, text/plain)
2013-11-08 06:34 UTC, Raymond Jennings
Details
emerge --info (einfo.txt,5.06 KB, text/plain)
2013-11-08 06:35 UTC, Raymond Jennings
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Jennings 2013-11-08 06:34:10 UTC
I ignored someone and...suddenly pidgin stopped.  No bug buddy prompt either but I did find a fresh core file in my homedir.

The dialog prompting to verify I awnted to remove a buddy stayed after clicking once.  Clicking OK twice crashed the program.

Reproducible: Always

Steps to Reproduce:
1.  ignore a spammer who you just added as your buddy
2.
3.
Actual Results:  
dialog would go away after the first click

Expected Results:  
dialog ignored the first click, whole program crashed on the second click
Comment 1 Raymond Jennings 2013-11-08 06:34:50 UTC
Created attachment 362774 [details]
backtrace from gdb
Comment 2 Raymond Jennings 2013-11-08 06:35:25 UTC
Created attachment 362776 [details]
emerge --info
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-11-12 23:44:42 UTC
Looks like it can't obtain the group the buddy is in.

Which version of Pidgin is this?
Comment 4 Raymond Jennings 2013-11-12 23:51:24 UTC
Pidgin 2.10.7 (libpurple 2.10.7)
Comment 5 Manuel Rüger (RETIRED) gentoo-dev 2015-06-01 11:08:14 UTC
Pidgin-2.10.7 has been removed from the tree a while ago.
Please report back if it still happens with recent versions of pidgin.