Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490726 - app-office/libreoffice-l10n-4.1.2.3 LINGUAS="(as|de|st)" - SRC_URI not found (404)
Summary: app-office/libreoffice-l10n-4.1.2.3 LINGUAS="(as|de|st)" - SRC_URI not found ...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-08 01:34 UTC by Malte Starostik
Modified: 2013-12-27 14:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
A small ebuild fix (libreoffice-l10n-4.1.3.2.ebuild,2.98 KB, text/plain)
2013-11-27 19:37 UTC, Hongjiu Zhang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Malte Starostik 2013-11-08 01:34:18 UTC
Package is trying to download http://download.documentfoundation.org/libreoffice/testing/4.1.2/rpm/x86/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz which doesn't exist.  Manually selecting 4.1.2 on the LO download site suggests that URL should be http://download.documentfoundation.org/libreoffice/stable/4.1.2/rpm/x86_64/LibreOffice_4.1.2_Linux_x86-64_rpm_langpack_de.tar.gz instead.  Or what about the patch level?  Anyway, current URL is broken.

As mentioned in $SUBJECT, I noticed this with linguas_de, just checked with fr and it to make sure: same problem.

$ emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.15-r3, 3.10.17-gentoo-stellaware x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-stellaware-x86_64-AMD_Phenom-tm-_II_N830_Triple-Core_Processor-with-gentoo-2.2
KiB Mem:     3789696 total,   1198384 free
KiB Swap:    8388604 total,   7938324 free
Timestamp of tree: Fri, 08 Nov 2013 00:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo crossdev bircoph celestilay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x skype-4.0.0.7-copyright TeamViewer PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs --load-average=3.0"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/crossdev /var/lib/layman/bircoph /var/lib/layman/celestilay"
USE="X a52 aac aalib acl acpi aften alsa amd64 amr avahi berkdb bluetooth branding bzip2 cairo calendar caps cdda cdr cli cracklib crypt cups curl cxx dbus declarative device-mapper dga djvu dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran gdbm geoip gif gimp git gpm iconv icu inotify ipv6 jack java jpeg jpeg2k kde kerberos kipi lame lcms ldap libnotify libsamplerate lm_sensors lzma mad matroska mikmod mmx mng modules mp3 mp4 mpeg mtp mudflap multilib ncurses nls nptl ntfs ogg openal openexr opengl openmp oscar pam pam_krb5 pango pcre pdf perl phonon plasma png policykit postgres ppds python qt3support qt4 quicktime readline samba sasl scanner schroedinger sdl semantic-desktop session smp sndfile snmp speex spell sqlite sse sse2 ssl startup-notification svg system-ffmpeg systemd tcpd telepathy theora threads tiff truetype udev udisks unicode upower usb v4l vcd video vim-syntax vorbis vpx webkit wxwidgets x264 xattr xcb xcomposite xine xinerama xml xmp xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" CELESTILAY_MODULES="kernel" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


Build log:
>>> Downloading 'http://de-mirror.org/distro/gentoo/distfiles/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz'
--2013-11-08 02:19:40--  http://de-mirror.org/distro/gentoo/distfiles/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz
Resolving de-mirror.org... 195.20.242.90, 2001:8d8:580:400::c314:f25a
Connecting to de-mirror.org|195.20.242.90|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-08 02:19:40 ERROR 404: Not Found.

>>> Downloading 'http://download.documentfoundation.org/libreoffice/testing/4.1.2/rpm/x86/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz'
--2013-11-08 02:19:40--  http://download.documentfoundation.org/libreoffice/testing/4.1.2/rpm/x86/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz
Resolving download.documentfoundation.org... 5.9.148.85, 2a01:4f8:190:3144::2
Connecting to download.documentfoundation.org|5.9.148.85|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-08 02:19:40 ERROR 404: Not Found.

!!! Couldn't download 'LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz'. Aborting.
 * Fetch failed for 'app-office/libreoffice-l10n-4.1.2.3', Log file:
 *  '/var/log/portage/app-office:libreoffice-l10n-4.1.2.3:20131108-011940.log'
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-15 16:43:41 UTC
LINGUAS=de ebuild libreoffice-l10n-4.1.2.3.ebuild fetch
Appending /newaches/gentoo/cvs/gentoo-x86 to PORTDIR_OVERLAY...
>>> Downloading 'http://download.documentfoundation.org/libreoffice/testing/4.1.2/rpm/x86/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz'
--2013-11-15 17:43:26--  http://download.documentfoundation.org/libreoffice/testing/4.1.2/rpm/x86/LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz
Resolving download.documentfoundation.org (download.documentfoundation.org)... 5.9.148.85, 2a01:4f8:190:3144::2
Connecting to download.documentfoundation.org (download.documentfoundation.org)|5.9.148.85|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-15 17:43:26 ERROR 404: Not Found.
!!! Couldn't download 'LibreOffice_4.1.2.3_Linux_x86_rpm_langpack_de.tar.gz'. Aborting.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-20 05:16:09 UTC
*** Bug 491728 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-20 05:17:11 UTC
# LINGUAS="as" ebuild libreoffice-l10n-4.1.3.2.ebuild fetch
Appending /newaches/gentoo/cvs/gentoo-x86 to PORTDIR_OVERLAY...
>>> Downloading 'http://download.documentfoundation.org/libreoffice/testing/4.1.3/rpm/x86/LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_as.tar.gz'
--2013-11-20 06:15:50--  http://download.documentfoundation.org/libreoffice/testing/4.1.3/rpm/x86/LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_as.tar.gz
Resolving download.documentfoundation.org (download.documentfoundation.org)... 5.9.148.85, 2a01:4f8:190:3144::2
Connecting to download.documentfoundation.org (download.documentfoundation.org)|5.9.148.85|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-20 06:15:50 ERROR 404: Not Found.
!!! Couldn't download 'LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_as.tar.gz'. Aborting.
# LINGUAS="st" ebuild libreoffice-l10n-4.1.3.2.ebuild fetch
Appending /newaches/gentoo/cvs/gentoo-x86 to PORTDIR_OVERLAY...
>>> Downloading 'http://download.documentfoundation.org/libreoffice/testing/4.1.3/rpm/x86/LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_st.tar.gz'
--2013-11-20 06:15:58--  http://download.documentfoundation.org/libreoffice/testing/4.1.3/rpm/x86/LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_st.tar.gz
Resolving download.documentfoundation.org (download.documentfoundation.org)... 5.9.148.85, 2a01:4f8:190:3144::2
Connecting to download.documentfoundation.org (download.documentfoundation.org)|5.9.148.85|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-20 06:15:58 ERROR 404: Not Found.
!!! Couldn't download 'LibreOffice_4.1.3.2_Linux_x86_rpm_langpack_st.tar.gz'. Aborting.
Comment 4 Hongjiu Zhang 2013-11-27 19:37:28 UTC
Created attachment 364094 [details]
A small ebuild fix

A small fix. Add space before and after ${lang} and ${helplang}, and do the same to the pattern after =~ so that no substring is accepted.
Comment 5 Malte Starostik 2013-11-28 14:41:39 UTC
Oh well, after running into a similar issue, https://bugs.gentoo.org/show_bug.cgi?id=492780#c1 shows the solution.  Apparently I've been deploying my boxes with a wrong mirror path for some time (ouch).  While the upstream URI is indeed broken, a correclty configured mirror comes to rescue with this one, too.  No idea what's the policy on such cases: does the package need to be fixed to carry a working SRC_URI?  Otherwise this bug can be closed while I go get a brown paper bag with an up to date mirror list printed on.
Comment 6 Hongjiu Zhang 2013-11-29 08:12:23 UTC
Oh, then we actually have different bugs. :)
Comment 7 Hongjiu Zhang 2013-12-11 23:27:37 UTC
Excuse me, is it okay to include this fix in Portage tree? I see no progress here. This fixes as and st part. The fix is explained in the #491728.
Comment 8 Andreas K. Hüttel gentoo-dev 2013-12-27 14:33:18 UTC
Sorry, we don't have control over the original SRC_URI. Please use a valid mirror. If this happens more often we'll have to come up with a solution though.