Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490674 - x11-terms/rxvt-unicode-9.19 does not build with <perl-core/ExtUtils-ParseXS-3.180.0
Summary: x11-terms/rxvt-unicode-9.19 does not build with <perl-core/ExtUtils-ParseXS-3...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-07 10:04 UTC by Vasilis Lourdas
Modified: 2013-11-08 15:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasilis Lourdas 2013-11-07 10:04:40 UTC
rxvt-unicode-9.19 does not build with perl-core/ExtUtils-ParseXS-2.22.05, I think the ebuild must be updated to reflect that.

The error I get when building with perl-core/ExtUtils-ParseXS-2.22.05 is:

x86_64-pc-linux-gnu-g++ -I.. -I. -I. -I./../libev -I./../libptytty/src -DHAVE_CONFIG_H -I/usr/include/freetype2  -I/usr/include/freetype2  -O2 -pipe -march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2 -w -I/usr/include/startup-notification-1.0  -c ptytty_wrapper.C
PERL="perl" perl /usr/bin/xsubpp -C++ -typemap /usr/lib64/perl5/5.16.1/ExtUtils/typemap -typemap typemap.iom -typemap typemap -prototypes ./rxvtperl.xs >rxvtperl.C
perl -MExtUtils::Embed -e xsinit -- -std urxvt
x86_64-pc-linux-gnu-g++ -I.. -I. -I. -I./../libev -I./../libptytty/src -DHAVE_CONFIG_H -I/usr/include/freetype2  -I/usr/include/freetype2  -O2 -pipe -march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2 -w -I/usr/include/startup-notification-1.0  -c rxvtd.C
Failed to load or import from ExtUtils::ParseXS (version 2.2205). Please check that ExtUtils::ParseXS is installed correctly and that the newest version will be found in your @INC path: "report_error_count" is not exported by the ExtUtils::ParseXS module
Can't continue after import errors at /usr/bin/xsubpp line 9.
make[1]: *** [rxvtperl.C] Error 255
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/x11-terms/rxvt-unicode-9.19/work/rxvt-unicode-9.19/src'
make: *** [all] Error 1
 * ERROR: x11-terms/rxvt-unicode-9.19::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-terms/rxvt-unicode-9.19::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-terms/rxvt-unicode-9.19::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-terms/rxvt-unicode-9.19/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-terms/rxvt-unicode-9.19/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-terms/rxvt-unicode-9.19/work/rxvt-unicode-9.19'
 * S: '/var/tmp/portage/x11-terms/rxvt-unicode-9.19/work/rxvt-unicode-9.19'


With perl-core/ExtUtils-ParseXS-3.180.0 it builds fine.
Comment 1 Jeroen Roovers gentoo-dev 2013-11-08 15:34:48 UTC
Works fine here so I assume you forgot to run perl-cleaner after a dev-lang/perl upgrade.

*** This bug has been marked as a duplicate of bug 41124 ***