Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490346 - nvidia-drivers-331.17 fails to compile
Summary: nvidia-drivers-331.17 fails to compile
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-04 05:23 UTC by Dale Lukas Peterson
Modified: 2013-11-05 15:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log showing the error (build.log,146.68 KB, text/x-log)
2013-11-04 05:25 UTC, Dale Lukas Peterson
Details
output of emerge --info '=x11-drivers/nvidia-drivers-331.17::gentoo' (info.txt,5.11 KB, text/plain)
2013-11-04 05:27 UTC, Dale Lukas Peterson
Details
output of emerge -pqv '=x11-drivers/nvidia-drivers-331.17::gentoo' (more_info.txt,102 bytes, text/plain)
2013-11-04 05:29 UTC, Dale Lukas Peterson
Details
fix compile error with kernel >= 3.11.0 (kernel-3.11.patch,495 bytes, patch)
2013-11-04 05:54 UTC, Alex Efros
Details | Diff
patch for 325.15.ebuild (nvidia-drivers-325.15.ebuild.patch,468 bytes, patch)
2013-11-04 05:55 UTC, Alex Efros
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Lukas Peterson 2013-11-04 05:23:37 UTC
See attached build.log

Reproducible: Always
Comment 1 Dale Lukas Peterson 2013-11-04 05:25:47 UTC
Created attachment 362536 [details]
build log showing the error
Comment 2 Dale Lukas Peterson 2013-11-04 05:27:49 UTC
Created attachment 362538 [details]
output of emerge --info '=x11-drivers/nvidia-drivers-331.17::gentoo'
Comment 3 Dale Lukas Peterson 2013-11-04 05:29:22 UTC
Created attachment 362540 [details]
output of emerge -pqv '=x11-drivers/nvidia-drivers-331.17::gentoo'
Comment 4 Alex Efros 2013-11-04 05:52:45 UTC
This is known issue with kernels >= 3.11.0. I'll attach patch which works for me on 319.60 and 325.15.
Comment 5 Alex Efros 2013-11-04 05:54:00 UTC
Created attachment 362542 [details, diff]
fix compile error with kernel >= 3.11.0
Comment 6 Alex Efros 2013-11-04 05:55:41 UTC
Created attachment 362544 [details, diff]
patch for 325.15.ebuild
Comment 7 Rafał Mużyło 2013-11-04 07:40:09 UTC
(In reply to Alex Efros from comment #5)
> Created attachment 362542 [details, diff] [details, diff]
> fix compile error with kernel >= 3.11.0

Going by https://devtalk.nvidia.com/default/topic/628864/unix-graphics-announcements-and-news/num_physpages-and-support-for-3-11-and-later-kernels/

this patch is plain wrong.
Comment 8 Rafał Mużyło 2013-11-04 07:47:37 UTC
...or at least incomplete. I wonder though how will the upstream's real fix will look like.
Comment 9 Dale Lukas Peterson 2013-11-04 22:39:33 UTC
This bug is for nvidia-drivers-331.17 not 319.60 or 32.15.  Have you tested your patch with 331.17?
Comment 10 Jeroen Roovers gentoo-dev 2013-11-05 15:52:11 UTC

*** This bug has been marked as a duplicate of bug 447566 ***