Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 490114 - Please stabilize app-office/libreoffice-4.1.3.2-r2 and friends
Summary: Please stabilize app-office/libreoffice-4.1.3.2-r2 and friends
Status: RESOLVED DUPLICATE of bug 500622
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 486204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-02 10:27 UTC by Andreas K. Hüttel
Modified: 2014-02-07 15:14 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2013-11-02 10:27:03 UTC
Please test thoroughly (also by running it, I cannot really do that well) and then if all goes well stabilize 

app-office/libreoffice-bin-4.1.3.2
app-office/libreoffice-bin-debug-4.1.3.2

This is mostly a -bin update built against newer poppler (see bug 489720) and icu (see bug 486948), but we used the opportunity to increase the bugfix level as well.

Target: amd64 x86
Comment 1 Toralf Förster gentoo-dev 2013-11-05 19:30:20 UTC
With "media-libs/libpng  ~x86" in /etc/portage/package.accept_keywords/misc I do get now always :



...
 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-libs/libpng-1.5.15
 *  - /usr/lib/libpng15.so.15
 *      used by /usr/lib/libreoffice/program/oosplash (app-office/libreoffice-bin-4.1.3.2)
Use emerge @preserved-rebuild to rebuild packages using these libraries



Adding "/usr/lib/libreoffice/program/oosplash" to /etc/revdep-rebuild/50-libreoffice-bin seems to help - or do I miss soemthing else ?
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2013-11-06 09:40:02 UTC
Seriously, if you use libpng16 no suprise it is broken when it was built against libpng15...
Comment 3 Toralf Förster gentoo-dev 2013-11-06 20:24:51 UTC
(In reply to Tomáš Chvátal from comment #2)
> Seriously, if you use libpng16 no suprise it is broken when it was built
> against libpng15...

But I do have it too :

tfoerste@n22 ~ $ ll /usr/lib/libpng15*
-rwxr-xr-x 1 root root 194296 Nov  6 17:03 /usr/lib/libpng15.so.15

tfoerste@n22 ~ $ eix -I libpng
[I] media-libs/libpng
     Available versions:
     (1.2)  1.2.50 (~)1.2.50-r1
     (0)    1.5.15 (~)1.5.17-r1 (~)1.6.6(0/16)
     (1.5)  (~)1.5.17-r15
       {apng neon static-libs ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
     Installed versions:  1.5.17-r15(1.5)(05:03:33 PM 11/06/2013)(apng -neon) 1.6.6(08:40:45 PM 11/04/2013)(apng -neon -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_X86="32 -64 -x32")
     Homepage:            http://www.libpng.org/
     Description:         Portable Network Graphics library
Comment 4 Andreas K. Hüttel gentoo-dev 2013-11-06 21:25:07 UTC
(In reply to Toralf Förster from comment #3)
> (In reply to Tomáš Chvátal from comment #2)
> > Seriously, if you use libpng16 no suprise it is broken when it was built
> > against libpng15...
> 
> But I do have it too :
> 
> tfoerste@n22 ~ $ ll /usr/lib/libpng15*
> -rwxr-xr-x 1 root root 194296 Nov  6 17:03 /usr/lib/libpng15.so.15

Guess why it's called "preserved"-rebuild... the library is preserved because it is needed. Anyway, please take this elsewhere, it's not relevant for this bug. 

(In addition, you can always install libpng-1.5.17 (which is slotted and can be present in parallel to 1.6).)
Comment 5 Elijah "Armageddon" El Lazkani (amd64 AT) 2013-11-19 05:10:29 UTC
I've been trying to test app-office/libreoffice-bin-debug-4.1.3.2 for a couple of days, I'm getting file mismatch. Can anyone please confirm ?
Comment 6 Andreas K. Hüttel gentoo-dev 2013-11-19 13:54:49 UTC
Debug info package.masked for now. Uploading the 12G distfiles made our mirror master explode, which may have caused some corruption / truncation.

Please stabilize only the real binpackage, 

=app-office/libreoffice-bin-4.1.3.2
Comment 7 Elijah "Armageddon" El Lazkani (amd64 AT) 2013-11-19 16:06:09 UTC
amd64: pass
Comment 8 Myckel Habets 2013-11-22 10:34:51 UTC
Sorry for taking so long. Builds and runs fine on x86. Rdeps build fine as well on x86. Please mark stable for x86.
Comment 9 Chema Alonso Josa (RETIRED) gentoo-dev 2013-11-27 10:49:07 UTC
Shouldn't be =app-office/libreoffice-l10n-4.1.3.2 stablized as well?

I get the following unstable deps:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-office/libreoffice-bin-4.1.3.2
# required by =app-office/libreoffice-bin-4.1.3.2 (argument)
=app-office/libreoffice-l10n-4.1.3.2 ~amd64
Comment 10 Matteo Modesti 2013-12-01 18:36:10 UTC
synced today and getting this conflict on amd64:


WARNING: One or more updates have been skipped due to a dependency conflict:

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) conflicts with
    =media-libs/harfbuzz-0.9.12 required by (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)


It's probably better if you fix this before stabilizing the package.
Comment 11 Matteo Modesti 2013-12-01 18:42:23 UTC
(In reply to Matteo Modesti from comment #10)
> synced today and getting this conflict on amd64:
> 
> 
> WARNING: One or more updates have been skipped due to a dependency conflict:
> 
> media-libs/harfbuzz:0
> 
>   (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) conflicts
> with
>     =media-libs/harfbuzz-0.9.12 required by
> (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)
> 
> 
> It's probably better if you fix this before stabilizing the package.

Just to be clear, I know that conflict regards 4.1.2.3 while this bug is about 4.1.3.2: I'm just telling you that since 4.1.3.2 too has that dependency, it's better to fix it now rather than later.
Comment 12 cazzantonio 2013-12-06 15:34:15 UTC
Dependency problems will arise again each time one of the following ebuild is updated:
	app-text/libexttextcat
	app-text/poppler
	dev-libs/boost
	dev-libs/icu
	media-gfx/graphite2
	media-libs/harfbuzz
	media-libs/libpng

Since it seems that updating at the same time the libreoffice build is impossible or too slow, and since stable users should not fight with such dependency problems, why not using the binary version distributed by upstream?

I know that a gentoo-custom-built binary with updated dependencies would be the best option, however sometimes better isn't equal to best. There are clearly problems keeping libreoffice-bin up-to-date with dependencies or there isn't enough manpower to properly maintain the package.
Comment 13 Andreas K. Hüttel gentoo-dev 2013-12-06 15:44:37 UTC
(In reply to cazzantonio from comment #12)
> Dependency problems will arise again each time one of the following ebuild
> is updated:
> 	app-text/libexttextcat
> 	app-text/poppler
> 	dev-libs/boost
> 	dev-libs/icu
> 	media-gfx/graphite2
> 	media-libs/harfbuzz
> 	media-libs/libpng
> 
> Since it seems that updating at the same time the libreoffice build is
> impossible or too slow, and since stable users should not fight with such
> dependency problems, why not using the binary version distributed by
> upstream?
> 
> I know that a gentoo-custom-built binary with updated dependencies would be
> the best option, however sometimes better isn't equal to best. There are
> clearly problems keeping libreoffice-bin up-to-date with dependencies or
> there isn't enough manpower to properly maintain the package.

Welll. We just invested time and effort to be able to re-make the binaries fast. If it then gets stuck with the arch teams for 1.5 months, something's wrong...

As a side note, we're adding the rest of the ebuilds here now.
Comment 14 Andreas K. Hüttel gentoo-dev 2013-12-06 15:48:20 UTC
Extending this to the whole set of packages.

Please test and stabilize 

amd64, ppc, x86:
app-office/libreoffice-4.1.3.2
app-office/libreoffice-l10n-4.1.3.2

amd64, x86:
app-office/libreoffice-bin-4.1.3.2
app-office/libreoffice-bin-debug-4.1.3.2
Comment 15 Reimundo Heluani 2013-12-09 08:24:02 UTC
(In reply to Matteo Modesti from comment #10)
> synced today and getting this conflict on amd64:
> 
> 
> WARNING: One or more updates have been skipped due to a dependency conflict:
> 
> media-libs/harfbuzz:0
> 
>   (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge) conflicts
> with
>     =media-libs/harfbuzz-0.9.12 required by
> (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)
> 
> 
> It's probably better if you fix this before stabilizing the package.

Still today on a stable amd64 with just built stable gnome I get when trying to emerge stable app-office/libreoffice-bin-4.1.2.3:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.24.3::gentoo, installed) pulled in by
    app-text/poppler:0/43=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.36-r1::gentoo, installed)
    app-text/poppler:0/43=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    >=app-text/poppler-0.20:0/43=[cairo] required by (app-text/evince-3.8.3::gentoo, installed)
    (and 2 more with the same problems)

  (app-text/poppler-0.22.5::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler:0/37 required by (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/51.1 required by (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)

  (dev-libs/icu-51.2-r1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.2= required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/icu-4:0/51.2= required by (app-misc/tracker-0.16.4::gentoo, installed)
    dev-libs/icu:0/51.2= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    (and 1 more with the same problems)

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.23::gentoo, installed) pulled in by
    media-libs/harfbuzz:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)
    >=media-libs/harfbuzz-0.9.9:0/0.9.18=[glib(+),truetype(+)] required by (x11-libs/pango-1.34.1::gentoo, installed)

  (media-libs/harfbuzz-0.9.12::gentoo, ebuild scheduled for merge) pulled in by
    =media-libs/harfbuzz-0.9.12 required by (app-office/libreoffice-bin-4.1.2.3::gentoo, ebuild scheduled for merge)

I agree that stable users should not go through this. These conflicts also happen with ~amd64 app-office/libreoffice-bin-4.1.3.2
Comment 16 Andreas K. Hüttel gentoo-dev 2013-12-09 11:14:58 UTC
(In reply to Reimundo Heluani from comment #15)
> Still today on a stable amd64 with just built stable gnome I get when trying
> to emerge stable app-office/libreoffice-bin-4.1.2.3:
> 
> !!! Multiple package instances within a single package slot have been pulled
> !!! into the dependency graph, resulting in a slot conflict:
> 
> app-text/poppler:0
> dev-libs/icu:0

These two are fixed once the stabilization goes through.

> media-libs/harfbuzz:0

This one is new and will still affect stable users. The package is already being rebuilt, and I'll upload a binary package app-office/libreoffice-bin-4.1.3.2-r1 soon. However, if stabilization again takes a month the whole process is kind of pointless and we can as well drop libreoffice-bin entirely (or alternatively remove it from the scope of the arch teams).
Comment 17 Pacho Ramos gentoo-dev 2013-12-09 12:18:26 UTC
(In reply to Andreas K. Hüttel from comment #16)
[...]
> This one is new and will still affect stable users. The package is already
> being rebuilt, and I'll upload a binary package
> app-office/libreoffice-bin-4.1.3.2-r1 soon. However, if stabilization again
> takes a month the whole process is kind of pointless and we can as well drop
> libreoffice-bin entirely (or alternatively remove it from the scope of the
> arch teams).

On what arches are you able to test it? Maybe you could stabilize it, at least, for the arch you are able to test it (since looks like Ago is not able to make so much work as was doing some time ago, I guess this is the way to go currently with our manpower :( ) (I run plain "libreoffice" on the system I use for development :/)
Comment 18 Andreas K. Hüttel gentoo-dev 2013-12-12 18:34:40 UTC
(In reply to Pacho Ramos from comment #17)
> (In reply to Andreas K. Hüttel from comment #16)
> [...]
> > This one is new and will still affect stable users. The package is already
> > being rebuilt, and I'll upload a binary package
> > app-office/libreoffice-bin-4.1.3.2-r1 soon. However, if stabilization again
> > takes a month the whole process is kind of pointless and we can as well drop
> > libreoffice-bin entirely (or alternatively remove it from the scope of the
> > arch teams).
> 
> On what arches are you able to test it? Maybe you could stabilize it, at
> least, for the arch you are able to test it (since looks like Ago is not
> able to make so much work as was doing some time ago, I guess this is the
> way to go currently with our manpower :( ) (I run plain "libreoffice" on the
> system I use for development :/)

I test and run the source version myself, but I cannot test the binary packages at all (since all my boxes are mixed arch/~arch). What we could do is something like I stabilize libreoffice-* myself here once all problems have been addressed and there's an OK from, say, two official archtesters.... what do you think?
Comment 19 Andreas K. Hüttel gentoo-dev 2013-12-12 23:52:48 UTC
Sorry for providing such a moving target... New list.

Please test and stabilize

amd64, ppc, x86:
app-office/libreoffice-4.1.3.2-r2
app-office/libreoffice-l10n-4.1.3.2

amd64, x86:
app-office/libreoffice-bin-4.1.3.2-r2
app-office/libreoffice-bin-debug-4.1.3.2-r2


The only changes are:
* 2 serious crash fixes for KDE/Qt backported (bug 489656 and bug 489988)
* bin rebuilt against new stable harfbuzz
Comment 20 Pacho Ramos gentoo-dev 2013-12-15 13:51:38 UTC
amd64 stable
Comment 21 Andrey Aleksandrovich 2013-12-16 19:14:54 UTC
Please, could you add the app-officeext/languagetool to $LIBREOFFICE_EXTENSIONS variables in ebuild.
So, we could install languagetool by dependency.
Comment 22 Andreas K. Hüttel gentoo-dev 2013-12-17 17:25:38 UTC
  17 Dec 2013; Andreas K. Huettel <dilfridge@gentoo.org>
  libreoffice-bin-4.1.3.2-r2.ebuild:
  stable on x86 based on testing by AT Myckel Habets, bug 490114

Since this is blocking a security bug (and has been for ages). Now sue me.
Comment 23 Hongjiu Zhang 2013-12-23 08:18:54 UTC
Sorry to disturb you guys here. Is anyone interested to deal with #490726 before you stabilise it? While enabling offlinehelp, ebuild would think there are offlinehelp files for linguas_as and linguas_st users since linguas_ast is in the offlinehelp list. A small fix is provided and need you check. Thank you.
Comment 24 Manfred Knick 2014-01-05 12:50:58 UTC
checking the Perl version... checked (perl 5)
checking for required Perl modules... Can't locate Archive/Zip.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at -e line 1.


cd /usr/lib64/perl5

find . -name Zip.pm
./5.16.3/IO/Compress/Zip.pm                      <-----
./vendor_perl/5.12.4/Archive/Zip.pm
./vendor_perl/5.12.4/IO/Compress/Zip.pm

perl -e 'use Archive::Zip'
Can't locate Archive/Zip.pm in @INC ...

perl -e 'use IO::Compress::Zip'                  <----- succeeds
Comment 25 Manfred Knick 2014-01-05 12:54:20 UTC
(ADDENDUM to comment #24)

GENTOO_VM=icedtea-bin-7  CLASSPATH="" JAVA_HOME="/opt/icedtea-bin-7.2.4.3"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""


# emerge --info =libreoffice-4.1.3.2
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.12.6 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.12.6-x86_64-Intel-R-_Xeon-R-_CPU_E3-1275_v3_@_3.50GHz-with-gentoo-2.2
KiB Mem:    32626160 total,  27664536 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 05 Jan 2014 03:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo mkn_local_overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/local-overlay"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X acl alsa amd64 avx avx2 berkdb bzip2 cli cracklib crypt cxx dbus dri dv dvb dvd encode ffmpeg fortran gdbm iconv ipv6 jpeg mad mms mmx modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg openmp pam pcre png readline session sna sse sse2 sse3 sse4.1 sse4.2 ssl ssse3 tcpd tiff unicode v4l vorbis xfce xinerama xv zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="coreboot multiboot pc efi-64" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 26 Andreas K. Hüttel gentoo-dev 2014-01-05 13:15:05 UTC
(In reply to Manfred Knick from comment #24)
> checking the Perl version... checked (perl 5)
> checking for required Perl modules... Can't locate Archive/Zip.pm in @INC
> (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux
> /usr/local/lib64/perl5/5.16.3
> /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux
> /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5
> /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux
> /usr/lib64/perl5/5.16.3 .) at -e line 1.
> 
> 
> cd /usr/lib64/perl5
> 
> find . -name Zip.pm
> ./5.16.3/IO/Compress/Zip.pm                      <-----
> ./vendor_perl/5.12.4/Archive/Zip.pm
> ./vendor_perl/5.12.4/IO/Compress/Zip.pm
> 
> perl -e 'use Archive::Zip'
> Can't locate Archive/Zip.pm in @INC ...
> 
> perl -e 'use IO::Compress::Zip'                  <----- succeeds

You need to run perl-cleaner --all (read your emerge messages! :)
Comment 27 Andreas K. Hüttel gentoo-dev 2014-02-04 23:37:06 UTC
*** Bug 486204 has been marked as a duplicate of this bug. ***
Comment 28 Andreas K. Hüttel gentoo-dev 2014-02-07 15:14:25 UTC

*** This bug has been marked as a duplicate of bug 500622 ***