Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489332 - app-office/openerp-client-6.1 version bump
Summary: app-office/openerp-client-6.1 version bump
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2013-10-25 06:52 UTC by Christopher Head
Modified: 2015-02-19 05:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch from 5.0.15-r1 to 6.1 (openerp-client-6.1.ebuild.patch,911 bytes, patch)
2013-10-25 06:52 UTC, Christopher Head
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2013-10-25 06:52:42 UTC
Created attachment 361868 [details, diff]
Patch from 5.0.15-r1 to 6.1

My particular workplace uses OpenERP 6.1. app-office/openerp-client is only available in version 5. app-office/openerp doesn’t even install a client. Attached is a patch from current stable 5.0.15-r1 to 6.1; the download URL has changed, a couple more Python packages are needed, and the tarball is now distributed with an extra layer of directory structure that needs to be traversed in src_compile and src_install.
Comment 1 Yixun Lan gentoo-dev 2013-10-25 08:29:12 UTC
also see bug #458440, have you made this ebuild working with openerp-6.1?
Comment 2 Christopher Head 2013-10-26 04:06:23 UTC
(In reply to Dennis 'dlan' Lan from comment #1)
> also see bug #458440, have you made this ebuild working with openerp-6.1?

I’m not sure what 458440 has to do with this bug. As I said in the original comment, app-office/openerp does not install a client (even when the ebuild is fixed to work at all). This bug (489332) is about the client. I suppose the client built by this bug’s ebuild works with app-office/openerp-6.1; I don’t actually know because I don’t run my workplace’s OpenERP server. The server exists and is version 6.1, and therefore I need the 6.1 client, which is why I filed this bug.
Comment 3 Yixun Lan gentoo-dev 2013-10-28 05:04:05 UTC
(In reply to Christopher Head from comment #2)

oops, my bad, I thought 6.1.1 was not main tree, thus ask if it works with ebuild 6.1.1 (from bug #458440).

Actually, my question would be like this
1) is app-office/openerp-client-6.1 depend on openerp-6.1? (openerp-6.1 need to be installed), either via DEPEND or RDEPEND
2) app-office/openerp-client-6.1 probably not work with openerp-7.x or later? should it block later versions?

I may investigate this later when I have time..
Comment 4 Christopher Head 2013-10-29 04:39:59 UTC
(In reply to Dennis 'dlan' Lan from comment #3)
> (In reply to Christopher Head from comment #2)
> 
> oops, my bad, I thought 6.1.1 was not main tree, thus ask if it works with
> ebuild 6.1.1 (from bug #458440).
> 
> Actually, my question would be like this
> 1) is app-office/openerp-client-6.1 depend on openerp-6.1? (openerp-6.1 need
> to be installed), either via DEPEND or RDEPEND
> 2) app-office/openerp-client-6.1 probably not work with openerp-7.x or
> later? should it block later versions?
> 
> I may investigate this later when I have time..

openerp-client does not depend on openerp. The former is the client; the latter is the server. Certainly the server needs to be running somewhere, but that somewhere would usually not be on the same computer, possibly not even on the same operating system, so a dependency is inappropriate.

The client might work with a version 7 server, or it might not. Probably not; upstream recommends using matching versions AFAIK. However, for the same reason as above, a block isn’t appropriate: although it’s less likely, one could, in theory, want a version 6 client installed to connect to some remote v6 server elsewhere, while also running a version 7 server on the local computer, perhaps for testing purposes.
Comment 5 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-12-05 15:49:44 UTC
Closing the old report since the package is unmaintained and the new versions don't use openerp-client anymore. If you still feel like really needing this, please let me know and we'll see what we can do.
Comment 6 Christopher Head 2015-02-19 05:42:19 UTC
Right, the whole package is gone now.