Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489208 - app-emulation/virtualbox{,-modules} - Message "/etc/init.d/vboxdrv setup" from VirtualBox is a little misleading - RTR3InitEx failed with rc=-1912 (rc=-1912)
Summary: app-emulation/virtualbox{,-modules} - Message "/etc/init.d/vboxdrv setup" fro...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal trivial (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2013-10-23 23:49 UTC by Linlin Yan
Modified: 2022-06-29 06:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Linlin Yan 2013-10-23 23:49:29 UTC
After re-emerging (upgrading) VirtualBox, it prompts '/etc/init.d/vboxdrv setup' rather than 'emerge -1 virtualbox-modules' when starting an existed virtual machine.

Reproducible: Always
Comment 1 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2013-10-24 06:50:49 UTC
Which package is this? app-emulation/virtualbox or app-emulation/virtualbox-bin?

What exactly did you do to trigger this message?
Comment 2 Linlin Yan 2013-10-24 09:49:34 UTC
According to my /var/log/emerge.log:

1. I first installed virtualbox (on Sep 15) by the following command:
     # emerge --ask --verbose virtualbox
   which emerged 41 packages, including:

2. Then I started VirtualBox and created a virtual machine (and installed Windows).

3. After that, when I upgrade the whole system (on Oct 22) by the following command:
     # emerge --ask --update --verbose --newuse --with-bdeps=y --deep @world
   which upgraded above packages from 4.1.26 to 4.2.18.

4. When I tried to start my virtual machine again, it failed and suggested me to run "/etc/init.d/vboxdrv setup". However there is no file named '/etc/init.d/vboxdrv'.

5. It kept failed until I tried to re-emerge the app-emulation/virtualbox-modules.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-10-24 16:18:29 UTC
Please post the puzzling output in a comment, in its entirety.
Comment 4 Linlin Yan 2013-10-28 03:59:44 UTC
Thanks, Jeroen. Here goes the dialog message:

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/etc/init.d/vboxdrv setup'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.
Comment 5 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2013-10-28 09:34:16 UTC
please post the output of

  emerge -Oqpv virtualbox virtualbox-modules

to this bug.
Comment 6 Linlin Yan 2013-10-28 11:09:56 UTC
# emerge -Oqpv virtualbox virtualbox-modules
[ebuild   R   ] app-emulation/virtualbox-4.2.18  USE="additions alsa doc extensions opengl pam pulseaudio qt4 sdk -headless -java -python -vboxwebsrv -vnc" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 
[ebuild   R   ] app-emulation/virtualbox-modules-4.2.18  USE="-pax_kernel"
Comment 7 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2013-10-28 14:35:37 UTC
Did you unload the old virtualbox kernel modules and load the new ones?
The ebuild is not doing this for you.
Comment 8 Linlin Yan 2013-10-29 08:31:56 UTC
Yes, I probably did that (restarted my desktop and chose another kernel).

Actually, what I really want to report is that the message "/etc/init.d/vboxdrv setup" from VirtualBox is a little misleading in Gentoo system. That command works fine in other distro such as Ubuntu. However, Gentoo need another command "emerge -1 virtualbox-modules" to do the same thing (recompile the kernel modules).

This should be *trivial*, because it only occurs when kernel version changed or app-emulation/virtualbox updated (without app-emulation/virtualbox-modules re-emerged).

Sorry about the confusing for my bad expression.
Comment 9 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2013-10-29 14:42:00 UTC
Thanks. Now I know how to reproduce this. I gonna work on a patch soon.