Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489190 - media-gfx/ipe-7.2.7 version bump
Summary: media-gfx/ipe-7.2.7 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL: http://lists.science.uu.nl/pipermail/...
Whiteboard: removal on 2018-06-09
Keywords: PMASKED
Depends on:
Blocks: qt4-removal qt4-r2-removal
  Show dependency tree
 
Reported: 2013-10-23 21:23 UTC by Manuel Rüger (RETIRED)
Modified: 2018-06-08 20:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ipe-7.1.7.ebuild (ipe-7.1.7.ebuild,1.83 KB, text/plain)
2015-03-06 20:52 UTC, Guilherme Amadio
Details
media-gfx/ipe-7.2.7 (ipe-7.2.7.ebuild,1.90 KB, text/plain)
2018-05-11 11:44 UTC, Jimmy.Jazz
Details
ipe-7.2.7-xlocale.patch (ipe-7.2.7-xlocale.patch,299 bytes, patch)
2018-05-11 11:45 UTC, Jimmy.Jazz
Details | Diff
An alternative, simpler version of ipe-7.2.7.ebuild (ipe-7.2.7.ebuild,825 bytes, text/plain)
2018-05-11 13:31 UTC, Marek Szuba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rüger (RETIRED) gentoo-dev 2013-10-23 21:23:28 UTC
Ipe 7.1.4 (2013-3-15)

  * Windows binaries provided again.

  * Migrated to using Lua 5.2 (feature #113).

  * Fixed bug in "ipescript update-master" with several figures (bug
    #85).

  * Ipe scripts (to be run with "ipescript <script>") must no longer
    contain the 'require "ipe"' line.

  * Snap modes on Ipe-startup can now be specified in preferences
    (feature #122).

  * Customizing mouse move works as expected (without _G.mouse)
    (bug #123).
Comment 3 Justin Lecher gentoo-dev 2015-01-05 09:20:28 UTC
Needs lua-5.2 which is currently masked


ompiling ipebase.cpp...
x86_64-pc-linux-gnu-g++ -march=native -mtune=native -O2 -pipe -frecord-gcc-switches -fdiagnostics-color=always -Wall -g -O2 -fPIC -DIPEUI_QT -I../include   -DIPEFONTMAP=\"/usr/share/ipe/7.1.6/fontmap.xml\"      -c -o ../../build/obj/ipelib/ipebase.o ipebase.cpp
ipeui_common.cpp: In member function ‘void Dialog::setListItems(lua_State*, int, Dialog::SElement&)’:
ipeui_common.cpp:326:31: error: ‘lua_rawlen’ was not declared in this scope
   int no = lua_rawlen(L, index);
                               ^
ipeui_common.cpp: In function ‘void make_metatable(lua_State*, const char*, const luaL_Reg*)’:
ipeui_common.cpp:745:30: error: ‘luaL_setfuncs’ was not declared in this scope
   luaL_setfuncs(L, methods, 0);
                              ^
../common.mak:210: recipe for target '../../build/obj/ipeui/ipeui_common.o' failed
make[1]: *** [../../build/obj/ipeui/ipeui_common.o] Error 1
Comment 5 Guilherme Amadio gentoo-dev 2015-03-06 20:52:24 UTC
Created attachment 398260 [details]
ipe-7.1.7.ebuild

Here is an ebuild, but media-gfx/ipe-7.1.7 depends on masked dev-lang/lua:5.2, so I'll wait for other dev's opinions before pushing this to the tree.
Comment 6 Rok Kralj 2015-12-24 10:30:15 UTC
Ipe has since migrated to Qt5.

The new version is 7.1.10.
Comment 7 Rok Kralj 2015-12-24 10:32:43 UTC
Also, is the dependency to lua a hard one?

Could we utilize the "lua" USE flag here?
Comment 8 Jonas Jelten 2016-01-28 16:16:30 UTC
Current version is Ipe 7.2.2, please bump it :)
Comment 9 Andreas Sturmlechner gentoo-dev 2018-04-05 21:45:42 UTC
Current versions in Gentoo ebuild repository are now several years old. If no one is going to bump this package, maybe we will have to last-rite it.
Comment 10 Larry the Git Cow gentoo-dev 2018-05-10 09:06:11 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1257c4eaf4fb5f39a6e0ea86a1bf84403f1943ba

commit 1257c4eaf4fb5f39a6e0ea86a1bf84403f1943ba
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-05-10 08:59:04 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-05-10 09:05:16 +0000

    profiles: Mask media-gfx/ipe for removal
    
    Bug: https://bugs.gentoo.org/489190

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 11 Jimmy.Jazz 2018-05-11 11:44:36 UTC
Created attachment 530800 [details]
media-gfx/ipe-7.2.7
Comment 12 Jimmy.Jazz 2018-05-11 11:45:45 UTC
Created attachment 530802 [details, diff]
ipe-7.2.7-xlocale.patch
Comment 13 Marek Szuba gentoo-dev 2018-05-11 13:31:56 UTC
Created attachment 530808 [details]
An alternative, simpler version of ipe-7.2.7.ebuild

Here is a simpler version of an ebuild for ipe-7.2.7, which as it turns out I was working on in parallel with Jimmy. It builds without problems on my test amd64 system (starting with a clean stage 3), suggesting quite a lot of things the old ebuilds contained are no longer necessary. It is by no means complete, for instance docs end up in the wrong place, but at this point it is meant as a proof of concept.

The main question is, do we WANT to add an ebuild to the tree which depends on masked versions of dev-lang/lua?
Comment 14 Larry the Git Cow gentoo-dev 2018-06-08 20:55:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c1eef1189009ca7d03eec13ee0dc62558c5dad14

commit c1eef1189009ca7d03eec13ee0dc62558c5dad14
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-06-02 11:28:07 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-06-08 20:55:09 +0000

    media-gfx/ipe: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/489190
    Closes: https://bugs.gentoo.org/648666

 media-gfx/ipe/Manifest                   |  2 -
 media-gfx/ipe/files/ipe-7.1.3-gold.patch | 30 ------------
 media-gfx/ipe/ipe-7.1.2.ebuild           | 77 ------------------------------
 media-gfx/ipe/ipe-7.1.3.ebuild           | 80 --------------------------------
 media-gfx/ipe/metadata.xml               | 17 -------
 profiles/package.mask                    |  5 --
 6 files changed, 211 deletions(-)