Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 489164 - x11-drivers/nvidia-drivers-319.49: error: ‘num_physpages’ undeclared (first use in this function)
Summary: x11-drivers/nvidia-drivers-319.49: error: ‘num_physpages’ undeclared (first u...
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Hardened (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: The Gentoo Linux Hardened Team
URL: https://devtalk.nvidia.com/default/to...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-23 15:04 UTC by Faust
Modified: 2013-10-24 22:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch (nvidia-drivers-physpages.patch,861 bytes, patch)
2013-10-23 15:05 UTC, Faust
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Faust 2013-10-23 15:04:24 UTC
If you are using linux >= 3.11 nvidia-drivers will fail compilation.
I had this problem with sys-kernel/hardened-sources-3.11.2.
The attached patch solves the problem for me.

Reproducible: Always
Comment 1 Faust 2013-10-23 15:05:00 UTC
Created attachment 361730 [details, diff]
Patch
Comment 2 Faust 2013-10-24 06:31:04 UTC
Please note that, to reproduce this bug, you should probably fix #482784 first.
Comment 3 Faust 2013-10-24 06:38:55 UTC
This bug is present also in x11-drivers/nvidia-drivers-319.60 and, probably, in other version.
Comment 4 Jaak Ristioja 2013-10-24 08:02:00 UTC
(In reply to Faust from comment #3)
> This bug is present also in x11-drivers/nvidia-drivers-319.60 and, probably,
> in other version.

I can confirm this with sys-kernel/gentoo-sources-3.11.6 and x11-drivers/nvidia-drivers-331.17. I also confirm that the aforementioned patch fixes merge of x11-drivers/nvidia-drivers-331.17.
Comment 5 Justin Lecher gentoo-dev 2013-10-24 16:10:03 UTC
I also see this with non hardened sources.
Comment 6 Jeroen Roovers gentoo-dev 2013-10-24 16:20:06 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 7 Faust 2013-10-24 22:57:57 UTC
May I ask why this bug was marked as duplicate of a bug marked as won't fix?
I didn't read all comments (they are so many and it looks like the discussion strayed many times from the original topic), but I can't see any concerns about the inclusion of this specific patch. At least I can't see any concerns that wouldn't be raised by any other patch in the portage tree.