Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 488794 - media-libs/flac - In file included from options.c:32: /usr/include/bits/string3.h:104:3: warning: call to __builtin___memcpy_chk will always overflow destination buffer [enabled by default]
Summary: media-libs/flac - In file included from options.c:32: /usr/include/bits/strin...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
: 507000 (view as bug list)
Depends on:
Blocks: fortify-source
  Show dependency tree
 
Reported: 2013-10-20 20:10 UTC by Agostino Sarubbo
Modified: 2014-04-07 05:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-10-20 20:10:01 UTC
 * Messages for package media-libs/flac-1.2.1-r3:

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * /usr/include/bits/string3.h:105:3: warning: call to __builtin___memcpy_chk will always overflow destination buffer [enabled by default]
 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://flac.sourceforge.net


x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..   -DFLaC__INLINE=__inline__ -DNDEBUG -I../.. -I./include -I../../include   -march=native -O2 -g0 -pipe -c options.c
operations_shorthand_vorbiscomment.c: In function 'import_vc_from':
operations_shorthand_vorbiscomment.c:306:8: warning: ignoring return value of 'fgets', declared with attribute warn_unused_result [-Wunused-result]
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..   -DFLaC__INLINE=__inline__ -DNDEBUG -I../.. -I./include -I../../include   -march=native -O2 -g0 -pipe -c usage.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..   -DFLaC__INLINE=__inline__ -DNDEBUG -I../.. -I./include -I../../include   -march=native -O2 -g0 -pipe -c utils.c
utils.c: In function 'write_vc_field':
utils.c:234:5: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result [-Wunused-result]
utils.c:238:5: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result [-Wunused-result]
utils.c:242:4: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result [-Wunused-result]
In file included from /usr/include/string.h:642:0,
                 from options.c:32:
In function 'strcpy',
    inlined from 'parse_block_type.part.5' at options.c:1044:12:
/usr/include/bits/string3.h:105:3: warning: call to __builtin___memcpy_chk will always overflow destination buffer [enabled by default]
Comment 1 Jeroen Roovers gentoo-dev 2014-04-07 00:06:00 UTC
*** Bug 507000 has been marked as a duplicate of this bug. ***
Comment 2 John Haller 2014-04-07 01:13:33 UTC
Note that flac 1.3.0 fixes at least the first error, but is not unmasked
Comment 3 Samuli Suominen gentoo-dev 2014-04-07 05:54:42 UTC
Should be OK with 1.3.0, will get it stabilized
Comment 4 Samuli Suominen gentoo-dev 2014-04-07 05:59:01 UTC
Bug 507006 for stabilization of 1.3.0