Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 488014 - lxde-base/lxdm - Add systemd unit file
Summary: lxde-base/lxdm - Add systemd unit file
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: LXDE team
URL:
Whiteboard:
Keywords: NeedPatch
Depends on: 443666
Blocks: install-systemd-unit
  Show dependency tree
 
Reported: 2013-10-14 13:10 UTC by Roc Vallès
Modified: 2013-12-22 12:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roc Vallès 2013-10-14 13:10:36 UTC
lxdm doesn't have an lxdm.service file, as required for systemd.

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2013-10-15 05:59:40 UTC
I am unsure about it RDEPENing on consolekit unconditionally and dropping pam_console due that requirement, wouldn't be better to have consolekit optional allowing to use logind? (see bug #478258 for full explanation about why consolekit isn't needed with systemd running)
Comment 2 Pacho Ramos gentoo-dev 2013-10-15 06:04:10 UTC
Mageia applies this patch for proper session registration:
http://svnweb.mageia.org/packages/cauldron/lxdm/releases/0.4.1/14.mga4/SOURCES/lxdm-0.4.1-pam.patch?view=markup
Comment 3 Pacho Ramos gentoo-dev 2013-12-22 11:12:51 UTC
(In reply to Pacho Ramos from comment #2)
> Mageia applies this patch for proper session registration:
> http://svnweb.mageia.org/packages/cauldron/lxdm/releases/0.4.1/14.mga4/
> SOURCES/lxdm-0.4.1-pam.patch?view=markup

Maintainers, what do you prefer? :/
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2013-12-22 11:17:09 UTC
I have no opinion since I don't know enough about systemd@. I don't mind what you do as long as you don't break it for non-systemd users :) So feel free to handle this however you want to.
Comment 5 Pacho Ramos gentoo-dev 2013-12-22 11:35:35 UTC
The bug 443666 should be handled, otherwise, we should RDEPEND on consolekit[systemd-units] with a systemd USE flag :| (that looks a bit ugly... other option would be to discuss again if consolekit should install that files unconditionally and keep relying on consolekit running even with systemd)

Regarding bug 443666 seems that the patch was accepted by upstream... but probably they didn't release a newer version including it :S
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2013-12-22 12:23:25 UTC
(In reply to Pacho Ramos from comment #5)
> The bug 443666 should be handled, otherwise, we should RDEPEND on
> consolekit[systemd-units] with a systemd USE flag :| (that looks a bit
> ugly... other option would be to discuss again if consolekit should install
> that files unconditionally and keep relying on consolekit running even with
> systemd)
> 
> Regarding bug 443666 seems that the patch was accepted by upstream... but
> probably they didn't release a newer version including it :S

As said in #443666 the upstream commit was partially broken. I fixed it in -r8. See feel free to proceed here :)
Comment 7 Pacho Ramos gentoo-dev 2013-12-22 12:47:39 UTC
+  22 Dec 2013; Pacho Ramos <pacho@gentoo.org> +files/lxdm.service,
+  lxdm-0.4.1-r8.ebuild:
+  Add unit file (#488014)
+

It's really the upstream service file (that is committed to master), if you get reports about vt1 console disappearing, that is "expected" by upstream as explained at:
https://bugs.archlinux.org/task/36845