Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 487590 - app-office/akonadi-server does not start
Summary: app-office/akonadi-server does not start
Status: RESOLVED DUPLICATE of bug 488332
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-11 03:14 UTC by Carter Young
Modified: 2013-10-19 09:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carter Young 2013-10-11 03:14:15 UTC
KMail reports that the Persona Information Service was not started.  Running akonadictl start returns:

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
ecyoung@bedroom_gentoo Thu Oct 10 10:05 PM ~ $ search paths:  ("/bin", "/sbin", "/usr/bin", "/usr/sbin", "/usr/local/bin", "/usr/local/sbin", "/opt/bin", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin", "/opt/mysql/sbin") 
Database process exited unexpectedly during initial connection!
executable: "/usr/sbin/mysqld"
arguments: ("--defaults-file=/root/.local/share/akonadi/mysql.conf", "--datadir=/root/.local/share/akonadi/db_data/", "--socket=/root/.local/share/akonadi/socket-bedroom_gentoo/mysql.socket")
stdout: ""
stderr: "131010 22:05:48 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

131010 22:05:48 [ERROR] Aborting

131010 22:05:48 [Note] /usr/sbin/mysqld: Shutdown complete

"
exit code: 1
process error: "Unknown error"
"[
0: akonadiserver(_Z11akBacktracev+0x34) [0x458c74]
1: akonadiserver() [0x4590ce]
2: /lib64/libc.so.6(+0x37e70) [0x7f1f252e4e70]
3: /lib64/libc.so.6(gsignal+0x35) [0x7f1f252e4dd5]
4: /lib64/libc.so.6(abort+0x185) [0x7f1f252e62a5]
5: /usr/lib64/qt4/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x64) [0x7f1f26dcc304]
6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0x9b) [0x45af5b]
7: /usr/lib64/qt4/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x86) [0x7f1f26e69586]
8: /usr/lib64/qt4/libQtCore.so.4(+0x120ae2) [0x7f1f26e74ae2]
9: /usr/lib64/qt4/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x31) [0x7f1f26e7d4b1]
10: akonadiserver(_ZN13DbConfigMysql19startInternalServerEv+0x178c) [0x4c816c]
11: akonadiserver(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0xc7) [0x45bc47]
12: akonadiserver(_ZN7Akonadi13AkonadiServerC1EP7QObject+0xa5) [0x45d9a5]
13: akonadiserver(_ZN7Akonadi13AkonadiServer8instanceEv+0x37) [0x45ef97]
14: akonadiserver(main+0x10a) [0x4522ca]
15: /lib64/libc.so.6(__libc_start_main+0xed) [0x7f1f252d166d]
16: akonadiserver() [0x452ad1]
]
"
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
...
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
"akonadiserver" crashed too often and will not be restarted! 

Troubleshooting Steps I've taken
1. Attempted to run  mysqld as user.(http://dev.mysql.com/doc/mysql-security-excerpt/5.6/en/changing-mysql-user.html)  Got
 * Starting mysql ...
 * start-stop-daemon: caught an interrupt
 * start-stop-daemon: /usr/sbin/mysqld died                                                                                                                               [ !! ]
 * ERROR: mysql failed to start
2. Removed /var/lib/mysql
3. emerge --config =dev-db/mysql-5.1.70, to create new db
4. Reinstalled  app-office/akonadi-server.

Please advise, as     my mail is all in there :(
Comment 1 Johannes Huber gentoo-dev 2013-10-12 11:32:13 UTC
> * Starting mysql ...
> * start-stop-daemon: caught an interrupt
> * start-stop-daemon: /usr/sbin/mysqld died                                                                                                                               > [ !! ] ERROR: mysql failed to start

Does that mean your mysql server is not functional?
Comment 2 Carter Young 2013-10-12 12:42:11 UTC
(In reply to Johannes Huber from comment #1)
> > * Starting mysql ...
> > * start-stop-daemon: caught an interrupt
> > * start-stop-daemon: /usr/sbin/mysqld died                                                                                                                               > [ !! ] ERROR: mysql failed to start
> 
> Does that mean your mysql server is not functional?

No it starts.
sudo /etc/init.d/mysql restart
Password: 
 * Stopping mysql ...                                                                                                                                              [ ok ]
 * Starting mysql ...                                                                                                                                              [ ok ]
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-10-13 18:42:37 UTC
(In reply to Carter Young from comment #0)

> Connecting to deprecated signal
> QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
> ecyoung@bedroom_gentoo Thu Oct 10 10:05 PM ~ $ search paths:  ("/bin",
> "/sbin", "/usr/bin", "/usr/sbin", "/usr/local/bin", "/usr/local/sbin",
> "/opt/bin", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec",
> "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin",
> "/opt/mysql/sbin") 
> Database process exited unexpectedly during initial connection!
> executable: "/usr/sbin/mysqld"
> arguments: ("--defaults-file=/root/.local/share/akonadi/mysql.conf",
> "--datadir=/root/.local/share/akonadi/db_data/",
> "--socket=/root/.local/share/akonadi/socket-bedroom_gentoo/mysql.socket")
> stdout: ""
> stderr: "131010 22:05:48 [ERROR] Fatal error: Please read "Security" section
> of the manual to find out how to run mysqld as root!

How are you starting KDE? Are you running it through [k,g,x]dm or are you running it through startx as root?
Comment 4 Carter Young 2013-10-14 05:18:21 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #3)
> (In reply to Carter Young from comment #0)

> How are you starting KDE? Are you running it through [k,g,x]dm or are you
> running it through startx as root?

I'm running it using startx as  a regular user, which is why I'm befuddled too, as to why the socket etc poimts to root
Comment 5 Johannes Huber gentoo-dev 2013-10-17 09:59:09 UTC
Could you please test the proposed changes in bug #488332 ?
Comment 6 Randy Andy 2013-10-17 14:27:23 UTC
Carter,

if this doesn't work for you, but you're using the >=nvidia-drivers-331.13, do a downgrade of it and retry after a reboot.

In my case with similar akonadi trouble, it was the solution.

Regards, Andy.
Comment 7 Carter Young 2013-10-17 15:59:01 UTC
I'll try both of these tonight.  I'm in the middle of an emerge -e system && emerge -e world after unmasking the ABI_X86 Flag for the new Wine...
Comment 8 Carter Young 2013-10-19 01:37:23 UTC
(In reply to Johannes Huber from comment #5)
> Could you please test the proposed changes in bug #488332 ?

This fixed it, I'm too rusty with patch so I used kate, as in kdesudo kate, opened /usr/bin/startkde and edited by hand....
Comment 9 Johannes Huber gentoo-dev 2013-10-19 09:25:53 UTC

*** This bug has been marked as a duplicate of bug 488332 ***