Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486614 - dev-lang/ocaml-3.12.1 - In function `caml_terminfo_setup': terminfo.c:(.text+0x67): undefined reference to `tgetent'
Summary: dev-lang/ocaml-3.12.1 - In function `caml_terminfo_setup': terminfo.c:(.text+...
Status: RESOLVED DUPLICATE of bug 459512
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-30 22:17 UTC by Tomas Vondra
Modified: 2013-09-30 22:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,14.97 KB, text/plain)
2013-09-30 22:18 UTC, Tomas Vondra
Details
build environment (environment,100.10 KB, text/plain)
2013-09-30 22:18 UTC, Tomas Vondra
Details
emerge --info '=dev-lang/ocaml-3.12.1' (emerge--info.log,5.18 KB, text/plain)
2013-09-30 22:19 UTC, Tomas Vondra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Vondra 2013-09-30 22:17:45 UTC
Whenever I try to compile ocaml (either directly or because of dependency), it fails with this error:

libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
terminfo.c:(.text+0x67): undefined reference to `tgetent'
terminfo.c:(.text+0x86): undefined reference to `tgetnum'
terminfo.c:(.text+0x9b): undefined reference to `tgetstr'
terminfo.c:(.text+0xb1): undefined reference to `tgetstr'
terminfo.c:(.text+0xc7): undefined reference to `tgetstr'
terminfo.c:(.text+0xdd): undefined reference to `tgetstr'
terminfo.c:(.text+0x167): undefined reference to `tgetstr'
libcamlrun.a(terminfo.o):terminfo.c:(.text+0x17d): more undefined references to `tgetstr' follow
libcamlrun.a(terminfo.o): In function `caml_terminfo_backup':
terminfo.c:(.text+0x1bd): undefined reference to `tputs'
libcamlrun.a(terminfo.o): In function `caml_terminfo_standout':
terminfo.c:(.text+0x203): undefined reference to `tputs'
libcamlrun.a(terminfo.o): In function `caml_terminfo_resume':
terminfo.c:(.text+0x24d): undefined reference to `tputs'
collect2: error: ld returned 1 exit status
make[2]: *** [ocamlrun] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-lang/ocaml-3.12.1/work/ocaml-3.12.1/byterun'
make[1]: *** [coldstart] Error 2
make[1]: Leaving directory `/var/tmp/portage/dev-lang/ocaml-3.12.1/work/ocaml-3.12.1'
make: *** [world] Error 2
emake failed


Reproducible: Always

Steps to Reproduce:
1. emerge -pqv '=dev-lang/ocaml-3.12.1'
2. wait
Actual Results:  
The compilation fails.

Expected Results:  
The ocaml compiles fine / install.
Comment 1 Tomas Vondra 2013-09-30 22:18:03 UTC
Created attachment 359826 [details]
build.log
Comment 2 Tomas Vondra 2013-09-30 22:18:22 UTC
Created attachment 359828 [details]
build environment
Comment 3 Tomas Vondra 2013-09-30 22:19:11 UTC
Created attachment 359830 [details]
emerge --info '=dev-lang/ocaml-3.12.1'
Comment 4 Tomas Vondra 2013-09-30 22:22:09 UTC
Happens with ocaml 4.01 too.
Comment 5 Jeroen Roovers gentoo-dev 2013-09-30 22:33:30 UTC

*** This bug has been marked as a duplicate of bug 459512 ***