Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486550 - app-office/libreoffice-4.1.2.2-r1 dev-libs/libixion-0.5.0:0/0.5 conflict on dev-util/mdds version
Summary: app-office/libreoffice-4.1.2.2-r1 dev-libs/libixion-0.5.0:0/0.5 conflict on d...
Status: RESOLVED DUPLICATE of bug 427938
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-30 08:30 UTC by adrin
Modified: 2014-12-28 23:16 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,4.84 KB, text/plain)
2014-02-05 15:17 UTC, adrin
Details
emerge -pd libreoffice (pd.log.tar.gz,347.53 KB, application/x-gzip)
2014-02-05 21:48 UTC, adrin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adrin 2013-09-30 08:30:27 UTC
These three packages block mdds for each other.

Reproducible: Always

Steps to Reproduce:
# emerge -av mdds libreoffice libixion

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/mdds-0.9.0:0/0.9.0 [0.8.1:0/0.8.1] 142 kB
[ebuild   R    ] dev-util/mdds-0.8.1:0/0.8.1  136 kB
[ebuild   R    ] dev-libs/libixion-0.5.0:0/0.5  USE="-static-libs" 331 kB
[ebuild  rR    ] dev-libs/libxml2-2.9.1-r1:2  USE="icu ipv6 lzma python readline -debug -examples -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_2 python3_3 -python2_6" 0 kB
[ebuild     U  ] app-office/libreoffice-4.1.2.2-r1 [4.1.2.2] USE="cups dbus eds gnome gstreamer gtk gtk3 telepathy (-aqua) -bluetooth -branding -debug -java -jemalloc -kde -mysql -odk -opengl -postgres {-test} -vba -webdav" LIBREOFFICE_EXTENSIONS="-nlpsolver -presenter-minimizer -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 python3_3" 134,774 kB

Total: 5 packages (2 upgrades, 3 reinstalls), Size of downloads: 135,381 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-util/mdds:0

  (dev-util/mdds-0.9.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-util/mdds-0.8.1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/mdds-0.8*:= required by (app-office/libreoffice-4.1.2.2-r1::gentoo, ebuild scheduled for merge)
Comment 1 Jeroen Roovers gentoo-dev 2013-10-04 13:31:09 UTC
Both of these are build time dependencies only, so you should be able to work around the problem by running emerge twice.
Comment 2 Andreas K. Hüttel gentoo-dev 2013-12-29 22:36:47 UTC
This looks more like a problem in dependency resolution, the dependencies themselves look good to me.
Comment 3 Sebastian Luther (few) 2013-12-30 06:42:01 UTC
Please try to run this command with --backtrack=30. If this doesn't help, update to portage-9999 and try again. If your problem isn't solved by then, provide emerge --info.
Comment 4 adrin 2014-02-05 15:17:14 UTC
Created attachment 369612 [details]
emerge --info
Comment 5 adrin 2014-02-05 15:18:05 UTC
running emerge twice, or more, didn't help. --backtrack=30 didn't help.

But I can upgrade mdds alone, which works. But, when I try to re-emerge libreoffice, it pulls back the old mdds. emerge --info is attached.

Should I still upgrade to portage-9999?

# eshowkw mdds
Keywords for dev-util/mdds:
          |                             | u          |  
          | a a   a           p     s   | n          |  
          | l m   r h i m m   p s   p   | u s        | r
          | p d a m p a 6 i p c 3   a x | s l        | e
          | h 6 r 6 p 6 8 p p 6 9 s r 8 | e o        | p
          | a 4 m 4 a 4 k s c 4 0 h c 6 | d t        | o
----------+-----------------------------+------------+-------
    0.7.1 | o + ~ o o o o o + ~ o o o + | o 0        | gentoo
----------+-----------------------------+------------+-------
    0.8.1 | o + ~ o o o o o + ~ o o o + | o 0/0.8.1  | gentoo
----------+-----------------------------+------------+-------
[I]0.10.1 | o ~ ~ o o o o o ~ ~ o o o ~ | o 0/0.10.1 | gentoo


# emerge -av --backtrack=30 libreoffice

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-util/mdds-0.8.1:0/0.8.1 [0.10.1:0/0.10.1] 136 kB
[ebuild   R    ] app-office/libreoffice-4.1.4.2  USE="cups dbus eds gnome gstreamer gtk gtk3 telepathy (-aqua) -bluetooth -branding -debug -java -jemalloc -kde -mysql -odk -opengl -postgres {-test} -vba -webdav" LIBREOFFICE_EXTENSIONS="-nlpsolver -presenter-minimizer -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 python3_3" 134,953 kB

Total: 2 packages (1 downgrade, 1 reinstall), Size of downloads: 135,089 kB
Comment 6 Sebastian Luther (few) 2014-02-05 17:17:58 UTC
portage-2.2.8 is good enough. Please attach the output of
"emerge -pd libreoffice".
Comment 7 adrin 2014-02-05 21:48:21 UTC
Created attachment 369662 [details]
emerge -pd libreoffice
Comment 8 Fabio Rossi 2014-05-31 12:21:21 UTC
on amd64 systems mdds-0.10.3 is now stable while libreoffice-4.1.* depend on =mdds-0.8*
Comment 9 Andreas K. Hüttel gentoo-dev 2014-12-28 18:41:35 UTC
libreoffice-4.1 is gone
Comment 10 Zac Medico gentoo-dev 2014-12-28 23:13:04 UTC

*** This bug has been marked as a duplicate of bug 427938 ***
Comment 11 Zac Medico gentoo-dev 2014-12-28 23:16:26 UTC
(In reply to adrin from comment #5)
> But I can upgrade mdds alone, which works.

That's because it's a build-time only dependency, which is safe to break until you need to rebuild libreoffice. We're tracking this issue with bug 427938.

> But, when I try to re-emerge
> libreoffice, it pulls back the old mdds. emerge --info is attached.

That's because it needs to satisfy the =mdds-0.8* in order to build libreoffice.