Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 48528 - Missing ebuild for new GCC v3.4
Summary: Missing ebuild for new GCC v3.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Toolchain Maintainers
Keywords: EBUILD
: 51934 (view as bug list)
Depends on: 47454 47455 47475 47667 47782 47865 47869 47870 48167 48406 48425 48523 48533 48596 48692 48703 48713 48758 48760 48798 48805 48815 48853 48889 48890 48911 48930 48931 48933 48947 48953 49005 49210 49221 49222 49229 49231 49233 49234 49236 49237 49238 49239 49241 49242 49304 49350 49372 49375 49383 49390 49449 49450 49452 49457 49470 49472 49474 49488 49566 49570 49573 49616 49682 49709 49715 49736 49818 49823 49844 49893 49925 49996 50116 50129 50193 50210 50233 50287 50331 50357 50428 50596 50597 50769 50820 51076 51222 51289 51312 51394 51399 51423 51514 51549 51559 51597 51600 51601 51615 51621 51758 51809 51838 51849 51997 52023 52037 52270 52373 52406 52444 53075 53195 53655
Blocks: 54918 54931
  Show dependency tree
Reported: 2004-04-20 19:46 UTC by Davi Arnaut
Modified: 2005-04-05 15:00 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

gcc-3.4.0.ebuild (gcc-3.4.0.ebuild,17.40 KB, text/plain)
2004-04-21 15:30 UTC, Robert Moss (RETIRED)
gcc-3.4.0-gentoo-branding.patch (gcc-3.4.0-gentoo-branding.patch,759 bytes, patch)
2004-04-21 15:30 UTC, Robert Moss (RETIRED)
Details | Diff
gcc-3.4.0.ebuild (gcc-3.4.0.ebuild,17.40 KB, text/plain)
2004-04-22 04:46 UTC, Robert Moss (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Davi Arnaut 2004-04-20 19:46:15 UTC
Missing ebuild for new GCC v3.4

Reproducible: Always
Steps to Reproduce:
Comment 1 Alex Tribble 2004-04-20 19:56:32 UTC
As of 4/20/2004, gcc 3.4.0 has been released - the tarballs are propagating to the mirrors, but are already available on aka I've succesfully bootstrapped this on an athlon-xp Gentoo 2004.0 system, and it passes the greatly enhanced testsuite. I believe the c++ ABI is incompatible with gcc-3.[23], so it probably needs a new SLOT, but it successfully builds the 2.6.6-rc1-mm1 kernel, and seems to work so far.
Comment 2 Robert Moss (RETIRED) gentoo-dev 2004-04-21 12:53:54 UTC
Alex, have you made an ebuild for this? If not I'll make one.
Comment 3 Robert Moss (RETIRED) gentoo-dev 2004-04-21 15:30:09 UTC
Created attachment 29778 [details]

Okay people, here it is in all its shiny goodness... the ebuild for GCC 3.4.0!
Hurah! Currently compiling, but no errors so far. I'll report back on what I
find out.
Comment 4 Robert Moss (RETIRED) gentoo-dev 2004-04-21 15:30:56 UTC
Created attachment 29779 [details, diff]

Put this in ${PORTDIR_OVERLAY}/sys-devel/gcc/files/3.4.0/ and all will be well
- and Gentoo branded :-)
Comment 5 SpanKY gentoo-dev 2004-04-21 15:59:10 UTC
we are waiting on the propolice patches which is why we havent added 3.4.0 yet, just the pre release
Comment 6 Robert Moss (RETIRED) gentoo-dev 2004-04-21 17:09:21 UTC
Fair enough. My shiny new GCC 3.4.0 installation is wonderful, it goes like shit off a shovel...
Comment 7 Hinrik Örn Sigurðsson 2004-04-21 22:24:00 UTC
This line should be changed from:




Comment 8 Robert Moss (RETIRED) gentoo-dev 2004-04-22 04:46:49 UTC
Created attachment 29810 [details]

Whoops, sorry - fixed above...
Comment 9 solar (RETIRED) gentoo-dev 2004-04-22 22:54:06 UTC
Still waiting on one gcc extention. (next few days hopefully)

After the extension is ready/released the 3.4.0.ebuild will have to be 
rewritten because 3.3.3-r2 is still in active development.

Till then it's best to keep on pecking away on Bug 48528 depends.
Comment 10 Andreas Eriksson 2004-04-23 01:06:06 UTC
I tried to bootstrap using this ebuild.
It didn't work, here's the error I got:

echo timestamp > gcc.pod
perl /var/tmp/portage/gcc-3.4.0/work/gcc-3.4.0/gcc/../contrib/ /var/tmp/portage/gcc-3.4.0/work/gcc-3.4.0/gcc/doc/invoke.texi > gcc.pod
/bin/sh: line 1: perl: command not found
make[1]: [gcc.pod] Error 127 (ignored)
echo timestamp > doc/gcc.1
/bin/sh: line 1: doc/gcc.1: No such file or directory
make[1]: *** [doc/gcc.1] Error 1
rm gcc.pod
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.0/work/build/gcc'
make: *** [install-gcc] Error 2

as you see, it tries to use perl for something, which of course isn't aviable during bootstrap.

I checked that doc directory and it was empty so I tried to unpack the gcc-3.4 tarball somewhere else and copy the files that are supposed to be in there.
It didn't work, I got the same error message, and after the doc dir was empty again.
Comment 11 Robert Moss (RETIRED) gentoo-dev 2004-04-23 01:12:26 UTC

I can't say I've even *tried* myself to bootstrap using 3.4.0. I think it would need perl adding to the stage1 tarball for that to work and a perl dependency being added to GCC? I've never worked on to be honest, so I'm guessing a bit. However, solar is right, the 3.4.0 ebuild *will* have to be completely rewritten once the last extension is rewritten - the above error being a case in point. Since I started using 3.4 in January I've not *once* managed to bootstrap with it - but then, I only tried once...

Anyway, I have a few more 3.4-related bugfixes on the way, when "emerge -e world" finishes I'll post my remaining fixes.
Comment 12 Andreas Eriksson 2004-04-23 01:29:27 UTC
well.. its only a 11k perl script. I was thinking that maybe it could be converted to something that is aviable during bootstrap, like a bash script, or maybe python. It seems a bit overkill to add perl just for a 11k script.
But I don't know..
Comment 13 Travis Tilley (RETIRED) gentoo-dev 2004-04-23 05:35:02 UTC
the perl stuff generates man pages. the 3.3 ebuilds take care of this by providing pre-generated man pages. so will 3.4 when it's ready... which it certainly isn't at the moment. i wouldn't recommend doing a bootstrap with it yet.

there also seems to be an additional problem on archs with bi-arch toolchains where libgcc_s from 3.3.x is still being used instead of the 3.4 version... and other stuff. gcc 3.4 will remain masked -* for quite some time yet.
Comment 14 Thomas Weidner 2004-04-23 06:23:49 UTC
I believed the c++ ABI now conforms to some kind of standard, which is also used by ICC. any sources for a incompatible c++ ABI between 3.3 <> 3.4 ?
Comment 15 Travis Tilley (RETIRED) gentoo-dev 2004-04-23 09:41:33 UTC
the abi is incompatible on mips, and i think one other arch.

either way there is the incompatible version of libstdc++ to deal with. c++ apps compiled with gcc 3.3.x will still need it around in order to work, or we need to create another compatibility library to ease migration.
Comment 16 Travis Tilley (RETIRED) gentoo-dev 2004-04-26 11:52:44 UTC
i've committed a new gcc 3.4.0 ebuild. it's not this one, but it could still use some testing. i'll keep this bug open as it seems to be functioning as a gcc 3.4 meta-bug for some reason... i'd like to note that gcc 3.4.0 is still masked and it'll be some time before it even makes it's way into testing
Comment 17 Tom Gall (RETIRED) gentoo-dev 2004-04-26 12:50:11 UTC
well for what it's worth the 3.4.0.ebuild as of now doesn't even build on ppc64, I'll try and investigate a bit more....

The 3.4 prelease that WAS in portage actually did build and work just fine. If the pre was there stil I could at least compare to see what changed ;-)
Comment 18 SpanKY gentoo-dev 2004-04-27 00:16:59 UTC
it's been added to portage now
Comment 19 SpanKY gentoo-dev 2004-05-31 20:41:26 UTC
*** Bug 51934 has been marked as a duplicate of this bug. ***