Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 484766 - sci-biology/ncbi-tools++-0.2010.06.15-r1 should depend on net-libs/gnutls[lzo] ? - /work/ncbi_cxx--Jun_15_2010/src/connect/ncbi_gnutls.c:101:5: error: 'GNUTLS_COMP_LZO' undeclared here (not in a function)
Summary: sci-biology/ncbi-tools++-0.2010.06.15-r1 should depend on net-libs/gnutls[lzo...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-13 13:37 UTC by Martin Mokrejš
Modified: 2014-08-03 20:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,495.19 KB, text/x-log)
2013-09-13 13:37 UTC, Martin Mokrejš
Details
Patch to disable LZO compression (gnutls.patch,278 bytes, patch)
2013-12-17 16:29 UTC, Hongjiu Zhang
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2013-09-13 13:37:41 UTC
Created attachment 358578 [details]
build.log

Seems that the old ncbitools++ ebuilds are not converted to the nice robustness of the one for 9.0 series (in sci overlay). I just ran into this issue which seems to me that gnutls has to be compiled with lzo support. But, there is no IUSE=lzo in gnutls ebuilds. Further, configure summary printed by gnutls ebuild does not list lzo being tested, so maybe my interpretation is wrong.

make[5]: Entering directory `/mnt/external/var/tmp/portage/sci-biology/ncbi-tools++-0.2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/GCC473-ReleaseMTDLL64/build/connect'
/usr/bin/x86_64-pc-linux-gnu-gcc  -c -Wall -Wno-format-y2k  -pthread -O2 -pipe -maes -mpclmul -mpopcnt -march=native -fPIC    -DNDEBUG -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -D_MT -D_REENTRANT -D_THREAD_SAFE -I/mnt/external/var/tmp/portage/sci-biology/ncbi-tools++-0.2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/GCC473-ReleaseMTDLL64/inc -I/mnt/external/var/tmp/portage/sci-biology/ncbi-tools++-0.2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/include  /mnt/external/var/tmp/portage/sci-biology/ncbi-tools++-0.2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/connect/ncbi_gnutls.c -o ncbi_gnutls.o 
/mnt/external/var/tmp/portage/sci-biology/ncbi-tools++-0.2010.06.15-r1/work/ncbi_cxx--Jun_15_2010/src/connect/ncbi_gnutls.c:101:5: error: 'GNUTLS_COMP_LZO' undeclared here (not in a function)
Comment 1 Hongjiu Zhang 2013-12-12 17:25:59 UTC
Same problem here. Maybe --without-gnutls?

https://github.com/Homebrew/homebrew-science/issues/161
Comment 2 Hongjiu Zhang 2013-12-17 16:29:54 UTC
Created attachment 365538 [details, diff]
Patch to disable LZO compression

According to the page I gave, it seems to be some legacy code and can be safely removed. This patch just disable LZO compression support, and try to minimise the change.
Comment 3 Martin Mokrejš 2013-12-17 21:07:56 UTC
I just asked abou this Aaron Ucko from NCBI dev team and he replied:

I can confirm that the correct fix is to remove the reference to GNUTLS_COMP_LZO outright.
Comment 4 Martin Mokrejš 2014-06-26 14:39:18 UTC
Some update on this specific to 12.0.0 which I just committed to sci overlay:

sci-biology/ncbi-tools++-12.0.0:
dropped altogether openssl-related USE flags and configure arguments (per upstream info nothing in the public code uses openssl and the configure test is there for their internal reasonings);
dropped gnutls[lzo] requirement which was only need for unpatched 9.0.0 version;
however, --with-lzo is still advantageous for
http://www.ncbi.nlm.nih.gov/IEB/ToolBox/CPP_DOC/doxyhtml/group__Compression.html


Did same to 9.0.0* ebuilds in the overlay.
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2014-08-03 20:35:18 UTC
ncbi-tools++ was removed from the tree it seems, so these bugs aren't relevant anymore.