Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 48456 - apache-1.3.29-r1 doesn't start properly with db-4.1.25_p1-r3
Summary: apache-1.3.29-r1 doesn't start properly with db-4.1.25_p1-r3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Apache Team - Bugzilla Reports
Depends on:
Reported: 2004-04-20 05:46 UTC by Stephan Hermann
Modified: 2005-04-23 19:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Hermann 2004-04-20 05:46:57 UTC
I installed a new gentoo box, and compiled ebuild apache-1.3.29-r1 with the dep db-4.1.25_p1-r3...
it doesn't start it says that it can't load the mod_auth_dbm.
I compiled then db-4.0.14-r2 and recompiled apache-1.3.29-r1...after that...apache workes fine ...

please fix this dep

Reproducible: Always
Steps to Reproduce:
1. compile db-4.1.25_pl1-r3 and apache-1.3.29-r1 (as a dep)
2. start apache 
3. compile db-4.0.14-r2 and recompile apache 1.3.29-r1
4. start apache

Actual Results:  
see details 

Expected Results:  
it must start properly 

Portage 2.0.50-r6 (default-x86-2004.0, gcc-3.3.2, glibc-2.3.2-r9, 
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(tm) MP 2600+ 
Gentoo Base System version 1.4.9 
Autoconf: sys-devel/autoconf-2.58-r1 
Automake: sys-devel/automake-1.8.3 
CFLAGS="-mcpu=athlon-mp -O3 -pipe" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-mcpu=athlon-mp -O3 -pipe" 
FEATURES="autoaddcvs ccache sandbox" 
USE="apache1 apm arts avi berkdb crypt cups curl encode foomaticdb gd 
gd-external gdbm gif gpm gtk2 imlib jpeg libg++ libwww mad mikmod mpeg mysql 
ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline 
sasl sdl slang spell ssl tcpd tiff truetype x86 xml xml2 xmms xv zlib"
Comment 1 Chuck Short (RETIRED) gentoo-dev 2004-04-20 11:06:07 UTC
What was the error message you were getting?

Comment 2 Chuck Short (RETIRED) gentoo-dev 2004-04-20 11:18:33 UTC
Comment 3 Stephan Hermann 2004-04-21 00:36:42 UTC

it said:

syntax error in config at line nnn
can't load mod_auth_dbm...cause of some unresolved symbols in libdb

i can recompile apache with the 4.1.25_pl1-r3 version if you want...


Comment 4 David James 2004-04-21 11:39:24 UTC
I have the same issue. The full error message is:

 * Starting apache...
Syntax error on line 48 of /etc/apache/conf/apache.conf:
Cannot load /etc/apache/modules/ into server: /etc/apache/modules/ undefined symbol: __db_ndbm_open_4001                   [ !! ]

The apache modules have compiled against db4.x header files, but have linked with the db1.x shared library:

ldd /etc/apache/modules/mod_auth_db*
/etc/apache/modules/ =>  (0xffffe000) => /lib/ (0x40012000) => /lib/ (0x40034000) => /usr/lib/ (0x40061000) => /usr/lib/ (0x40070000) => /usr/lib/ (0x40074000) => /lib/ (0x4009a000) => /lib/ (0x400eb000)
        /lib/ => /lib/ (0x80000000)
/etc/apache/modules/ =>  (0xffffe000) => /lib/ (0x40012000) => /lib/ (0x40034000) => /usr/lib/ (0x40061000) => /usr/lib/ (0x40070000) => /usr/lib/ (0x40074000) => /lib/ (0x4009a000) => /lib/ (0x400eb000)
        /lib/ => /lib/ (0x80000000)

The log from doing emerge '<apache-2' shows the module being linked against -ldb1:

gcc -shared  -o mod_auth_dbm.lo -L/usr/lib -lm -lcrypt -ldb1 -lmm -lexpat -lpthread
./src/helpers/ -c -m 755 ./src/modules/standard/ /var/tmp/portage/apache-1.3.29-r1/image//usr/lib/apache/
Comment 5 Chuck Short (RETIRED) gentoo-dev 2004-04-21 11:54:03 UTC
Try upgrading to gdbm-1.8.3

Comment 6 David Stanek 2004-05-15 18:46:59 UTC
Does this still not work? The patch I created for ticket #48795 should have corrected this...
Comment 7 Tom P. 2004-06-03 11:17:43 UTC
Just some additional info, hope this helps.  I encountered bug 52201 only on one of my boxes.  Searching for releated db bugs, I found this one.

My debugging shows that apache 1.3.31 will not compile unless sys-libs/db 1.85-r1 is present on the system/linked with gdbm 1.80-r5.

See my comments on bug 52201 for the steps I took if this is interesting to you.
Comment 8 Benedikt Böhm (RETIRED) gentoo-dev 2005-01-19 23:16:25 UTC
A new ebuild is portage since the apache herds package refresh, pleae test if it works now. See

Generic Upgrade Instructions:

After we have refreshed the packages on 8th Jan, to upgrade you will need to
do the following.

If you do not want to install masked/unstable packages on your machine(s),
these ebuilds will be unmasked and marked stable as soon as we have
determined that everything is working properly.

- unmask all needed packages (using /etc/portage/package.unmask and
- emerge -uav world

With this update, we are bringing some changes to the Apache configuration:

- /etc/apache{,2}/conf is moving to be /etc/apache{,2}
- new httpd.conf replaces commonapache{,2}.conf and apache{,2}.conf files
- /etc/apache{,2}/conf/vhosts is moving to be /etc/apache{,2}/vhosts.d

After installing this update, you will need to manually migrate any changes
you've made to your existing configuration files into the new configuration
Comment 9 Elfyn McBratney (beu) (RETIRED) gentoo-dev 2005-04-23 19:51:48 UTC
The above mentioned fix has worked for many I've spoken to who experienced the same problem.  Closing, please re-open if you continue to have issues.