Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 484136 - net-analyzer/rrdtool built with USE="perl" should be rebuild after some perl update
Summary: net-analyzer/rrdtool built with USE="perl" should be rebuild after some perl ...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-07 21:45 UTC by Piotr Szymaniak
Modified: 2013-09-08 15:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymaniak 2013-09-07 21:45:53 UTC
Few days ago there was some important perl update:
Thu Sep  5 22:23:09 2013 >>> dev-lang/perl-5.18.1

And today I noticed that my rrdtool stopped gathering data. I got the idea, that it was perl-related (the script is written in perl [1]), but didn't get the missing link (I was like „wtf perl? needz to perl-cleaner --all?”, but it didn't work out). But then, in a flashback, there it was, some @preserved-rebuild… so I tried a simple emerge -1 rrdtool and it's working again.

Would be nice, with all those slots, auto-rebuilds and other magic to do the trick and rebuild rrdtool as well. ;)

[1] http://martybugs.net/electronics/tempsensor/download/rrd_tempsensor.txt
Comment 1 Jeroen Roovers gentoo-dev 2013-09-08 15:22:31 UTC
That is what perl-cleaner is for. You should run it after you update dev-lang/perl.

*** This bug has been marked as a duplicate of bug 41124 ***