Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 484052 - <=dev-perl/perl-tk-804.29 with >=dev-lang/perl-5.18 - In function ‘XS_Tk__IO_read’: IO.xs:210:6: error: invalid use of void expression
Summary: <=dev-perl/perl-tk-804.29 with >=dev-lang/perl-5.18 - In function ‘XS_Tk__IO_...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 484504 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-06 23:51 UTC by Carter Young
Modified: 2013-10-06 10:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,157.31 KB, text/x-log)
2013-09-06 23:55 UTC, Carter Young
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carter Young 2013-09-06 23:51:39 UTC
Perl-Cleaner did not finish after upgrade to perl-5.18.1

Reproducible: Always

Steps to Reproduce:
1. Upgrade dev-lang/perl to 5.18.1
2. perl-cleaner --all as instructed by previous ebuild 

Actual Results:  
cp IO.pm ../blib/lib/Tk/IO.pm
/usr/bin/perl5.18.1 /usr/lib64/perl5/vendor_perl/5.18.1/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.18.1/ExtUtils/typemap -typemap /var/tmp/portage/dev-perl/perl-tk-804.29.0/work/Tk-804.029/Tk/typemap  IO.xs > IO.xsc && mv IO.xsc IO.c
Warning: Found a 'CODE' section which seems to be using 'RETVAL' but no 'OUTPUT' section. in IO.xs, line 235
x86_64-pc-linux-gnu-gcc -c  -I..  -I/usr/include/freetype2 -fno-strict-aliasing -pipe -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -march=amdfam10 -O2 -pipe   -DVERSION=\"804.029\" -DXS_VERSION=\"804.029\" -fPIC "-I/usr/lib64/perl5/5.18.1/x86_64-linux/CORE"   -Wall -Wno-implicit-int -Wno-comment -Wno-unused -D__USE_FIXED_PROTOTYPES__ IO.c
IO.xs: In function ‘XS_Tk__IO_read’:
IO.xs:210:6: error: invalid use of void expression
make[1]: *** [IO.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-perl/perl-tk-804.29.0/work/Tk-804.029/IO'
make: *** [subdirs] Error 2

Expected Results:  
perl-tk should build cleanly, adding dev-perl/perl-tk  ~amd64 should fix as this was fixed upstream, hence stablization request.

 sudo emerge --info
Password: 
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.10.7-gentoo x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-x86_64-AMD_Athlon-tm-_II_X2_255_Processor-with-gentoo-2.2
KiB Mem:     4052588 total,     97036 free
KiB Swap:    4000180 total,   3993004 free
Timestamp of tree: Fri, 06 Sep 2013 04:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo sunrise mv
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/mv"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="64bit X a52 aac aalib acl acpi aim alsa amd64 apache2 apm audiofile bash-completion bazaar bcmath berkdb bidi binfilter bluetooth branding bzip2 c++0x cairo calendar cdda cddb cdr cgi cli client consolekit cracklib crypt css ctype cups curl curlwrappers cvs cxx datahub dbus dconf declarative dga djvu downloads-monitor dri dts dvd dvdr emboss encode exif expat extra-cardsets fam fbcondecor ffmpeg firefox flac fontconfig foomaticdb fortran freetds ftp g15 gd gdbm geoip gif gimp gles2 glut gnome-screensaver gnome-shell gphoto2 gpm gps graphite graphviz gsm gtk gtkstyle gudev guile hwdb i18n iconv icq icu idn ieee1394 imap imlib introspection ipod ipv6 jabber jack java java6 javascript jbig jingle joystick jpeg jpeg2k kde kipi ladspa lame lash latex lcms ldap libcaca libgda libnotify lirc lm_sensors lock lua lzma lzo mad mbox mime minizip mmap mmx mng modplug modules mozilla mp3 mp4 mpeg mplayer msn mudflap multilib musepack mysql nas ncurses nis nls nntp nptl nsplugin nvidia odbc odk offensive ogg openal openexr opengl openmp openrc oscar pam pango pch pcre pda pdf phonon php plasma plotutils png policykit posix postgres ppds pulseaudio python qt3support qt4 raw rdesktop readline rss ruby scanner sdl semantic-desktop session sharedext sharedmem shorten slp smp sndfile snmp soap sockets speex spell sqlite sse sse2 ssl startup-notification subversion svg syslog taglib tcl tcpd theora threads thumbnail thunar tidy tiff tk truetype udev udisks unicode upower usb vala video vorbis webkit wmf wxwidgets x264 xcb xcomposite xft xine xinerama xml xmlreader xmlrpc xmlwriter xpm xscreensaver xv xvid yahoo zip zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="alias auth_basic auth_digest rewrite authz_host dir mime cgid php dav mono status include mime_magic log_config setenvif" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard virtualbox" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver pdfimport presenter-console presenter-minimizer scripting-javascript" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Carter Young 2013-09-06 23:55:10 UTC
Created attachment 358120 [details]
build log
Comment 2 Carter Young 2013-09-07 00:01:51 UTC
As thought installing dev-perl/perl-tk  ~amd64 solves issue.
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-09-07 14:11:03 UTC
(In reply to Carter Young from comment #2)
> As thought installing dev-perl/perl-tk  ~amd64 solves issue.

yes, many packages broken with new version of perl, please use last unstable version now, it will be mark stable ASAP.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-09-10 17:52:33 UTC
*** Bug 484504 has been marked as a duplicate of this bug. ***
Comment 5 Carter Young 2013-09-10 19:10:50 UTC
Not that it matters now, but versions above 5.16 are hard masked...