Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 483502 - www-apps/redmine - pkg_config(): Migrating database fails with rake aborted! / / undefined method `active_record' for /var/lib/redmine/Rakefile:5:in `<top (required)>'
Summary: www-apps/redmine - pkg_config(): Migrating database fails with rake aborted! ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 590646
  Show dependency tree
 
Reported: 2013-09-03 16:39 UTC by cruzki
Modified: 2016-08-14 06:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cruzki 2013-09-03 16:39:56 UTC
I am trying to update redmine to 2.3.2. After compiling emerge ask for running 

emerge --config "=www-apps/redmine-2.3.2" 

that fails horrible (see below). The problem is that redmain does not work anymore. I have tryied to donwgrading to 2.2.4, reinstaling arel, bigdecimal and minitest without luck. 

Any idea of what is happening?

Thanks in advance

***********************************************************************

energos redmine # emerge --config "=www-apps/redmine-2.3.2"


Configuring pkg...

 * 
 * Upgrading database.
 * 
 * Migrating database.
rake aborted!
undefined method `active_record' for #<Rails::Application::Configuration:0x00000000e58c60>
/var/lib/redmine/config/application.rb:26:in `<class:Application>'
/var/lib/redmine/config/application.rb:13:in `<module:RedmineApp>'
/var/lib/redmine/config/application.rb:12:in `<top (required)>'
/var/lib/redmine/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)
 * ERROR: www-apps/redmine-2.3.2::gentoo failed (config phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called pkg_config
 *   environment, line 4011:  Called die
 * The specific snippet of code:
 *           RAILS_ENV="${RAILS_ENV}" ${RUBY} -S rake db:migrate || die;
 * 
 * If you need support, post the output of `emerge --info '=www-apps/redmine-2.3.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-apps/redmine-2.3.2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =redmine-2.3.2
 * The complete build log is located at '/home/portage/portage/www-apps/redmine-2.3.2/temp/build.log'.
 * The ebuild environment file is located at '/home/portage/portage/www-apps/redmine-2.3.2/temp/environment'.
 * Working directory: '/var/lib/redmine'
 * S: '/home/portage/portage/www-apps/redmine-2.3.2/work/redmine-2.3.2'

energos redmine #  emerge --info =redmine-2.3.2
Portage 2.2.1 (default/linux/amd64/13.0, gcc-4.8.1, glibc-2.17, 3.10.2-aufs x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.10.2-aufs-x86_64-AMD_Opteron-tm-_Processor_6168-with-gentoo-2.2
KiB Mem:    32950392 total,  30747328 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of tree: Tue, 03 Sep 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.4.7, 4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local-overlay kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/redmine/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/home/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --jobs 25 --load-average 25"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks fixlafiles merge-sync metadata-transfer news nodoc parallel-fetch parallel-install sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.rediris.es/sites/gentoo.org/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo-euetib.upc.es/mirror/gentoo/"
LANG="es_ES"
LC_ALL="es_ES.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j25"
PKGDIR="/home/portage/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/overlay /var/lib/layman/kde"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow acpi amd64 bzip2 cleartype cli corefonts cracklib crypt cxx dbus djvu dri fontconfig ftp gif gmp iconv icu jpeg laptop latex lcms lm_sensors lzma mmx mmxext modules mudflap multilib ncurses network nls nptl nsl openmp openssl pam pango pch pcre pdf pgo png postscript readline session smp spell sse sse2 sse3 ssl ssse3 svg symlink tcpd threads tiff unicode usb xcb xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

www-apps/redmine-2.3.2 was built with the following:
USE="fastcgi imagemagick ldap (multilib) openid passenger -test" ABI_X86="64" RUBY_TARGETS="ruby19 -ruby18"
Comment 1 Alice Ferrazzi Gentoo Infrastructure gentoo-dev 2013-09-04 11:49:46 UTC
Please attach the entire build log to this bug report.
Comment 2 cruzki 2013-09-04 15:44:47 UTC
(In reply to Alice Ferrazzi from comment #1)
> Please attach the entire build log to this bug report.

O.o What you mean for "complete build log"? redmine compiles correctly but fail when configuring. If you mean the "configure build log" I think it is the same as the one posted avobe (I think :S). I will paste below just in case.

In any case, thanks for answering.

***************************************************************************

energos cruzki # cat /home/portage/portage/www-apps/redmine-2.3.2/temp/build.log
 *                                                                                                                                                                                  
 * Upgrading database.
 * 
 * Migrating database.
rake aborted!
undefined method `active_record' for #<Rails::Application::Configuration:0x000000015de368>
/var/lib/redmine/config/application.rb:26:in `<class:Application>'
/var/lib/redmine/config/application.rb:13:in `<module:RedmineApp>'
/var/lib/redmine/config/application.rb:12:in `<top (required)>'
/var/lib/redmine/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)
 * ERROR: www-apps/redmine-2.3.2::gentoo failed (config phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called pkg_config
 *   environment, line 4011:  Called die
 * The specific snippet of code:
 *           RAILS_ENV="${RAILS_ENV}" ${RUBY} -S rake db:migrate || die;
 * 
 * If you need support, post the output of `emerge --info '=www-apps/redmine-2.3.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-apps/redmine-2.3.2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =redmine-2.3.2
 * The complete build log is located at '/home/portage/portage/www-apps/redmine-2.3.2/temp/build.log'.
 * The ebuild environment file is located at '/home/portage/portage/www-apps/redmine-2.3.2/temp/environment'.
 * Working directory: '/var/lib/redmine'
 * S: '/home/portage/portage/www-apps/redmine-2.3.2/work/redmine-2.3.2'
energos cruzki #
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-09-05 11:33:09 UTC
(In reply to cruzki from comment #2)
> O.o What you mean for "complete build log"?

As stated by the output, it shows you where as well as requests you to do so.

> I will paste below just in case.

Please attach build logs to the bug in the future, thank you in advance.
Comment 4 Coacher 2013-09-10 18:36:30 UTC
Please show your `eselect ruby list` output. Do you have ruby-2.0 installed?
Comment 5 cruzki 2013-09-10 18:44:08 UTC
(In reply to Coacher from comment #4)
> Please show your `eselect ruby list` output. Do you have ruby-2.0 installed?

Not until today. I have Ruby 1.9 until today update. I have tested with 2.0 this morning and fails with another error. I will post tomorrow the output of eselect ruby and the new error.
Comment 6 Coacher 2013-09-10 19:07:43 UTC
(In reply to cruzki from comment #5)
> Not until today. I have Ruby 1.9 until today update. I have tested with 2.0
> this morning and fails with another error. I will post tomorrow the output
> of eselect ruby and the new error.

redmine doesn't support ruby-2.0 officially yet and I thought maybe your problem is related to ruby-2.0 installed and being default. Please see this [0] bugreport before posting your error with ruby-2.0.

[0]: https://bugs.gentoo.org/show_bug.cgi?id=484484
Comment 7 Coacher 2013-09-10 19:20:17 UTC
(In reply to Coacher from comment #6)
> (In reply to cruzki from comment #5)
> > Not until today. I have Ruby 1.9 until today update. I have tested with 2.0
> > this morning and fails with another error. I will post tomorrow the output
> > of eselect ruby and the new error.
> 
> redmine doesn't support ruby-2.0 officially yet and I thought maybe your
> problem is related to ruby-2.0 installed and being default. Please see this
> [0] bugreport before posting your error with ruby-2.0.
> 
> [0]: https://bugs.gentoo.org/show_bug.cgi?id=484484

Correction: redmine should support ruby-2.0 already, since 2.3.0
Comment 8 cruzki 2013-09-11 07:55:40 UTC
(In reply to Coacher from comment #4)
> Please show your `eselect ruby list` output. Do you have ruby-2.0 installed?

energos cruzki # eselect ruby list
Available Ruby profiles:
  [1]   ruby19 (with Rubygems) *
  [2]   ruby20 (with Rubygems)

If I change to ruby20 the error now is:

cannot load such file -- rack (LoadError)
  /usr/lib64/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
  /usr/lib64/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:77:in `preload_app'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:127:in `<module:App>'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:6:in `<module:PhusionPassenger>'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:5:in `<main>

Thanks for your help.
Comment 9 Georg Hopp 2013-12-19 14:00:50 UTC
I had exactly the same issue with a fresh gentoo install.

Neither 2.2.4 nor 2.3.2 seem to work under ruby 1.9.

After some experiments I realized that I had 2 version of activerecord
installed. 3.2.16 and 4.0.2 for ruby 1.9 while there was only the 3.2.16
for ruby 1.8.

After I removed the 4.0.2 version I was able to run

emerge --config "=www-apps/redmine-2.2.4"

and

emerge --config "=www-apps/redmine-2.3.2"

with ruby 1.9 without any problem.
Comment 10 Peter Volkov (RETIRED) gentoo-dev 2014-01-10 09:07:03 UTC
cruzki, could you confirm that activerecord-4.0.2 is the source of the problem?
Comment 11 Peter Volkov (RETIRED) gentoo-dev 2014-01-10 11:59:18 UTC
Ok, just reproduced the issue myself.

In my case dev-ruby/railties:4.0 and dependencies were the problem. So I had to selectively unmask specific slots for the following packages:
dev-ruby/activerecord:3.2 ~amd64
dev-ruby/actionpack:3.2 ~amd64
dev-ruby/railties:3.2 ~amd64
dev-ruby/activesupport:3.2 ~amd64

and remove :4.0 versions of this packages.

@ruby: could you comment here? Could you, guys, comment here?
Comment 12 cruzki 2014-01-11 05:55:58 UTC
@Peter Volkov

Thanks for the help. 

I have a terrible flu and I am at home without access to this machine. I will try on Monday.
Comment 13 Hans de Graaff gentoo-dev 2014-01-11 09:30:41 UTC
(In reply to Peter Volkov from comment #11)

> @ruby: could you comment here? Could you, guys, comment here?

all_ruby_prepare() {
    rm Gemfile || die
}

Most likely this is causing the issue since no other mechanism to load the correct package versions looks to be in place, in which case the latest version of packages will be loaded by default.

To fix this, either keep the Gemfile and load things through that, or use some other mechanism like Isolate or manually specifying the correct versions with the 'gem' mechanism.
Comment 14 cruzki 2014-01-13 13:50:13 UTC
After deleting versions :4 of 

dev-ruby/activerecord:3.2 ~amd64
dev-ruby/actionpack:3.2 ~amd64
dev-ruby/railties:3.2 ~amd64
dev-ruby/activesupport:3.2 ~amd64

I have succed in applying 

emerge --config "=www-apps/redmine-2.3.4"

Now it seems my apache is not well configured. Thanks for the help!
Comment 15 Julian Ospald 2014-04-04 14:27:15 UTC
bug is almost half a year old, seems like it's time to hardmask this as broken
Comment 16 Manuel Rüger (RETIRED) gentoo-dev 2014-04-04 18:33:02 UTC
(In reply to Julian Ospald (hasufell) from comment #15)
> bug is almost half a year old, seems like it's time to hardmask this as
> broken

If this is the only criterion, we should probably hardmask 50% of the tree.
Comment 17 Julian Ospald 2014-04-04 18:34:38 UTC
(In reply to Manuel Rüger from comment #16)
> (In reply to Julian Ospald (hasufell) from comment #15230)
> > bug is almost half a year old, seems like it's time to hardmask this as
> > broken
> 
> If this is the only criterion, we should probably hardmask 50% of the tree.

It isn't, please read the whole bug report.
Comment 18 Pacho Ramos gentoo-dev 2016-08-12 14:15:40 UTC
3.2 slots are not available and, then, we cannot fix the deps :/

CCing treecleaners
Comment 19 Hans de Graaff gentoo-dev 2016-08-14 06:38:45 UTC
No need for treecleaner since this bug only applies to the 2.3 versions of redmine. Closing this as OBSOLETE.