Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 483496 - sys-devel/gdb with ncurses[tinfo] and libtermcap-compat: ld: tui.o: undefined reference to symbol 'cbreak'
Summary: sys-devel/gdb with ncurses[tinfo] and libtermcap-compat: ld: tui.o: undefined...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-09-03 14:47 UTC by Jean-Francois Ostiguy
Modified: 2015-12-05 21:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,425.74 KB, text/plain)
2013-09-03 14:48 UTC, Jean-Francois Ostiguy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Ostiguy 2013-09-03 14:47:23 UTC
See build log. 

Portage 2.2.1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.9.9-gentoo x86_64)
=================================================================
System uname: Linux-3.9.9-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem:     8099184 total,   2522004 free
KiB Swap:   25173848 total,  25173764 free
Timestamp of tree: Tue, 03 Sep 2013 14:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            3.4.6-r2, 4.4.7, 4.5.4, 4.6.4, 4.7.3, 4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-portage kde-sunset sunrise
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.mcs.anl.gov/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ rsync://rsync.gtlib.gatech.edu/gentoo rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ rsync://gentoo.cs.uni.edu/gentoo-distfiles"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog --delete-excluded"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/kde-sunset /var/lib/layman/sunrise"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus declarative dri dts dvd dvdr dvdread emboss encode exif fam fftw firefox flac fontconfig fortran gcj gdbm geant4 gif glut gpm gtk iconv icu ipv6 java jpeg kde kerberos kipi kpathsea lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin odbc ogg opengl openmp pam pango pcre pdf phonon php plasma png policykit postgres ppds pulse python qt3support qt4 readline real sdl semantic-desktop session spell sql sqlite sse sse2 ssl startup-notification svg tcpd threads tiff truetype truetype-fonts type1 type1-fonts udev udisks unicode upower usb vhosts vorbis webkit wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" NETBEANS_MODULES="apisupport java websvccommon php profiler" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC, USE_PYTHON


Reproducible: Always
Comment 1 Jean-Francois Ostiguy 2013-09-03 14:48:07 UTC
Created attachment 357766 [details]
build.log
Comment 2 Jeroen Roovers gentoo-dev 2014-03-03 19:37:07 UTC
checking which library has the termcap functions... using libtermcap

It looks like configure.ac is getting confused here. Do you have sys-libs/libtermcap-compat installed?
Comment 3 Francesco Riosa 2014-10-07 22:45:05 UTC
sys-devel/gdb 7.8 is ok
Comment 4 Jeroen Roovers gentoo-dev 2014-10-28 22:56:48 UTC
It picks up a libtermcap from somewhere and we never learned where from, but it's not related to USE=tinfo since it finds libtermcap /before/ it looks for ncurses/termcap/tinfo (in some order, I didn't check).


(In reply to Francesco Riosa from comment #3)
> sys-devel/gdb 7.8 is ok

I have build logs for 7.6.1 that are fine with sys-libs/ncurses[tinfo], too.
Comment 5 SpanKY gentoo-dev 2015-05-06 08:31:37 UTC
a few packages still depend on libtermcap-compat in the tree, and gdb will search for it before tinfo
Comment 6 SpanKY gentoo-dev 2015-12-05 21:07:59 UTC
looking closer, this build doesn't make sense:
checking which library has the termcap functions... using libtermcap

but in order for that to happen, you need to have a libtermcap.so or libtermcap.a file, but nothing in the tree provides that.  libtermcap-compat only provides the libtermcap.so.2 file.

please post the the config.log and the output of doing:
$ echo 'int main(){}' | gcc -Wl,--verbose -x c - -ltermcap