Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 483478 - app-misc/pal-0.4.3-r1 with sys-libs/ncurses[tinfo] - ld: tmp.opt/manage.o: undefined reference to symbol 'cbreak'
Summary: app-misc/pal-0.4.3-r1 with sys-libs/ncurses[tinfo] - ld: tmp.opt/manage.o: un...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-09-03 11:13 UTC by Zoltan Puskas
Modified: 2014-10-28 22:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Use pkg-config in Makefile for ncurses ldflags (pal_ncurses_tinfo.patch,561 bytes, patch)
2013-09-03 11:53 UTC, Zoltan Puskas
Details | Diff
app-misc/pal-0.4.3-r1 build log (build.log,7.16 KB, text/plain)
2013-10-28 16:11 UTC, Zoltan Puskas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Puskas 2013-09-03 11:13:08 UTC
Build is broken in regards to the ncurses/tinfo API changes.

Reproducible: Always

Steps to Reproduce:
1. emerge pal
Actual Results:  
Build failed with the following error message:

...
 [gcc] pal
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: tmp.opt/manage.o: undefined reference to symbol 'cbreak'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'cbreak' is defined in DSO /lib64/libtinfow.so.5 so try adding it to the linker command line
/lib64/libtinfow.so.5: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [pal] Error 1

Expected Results:  
Successful build.

Portage 2.2.1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.10.9-gentoo x86_64)
=================================================================
System uname: Linux-3.10.9-gentoo-x86_64-Intel-R-_Core-TM-_i5-3470_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:     8146588 total,    320932 free
KiB Swap:    4194300 total,   4194236 free
Timestamp of tree: Mon, 02 Sep 2013 10:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0::java-overlay
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo java
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.inode.at/ http://gentoo.inf.elte.hu/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java"
USE="X a52 aac acl acpi alsa amd64 avahi avx bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gphoto2 gpm handbook iconv java6 javascript jpeg jpeg2k kde kipi lcms ldap libnotify lm_sensors mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit posix ppds qt3support qt4 readline sdl semantic-desktop session smp spell sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vcd vim-syntax vorbis wifi wxwidgets x264 xcb xcomposite xinerama xml xmp xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 arm" QEMU_USER_TARGETS="x86_64 arm" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Zoltan Puskas 2013-09-03 11:53:59 UTC
Created attachment 357756 [details, diff]
Use pkg-config in Makefile for ncurses ldflags

Incremental patch that replaces -lncursesw with pkg-config --libs ncursesw. Package builds and works.
Comment 2 Pacho Ramos gentoo-dev 2013-10-13 16:59:12 UTC
looks like it doesn't apply cleanly anymore :(
Comment 3 Zoltan Puskas 2013-10-28 16:10:09 UTC
The attached patch still works for me with app-misc/pal-0.4.3-r1. I have placed it "as is" into "/etc/portage/patches/app-misc/pal-0.4.3-r1". What is the output for you in emerge? My use flags are:

# equery uses pal
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for app-misc/pal-0.4.3-r1:
 U I
 + + nls     : Add Native Language Support (using gettext - GNU locale utilities)
 + + unicode : Add support for Unicode
Comment 4 Zoltan Puskas 2013-10-28 16:11:36 UTC
Created attachment 362138 [details]
app-misc/pal-0.4.3-r1 build log

The complete build log is not too long. Patch applies cleanly. Portage tree is also up to date.
Comment 5 Jeroen Roovers gentoo-dev 2014-10-28 22:11:57 UTC
Fixed without revision bump. Sorry, I missed that patch there.