Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 483134 - dev-lang/vala (all versions) sandbox violation with .git above ${S}
Summary: dev-lang/vala (all versions) sandbox violation with .git above ${S}
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 560308 614728 677772 707922 (view as bug list)
Depends on:
Blocks: 558556
  Show dependency tree
 
Reported: 2013-08-31 12:04 UTC by Florian Schmaus
Modified: 2020-02-02 14:33 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,2.45 KB, text/x-log)
2013-08-31 12:04 UTC, Florian Schmaus
Details
emerge --info (emerge_info,6.59 KB, text/plain)
2013-08-31 12:05 UTC, Florian Schmaus
Details
build.log with vala-0.20.1 (build.log,157.43 KB, text/x-log)
2013-09-08 13:41 UTC, Florian Schmaus
Details
ebuild and external patch (x,1.40 KB, patch)
2014-02-07 06:23 UTC, Michael Weber (RETIRED)
Details | Diff
ebuild patch (x,952 bytes, patch)
2014-02-07 06:37 UTC, Michael Weber (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Schmaus gentoo-dev 2013-08-31 12:04:23 UTC
Emerging dev-lang/vala-0.14.2 (and possible other versions too) failes with a sandbox violation when git is installed and the directory /.git exists

Reproducible: Always
Comment 1 Florian Schmaus gentoo-dev 2013-08-31 12:04:46 UTC
Created attachment 357504 [details]
build.log
Comment 2 Florian Schmaus gentoo-dev 2013-08-31 12:05:01 UTC
Created attachment 357506 [details]
emerge --info
Comment 3 Pacho Ramos gentoo-dev 2013-09-08 10:55:43 UTC
Try with 0.20 slot
Comment 4 Florian Schmaus gentoo-dev 2013-09-08 13:41:42 UTC
Created attachment 358274 [details]
build.log with vala-0.20.1

Same problem with vala:0.20
Comment 5 Pacho Ramos gentoo-dev 2013-09-08 13:56:32 UTC
Maybe this comes from build-aux/git-version-gen, but I don't know why it's being called. Maybe dropping its reference in configure.ac (in the top line), and running eautoreconf after that could help
Comment 6 Pacho Ramos gentoo-dev 2013-12-24 13:17:36 UTC
(In reply to Pacho Ramos from comment #5)
> Maybe this comes from build-aux/git-version-gen, but I don't know why it's
> being called. Maybe dropping its reference in configure.ac (in the top
> line), and running eautoreconf after that could help

Did you try dropping that reference?
Comment 7 Michael Weber (RETIRED) gentoo-dev 2014-02-07 06:23:54 UTC
Created attachment 369762 [details, diff]
ebuild and external patch

(In reply to Pacho Ramos from comment #6)
> Did you try dropping that reference?

did not fix the problem
Comment 8 Michael Weber (RETIRED) gentoo-dev 2014-02-07 06:37:29 UTC
Created attachment 369764 [details, diff]
ebuild patch

just distract the build system
Comment 9 Gilles Dartiguelongue gentoo-dev 2014-02-09 12:43:17 UTC
I see no upstream report yet, could you guys do one and paste the URL here ? It will probably have better chance to get some interest.
Comment 10 Pacho Ramos gentoo-dev 2015-01-24 12:55:56 UTC
(In reply to Michael Weber from comment #7)
> Created attachment 369762 [details, diff] [details, diff]
> ebuild and external patch
> 
> (In reply to Pacho Ramos from comment #6)
> > Did you try dropping that reference?
> 
> did not fix the problem

Does this patch work then? Also, is it still needed for 0.26.2? Was this reported? Thanks :)
Comment 11 Guillaume Lespinasse 2015-05-24 20:16:09 UTC
I can confirm that this bug is still present in version 0.26.2 (removing /.git compiles successfully)

The patches didn't get rid of the sandbox violation, though I had to modify them since they were made specifically for an old version of the ebuild (0.22.1)
Comment 12 Alexandre Rostovtsev (RETIRED) gentoo-dev 2015-09-13 00:17:24 UTC
*** Bug 560308 has been marked as a duplicate of this bug. ***
Comment 13 Coacher 2017-04-05 16:01:18 UTC
*** Bug 614728 has been marked as a duplicate of this bug. ***
Comment 14 Gabriele Svelto 2018-01-18 10:58:29 UTC
For what is worth I just hit this with dev-lang/vala-0.36.7. The only way to install the package was by exporting FEATURES="-sandbox -usersandbox" before invoking emerge.
Comment 15 Larry the Git Cow gentoo-dev 2018-01-28 19:49:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=aa48765f6497dd0443a7bfb747386e7c15e80d90

commit aa48765f6497dd0443a7bfb747386e7c15e80d90
Author:     Michael Weber <xmw@gentoo.org>
AuthorDate: 2018-01-28 19:49:10 +0000
Commit:     Michael Weber <xmw@gentoo.org>
CommitDate: 2018-01-28 19:49:28 +0000

    dev-lang/vala: Limit errornous git invocation to ${WORKDIR} by exporting GIT_CEILING_DIRECTORIES.
    
    Bug: https://bugs.gentoo.org/558556
    Closes: https://bugs.gentoo.org/483134
    Package-Manager: Portage-2.3.20, Repoman-2.3.6

 dev-lang/vala/vala-0.32.1.ebuild | 5 ++++-
 dev-lang/vala/vala-0.34.9.ebuild | 5 ++++-
 dev-lang/vala/vala-0.36.7.ebuild | 3 +++
 3 files changed, 11 insertions(+), 2 deletions(-)
Comment 16 Mart Raudsepp gentoo-dev 2018-01-29 18:11:58 UTC
Hacks without upstream reports don't constitute a fix.
Comment 17 Mart Raudsepp gentoo-dev 2019-02-16 16:20:25 UTC
*** Bug 677772 has been marked as a duplicate of this bug. ***
Comment 18 Larry the Git Cow gentoo-dev 2019-02-16 16:25:13 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9d336568e1ba9cfb5ee04fd70cabc63047377576

commit 9d336568e1ba9cfb5ee04fd70cabc63047377576
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-02-16 16:24:04 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-02-16 16:24:49 +0000

    dev-lang/vala: remove git ceiling dir hack
    
    This was added without maintainer authorization, and doesn't even
    seem to work these days.
    If you have a /.git/ or .git/ somewhere between WORKDIR and /, you
    get to deal with it yourself (or just don't do such odd things).
    Sorry.
    
    Bug: https://bugs.gentoo.org/483134
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 dev-lang/vala/vala-0.32.1.ebuild  | 3 ---
 dev-lang/vala/vala-0.34.16.ebuild | 3 ---
 dev-lang/vala/vala-0.36.15.ebuild | 3 ---
 dev-lang/vala/vala-0.36.17.ebuild | 5 +----
 dev-lang/vala/vala-0.40.13.ebuild | 3 ---
 dev-lang/vala/vala-0.42.5.ebuild  | 3 ---
 6 files changed, 1 insertion(+), 19 deletions(-)
Comment 19 Mart Raudsepp gentoo-dev 2020-02-02 13:54:24 UTC
*** Bug 707922 has been marked as a duplicate of this bug. ***