Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 482950 - dev-lang/php-5.5.2 breaks search in www-apps/mediawiki-1.21.1 (segfault)
Summary: dev-lang/php-5.5.2 breaks search in www-apps/mediawiki-1.21.1 (segfault)
Status: RESOLVED DUPLICATE of bug 471682
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: PHP Bugs
Depends on:
Reported: 2013-08-29 18:17 UTC by Joerg Schaible
Modified: 2015-11-07 02:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Schaible 2013-08-29 18:17:13 UTC
After upgrading from php-5.5.1 to php-5.5.2 (and a restart of apache2), the search in mediawiki is broken, the error_log of apache contains 3 segmentation faults for every search attempt. As alternative I tried to upgrade to php-5.5.3-r1, but the effect is the same (even after reboot of the machine):

=================== %< ===============
[Thu Aug 29 18:44:51 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.1c PHP/5.5.2-pl0-gentoo configured -- resuming normal operations
[Thu Aug 29 18:46:24 2013] [notice] child pid 24096 exit signal Segmentation fault (11)
[Thu Aug 29 18:46:24 2013] [notice] child pid 24101 exit signal Segmentation fault (11)
[Thu Aug 29 18:46:26 2013] [notice] child pid 24178 exit signal Segmentation fault (11)
[Thu Aug 29 19:45:10 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.1c PHP/5.5.3-pl1-gentoo configured -- resuming normal operations
[Thu Aug 29 19:45:34 2013] [notice] child pid 18049 exit signal Segmentation fault (11)
[Thu Aug 29 19:45:34 2013] [notice] child pid 18052 exit signal Segmentation fault (11)
[Thu Aug 29 19:45:36 2013] [notice] child pid 18129 exit signal Segmentation fault (11)
=================== %< ===============

Finally I restored the ebuild for php-5.5.1, installed it, restarted apache and the search in mediawiki works again.

Reproducible: Always

Steps to Reproduce:
1. install and setup stable apache, mediawiki and php-5.5.1
2. use webapp to add page to mediawiki
3. search in webapp for a word in that page
Actual Results:  
browser displays after some seconds standard error for broken connection, error_log of apaceh contains 3 lines with segmentation faults

Expected Results:  
normal result page of webapp

# emerge --info
Portage (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.10.7-gentoo x86_64)
System uname: Linux-3.10.7-gentoo-x86_64-Pentium-R-_Dual-Core_CPU_E6500_@_2.93GHz-with-gentoo-2.2
KiB Mem:     4046404 total,   2209764 free
KiB Swap:   12000548 total,  12000548 free
Timestamp of tree: Thu, 29 Aug 2013 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-local
CFLAGS="-march=native -mtune=native -Os -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -mtune=native -Os -pipe -fno-default-inline"
EMERGE_DEFAULT_OPTS="--autounmask=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2 -s"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl alsa amd64 bash-completion berkdb bzip2 caps cli cracklib crypt cups cxx dbus dri fam fortran gdbm gpm iconv icu idn jpeg jpeg2k logrotate mmx modules mudflap multilib ncurses nls nptl pam pcre png readline session sse sse2 ssl ssse3 syslog tcpd tiff unicode usb vim-syntax xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Joerg Schaible 2013-08-29 18:18:09 UTC
I also tried to rebuild apache and mediawiki with newer php-5.5.2 installed.
Comment 2 Ole Markus With (RETIRED) gentoo-dev 2013-08-30 13:07:55 UTC
Hi. If you want us to do anything about this bug, you have to find a smaller script that reproduces the error. Now it is impossible for us to see where the error might be.
Comment 3 Christopher Crammond 2013-09-01 02:32:14 UTC
I am also experiencing this bug, same scenario/symptoms as the bug filer.  Perhaps this could be related to the PHP Bug 64836 (  There the proposed workaround was to downgrade to sys-app/file-5.11.  I tried this, but it did not work for me.  :\

Also, the PHP references Gentoo Bug #471682 (
Comment 4 KevinOfOz 2013-09-02 14:35:17 UTC
Also experiencing the segmntation fault on search in Mediawiki-1.21.1 and php-5.5.2.

Switching back to php-5.4 solves the problem.
Comment 5 Michael Orlitzky gentoo-dev 2015-11-07 02:29:30 UTC

*** This bug has been marked as a duplicate of bug 471682 ***