Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 482754 - app-editors/gvim-7.4.5: E25: GUI cannot be used: Not enabled at compile time
Summary: app-editors/gvim-7.4.5: E25: GUI cannot be used: Not enabled at compile time
Status: UNCONFIRMED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-28 06:08 UTC by Massimo Burcheri
Modified: 2016-08-02 08:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-editors:gvim-7.4.5:20130828-102526.log (file_482754.txt,40.57 KB, text/plain)
2013-08-28 11:44 UTC, Massimo Burcheri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Burcheri 2013-08-28 06:08:51 UTC
I have built gvim with similar USE flags as on native Gentoo. But starting gvim fails. vim works but is built without GUI.

The prefix access is over SSH with X-forwarding enabled by -Y and was active at compile time, xclock works there as well as the local gvim from host distribution (Prefix on Linux).

Reproducible: Always

Actual Results:  
$ gvim --version
E25: GUI cannot be used: Not enabled at compile time

$ type gvim
gvim is hashed (/home/mo/gentoo/usr/bin/gvim)

$ vim --version |grep version
Huge version without GUI.  Features included (+) or not (-):

$ /usr/bin/gvim --version |head -n5
VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Jun 25 2011 09:42:35)
Included patches: 1-411
Modified by <bugzilla@redhat.com>
Compiled by <bugzilla@redhat.com>
Huge version with GTK2 GUI.  Features included (+) or not (-):

$ equery --quiet uses gvim vim
+X
-acl
+cscope
-debug
-gnome
+gtk
-lua
-luajit
-minimal
-motif
-neXt
-netbeans
+nls
+perl
+python
-python_single_target_python2_6
+python_single_target_python2_7
-python_single_target_python3_2
-python_single_target_python3_3
-python_targets_python2_6
+python_targets_python2_7
+python_targets_python3_2
-python_targets_python3_3
-ruby

+X
-acl
+cscope
-debug
-lua
-luajit
-minimal
+nls
+perl
+python
-python_single_target_python2_6
+python_single_target_python2_7
-python_single_target_python3_2
-python_single_target_python3_3
-python_targets_python2_6
+python_targets_python2_7
+python_targets_python3_2
-python_targets_python3_3
-ruby
+vim-pager




$ emerge --info

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

        default/linux/amd64/13.0/no-multilib

You may use the following command to upgrade:

        eselect profile set default/linux/amd64/13.0/no-multilib

Portage 2.2.01.22288-prefix (prefix/linux/amd64, gcc-4.6.3, unavailable, 2.6.32-71.29.1.el6.x86_64 x86_64)
=================================================================
System uname: Linux-2.6.32-71.29.1.el6.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-centos-6.0-Final
KiB Mem:     3948868 total,    672836 free
KiB Swap:   16000732 total,   9426732 free
Timestamp of tree: Mon, 26 Aug 2013 22:05:58 +0000
ld GNU ld (GNU Binutils) 2.23
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.5-r2, 3.2.3-r2, 3.3.2-r2
dev-util/ccache:          3.1.8
dev-util/pkgconfig:       0.28
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.4
sys-devel/binutils:       2.23
sys-devel/gcc:            4.4.6-r1, 4.6.3
sys-devel/gcc-config:     1.8-r00.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
Repositories: gentoo_prefix portage_mnr_gentoo-prefix
ACCEPT_KEYWORDS="~amd64-linux"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/home/mo/gentoo/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distcc distcc-pump distlocks ebuild-locks fixlafiles force-prefix merge-sync news notitles parallel-fetch parallel-install preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.halifax.rwth-aachen.de/gentoo http://de-mirror.org/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j24"
PKGDIR="/home/mo/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/home/mo/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/mo/gentoo/var/tmp"
PORTDIR="/home/mo/gentoo/usr/portage"
PORTDIR_OVERLAY="/home/mo/gentoo/usr/local/portage"
USE="X amd64 apng bash-completion berkdb bzip2 cli cracklib crypt cscope cxx dri fortran gcj gdbm hbci iconv java mercurial mmx modules mudflap ncurses nls nptl openmp optimization pcre perl png prefix python qt3support readline session sse sse2 ssl strong-optimization subversion tcpd unicode vim-pager vim-syntax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Massimo Burcheri 2013-08-28 11:44:45 UTC
Created attachment 357236 [details]
app-editors:gvim-7.4.5:20130828-102526.log

There is
checking for GTK - version >= 2.2.0... no.

Appearently x11-libs/gtk+ is not emerged by emerge -auNDv gvim, eventhough USE="gtk" is enabled.
Comment 2 Massimo Burcheri 2013-08-28 12:23:02 UTC
gvim is working now after manually installing x11-libs/gtk+ with all its deps.

So the dependencies of gvim are failing somehow.
Comment 3 Fabian Groffen gentoo-dev 2013-09-10 15:33:57 UTC
odd, the dependencies DO suggest a gtk+ dep:

        gtk? (
            >=x11-libs/gtk+-2.6:2
            x11-libs/libXft
            gnome? ( >=gnome-base/libgnomeui-2.6 )
        )