Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 48124 - arts-1.2.1 failed to compile, due to not available
Summary: arts-1.2.1 failed to compile, due to not available
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-04-17 06:20 UTC by Tom Fredrik Blenning Klaussen
Modified: 2005-07-22 11:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tom Fredrik Blenning Klaussen 2004-04-17 06:20:02 UTC
When I tried to emerge arts-1.2.1 it tried to access a file /var/tmp/portage/jpeg-6b-r3/image//usr/lib/
This file is not there.

Reproducible: Always
Steps to Reproduce:

Actual Results:  
/bin/sh ../libtool --silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor -Wno-l
ong-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversi
on -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG
-DNO_DEBUG -O2 -march=pentium3 -O3 -pipe -Wformat-security
-Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common 
-ftemplate-depth-99    -o -rpath /usr/kde/3.2/lib -no-undefined
-Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 1:0 -R
/usr/kde/3.2/lib -R /usr/qt/3/lib -R /usr/X11R6/lib  -L/usr/qt/3/lib
-L/usr/X11R6/lib  qiomanager.lo ../mcop/ -lqt-mt -ljpeg -lz -lpng -lz
-lm -lXext -lX11  -lSM -lICE -lpthread 
grep: /var/tmp/portage/jpeg-6b-r3/image//usr/lib/ No such file or
/bin/sed: can't read /var/tmp/portage/jpeg-6b-r3/image//usr/lib/ No
such file or directory
libtool: link: `/var/tmp/portage/jpeg-6b-r3/image//usr/lib/' is not a
valid libtool archive
make[2]: *** [] Error 1
make[2]: Leaving directory `/var/tmp/portage/arts-1.2.1/work/arts-1.2.1/qtmcop'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/arts-1.2.1/work/arts-1.2.1'
make: *** [all] Error 2

!!! ERROR: kde-base/arts-1.2.1 failed.
!!! Function kde_src_compile, Line 128, Exitcode 2
!!! died running emake, kde_src_compile:make

Output from "emerge info"Portage 2.0.50-r6 (default-x86-1.4, gcc-3.3.2,
glibc-2.3.2-r3, 2.4.22-gentoo-r2-
System uname: 2.4.22-gentoo-r2-fix2 i686 Pentium III (Katmai)
Gentoo Base System version 1.4.9
distcc 2.11.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=pentium3 -O3 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1
/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm
/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /us
r/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O3 -pipe"
FEATURES="autoaddcvs ccache distcc sandbox"
USE="3ds X Xaw3d aalib acl acpi acpi4linux alsa amd apache2 apm arts avi berkdb
bots canna crypt cups curl dedicated dga directfb dnd doc dvd emacs encode esd
evo exiscan exiscan-acl faad flash foomaticdb foreign-package freewnn gb gd gif
ginac gmtfull gmthigh gmtsuppl gmttria gtk gtk2 imlib ipv6 java jikes jpeg kde
ladcca lcms leim libg++ libgda libwww mad maildir matroska md5sum mikmod motif
mozilla moznocompose moznoirc moznomail mpeg mpi mule music mysql nas ncurses
nls odbc offensive oggvorbis opengl oss pam parse-clocks pdflib perl png python
qt quicktime readline ruby samba sdl slang slp spell sse ssl svga tcltk tcpd
tiff truetype wxwindows x86 xinerama xml xml2 xmms xv zlib"

I also tried to add "noclean keepwork keeptemp" to features, and reemerge "jpeg"
this did not seem to help.
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2004-04-17 09:48:26 UTC
This isn't a kde problem.  You have a ".la" file in your /usr/lib directory that is pointing to a bogus location of libjpeg.  You should be able to figure out which file using "grep" and fix it, and all will be happy again.
Comment 2 Tom Fredrik Blenning Klaussen 2004-04-18 02:47:08 UTC
You are quite right, seemed libraries from "media-libs/libmng" and "media-libs/imlib" had pointers to that location. Anyway, everything worked out just fine.
Comment 3 Tom Fredrik Blenning Klaussen 2005-07-22 11:46:24 UTC
Closing bug