Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 481074 - sys-apps/portage-2.2.0 - emerge shows blocking packages only at the first call
Summary: sys-apps/portage-2.2.0 - emerge shows blocking packages only at the first call
Status: UNCONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2013-08-14 17:19 UTC by Toralf Förster
Modified: 2013-08-16 07:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2013-08-14 17:19:42 UTC
2 subsequent calls in a row brought a different picture at an chrooted 32 bit Gentoo ~x86 Linux :

n22 ~ # eix-update -q && emerge --update @world --deep --changed-use --with-bdeps=y --ask
These are the packages that would be merged, in reverse order:

Calculating dependencies  ... done!
[ebuild     U  ] app-admin/syslog-ng-3.4.3 [3.4.2]
[ebuild     U  ] sys-fs/cryptsetup-1.6.2 [1.6.1]
[ebuild     U  ] app-editors/vim-7.4 [7.3.1214] USE="-lua% -luajit%" 
[nomerge       ] perl-core/CPAN-Meta-2.132.140 [2.120.921]
[nomerge       ]  virtual/perl-ExtUtils-MakeMaker-6.720.0 [6.640.0]
[nomerge       ]   perl-core/ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ]    virtual/perl-CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]     perl-core/CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]      virtual/perl-ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ]       perl-core/ExtUtils-MakeMaker-6.720.0 [6.640.0]
[nomerge       ]  sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%" 
[ebuild  N     ]   net-misc/netifrc-0.1 
[ebuild     U  ]    sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%" 
[nomerge       ] net-print/cups-1.6.3-r2 
[nomerge       ]  net-print/foomatic-filters-4.0.17-r1 
[ebuild     U  ]   net-print/cups-filters-1.0.36-r1 [1.0.35-r1]
[nomerge       ] dev-db/mysql-5.5.32 
[nomerge       ]  dev-perl/DBD-mysql-4.20.0 
[ebuild     U  ]   dev-perl/DBI-1.628.0 [1.623.0]
[ebuild     U  ]    virtual/perl-Sys-Syslog-0.330.0 [0.320.0]
[ebuild     U  ]     perl-core/Sys-Syslog-0.330.0 [0.320.0]
[nomerge       ] dev-perl/DBI-1.628.0 [1.623.0]
[nomerge       ]  dev-perl/PlRPC-0.202.0 
[ebuild     U  ]   virtual/perl-Storable-2.450.0 [2.390.0]
[ebuild     U  ]    perl-core/Storable-2.450.0 [2.390.0]
[nomerge       ] perl-core/CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]  virtual/perl-Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ]   perl-core/Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ]  virtual/perl-Parse-CPAN-Meta-1.440.500 [1.440.400]
[ebuild     U  ]   perl-core/Parse-CPAN-Meta-1.440.500 [1.440.400]
[nomerge       ] app-editors/vim-7.4 [7.3.1214] USE="-lua% -luajit%" 
[ebuild     U  ]  app-editors/vim-core-7.4 [7.3.1214] USE="-minimal%" 
[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking net-misc/netifrc-0.1)

Would you like to merge these packages? [Yes/No] No

Quitting.

n22 ~ # cp /etc/conf.d/net /var/tmp/

n22 ~ # eix-update -q && emerge --update @world --deep --changed-use --with-bdeps=y --ask

These are the packages that would be merged, in reverse order:

Calculating dependencies  . ..... done!
[ebuild     U  ] app-editors/vim-7.4 [7.3.1214] USE="-lua% -luajit%" 
[ebuild     U  ] app-admin/syslog-ng-3.4.3 [3.4.2]
[ebuild     U  ] sys-fs/cryptsetup-1.6.2 [1.6.1]
[nomerge       ] perl-core/CPAN-Meta-2.132.140 [2.120.921]
[nomerge       ]  virtual/perl-ExtUtils-MakeMaker-6.720.0 [6.640.0]
[nomerge       ]   perl-core/ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ]    virtual/perl-CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]     perl-core/CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]      virtual/perl-ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ]       perl-core/ExtUtils-MakeMaker-6.720.0 [6.640.0]
[nomerge       ] dev-db/mysql-init-scripts-2.0_pre1-r3
[nomerge       ]  sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%"
[ebuild  N     ]   net-misc/netifrc-0.1
[ebuild     U  ]    sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%"
[nomerge       ] net-print/cups-1.6.3-r2
[nomerge       ]  net-print/foomatic-filters-4.0.17-r1
[ebuild     U  ]   net-print/cups-filters-1.0.36-r1 [1.0.35-r1]
[nomerge       ] dev-db/mysql-5.5.32
[nomerge       ]  dev-perl/DBD-mysql-4.20.0
[ebuild     U  ]   dev-perl/DBI-1.628.0 [1.623.0]
[ebuild     U  ]    virtual/perl-Sys-Syslog-0.330.0 [0.320.0]
[ebuild     U  ]     perl-core/Sys-Syslog-0.330.0 [0.320.0]
[nomerge       ] dev-perl/DBI-1.628.0 [1.623.0]
[nomerge       ]  dev-perl/PlRPC-0.202.0
[ebuild     U  ]   virtual/perl-Storable-2.450.0 [2.390.0]
[ebuild     U  ]    perl-core/Storable-2.450.0 [2.390.0]
[nomerge       ] perl-core/CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ]  virtual/perl-Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ]   perl-core/Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ]  virtual/perl-Parse-CPAN-Meta-1.440.500 [1.440.400]
[ebuild     U  ]   perl-core/Parse-CPAN-Meta-1.440.500 [1.440.400]
[nomerge       ] app-editors/vim-7.4 [7.3.1214] USE="-lua% -luajit%"
[ebuild     U  ]  app-editors/vim-core-7.4 [7.3.1214] USE="-minimal%"

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests
>>> Emerging (1 of 20) app-editors/vim-core-7.4
>>> Jobs: 0 of 20 complete, 1 running               Load avg: 13.0, 11.1, 8.5
Comment 1 Arfrever Frehtes Taifersar Arahesis 2013-08-14 20:37:31 UTC
Probably result of hash randomization. When you call that command multiple times again, then sometimes you should reproduce this behavior, which happened during first call.
Comment 2 Toralf Förster gentoo-dev 2013-08-15 16:37:37 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #1)
> Probably result of hash randomization. When you call that command multiple
> times again, then sometimes you should reproduce this behavior, which
> happened during first call.

Pfff ... for package manager an brave behaviour
Comment 3 Zac Medico gentoo-dev 2013-08-15 18:53:39 UTC
(In reply to Toralf Förster from comment #2)
> (In reply to Arfrever Frehtes Taifersar Arahesis from comment #1)
> > Probably result of hash randomization. When you call that command multiple
> > times again, then sometimes you should reproduce this behavior, which
> > happened during first call.
> 
> Pfff ... for package manager an brave behaviour

Hash randomization is enabled by default since Python 3.3, so it's not really portage's choice.

(In reply to Toralf Förster from comment #0)
> [nomerge       ] app-editors/vim-7.4 [7.3.1214] USE="-lua% -luajit%" 
> [ebuild     U  ]  app-editors/vim-core-7.4 [7.3.1214] USE="-minimal%" 
> [blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking
> net-misc/netifrc-0.1)
> 
> Would you like to merge these packages? [Yes/No] No

This part is a little confusing for me, because it looks like there's an unresolved blocker but then it asks you if you want to go ahead and merge the packages. Is that exactly how the output appeared, or did you edit it some?
Comment 4 Toralf Förster gentoo-dev 2013-08-15 21:04:18 UTC
(In reply to Zac Medico from comment #3)
> 
> This part is a little confusing for me, because it looks like there's an
> unresolved blocker but then it asks you if you want to go ahead and merge
> the packages. Is that exactly how the output appeared, or did you edit it
> some?

No - I did not edit it - that's why I'm so confused too.
Comment 5 Zac Medico gentoo-dev 2013-08-16 02:39:01 UTC
I've looked through the blocker handling code and I still don't don't understand how it could ask you to merge the packages with an unsolved blocker like that. Have you been able to reproduce it more than once?
Comment 6 Toralf Förster gentoo-dev 2013-08-16 06:54:19 UTC
(In reply to Zac Medico from comment #5)
> I've looked through the blocker handling code and I still don't don't
> understand how it could ask you to merge the packages with an unsolved
> blocker like that. Have you been able to reproduce it more than once?

I could install those packages at th2 2nd attempt.
I could never reproduce it.
(And FWIW I'm sure I did not run an "emerge sync" in another terminal - I cannot understand it too, therefore this bug report)