Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 480526 - =app-editors/emacs-24.3-r2 - segmentation fault in `/bin/pwd`/temacs --batch --load loadup bootstrap
Summary: =app-editors/emacs-24.3-r2 - segmentation fault in `/bin/pwd`/temacs --batch ...
Status: RESOLVED DUPLICATE of bug 456970
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Emacs project
Depends on:
Reported: 2013-08-10 19:23 UTC by Graham Murray
Modified: 2013-08-11 14:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Build Log (app-editors:emacs-24.3-r2:20130810-175216.log,196.59 KB, text/plain)
2013-08-10 19:23 UTC, Graham Murray

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Murray 2013-08-10 19:23:07 UTC
Created attachment 355630 [details]
Build Log

Dumping under the name emacs
Warning: Your system has a gap between BSS and the
heap (58179551 bytes).  This usually means that exec-shield
or something similar is in effect.  The dump may
fail because of this.  See the section about
exec-shield in etc/PROBLEMS for more information.
/bin/sh: line 7: 19742 Segmentation fault      `/bin/pwd`/temacs --batch --load loadup bootstrap

I have tried both possible workarounds from the PROBLEMS file but still get the segfault.

emerge --info =app-editors/emacs-24.3-r2
Portage 2.2.0_alpha196 (hardened/linux/amd64, gcc-4.8.1, glibc-2.17, 3.10.5-hardened x86_64)
                         System Settings
System uname: Linux-3.10.5-hardened-x86_64-Intel-R-_Core-TM-_i5-2320_CPU_@_3.00GHz-with-gentoo-2.2
KiB Mem:     8159532 total,    499584 free
KiB Swap:   16777212 total,  16737712 free
Timestamp of tree: Sat, 10 Aug 2013 16:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.3.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.4, 4.7.3, 4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo raiagent x11 gamerlay fidonet Graham-s-Local-Portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -mtune=native -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/raiagent /var/lib/layman/x11 /var/lib/layman/gamerlay /var/lib/layman/fidonet /usr/local/portage"
USE="X a52 aac acl alsa amd64 apache2 berkdb branding bzip2 cairo caps cdda cddb cli cracklib crypt cups cxx dbus directfb doc dri dts dvd emacs encode examples exif fam ffmpeg flac fontconfig fortran gd gdbm geoip gif gmp gnome gnome-keyring gnutls gpm gstreamer gtk hardened iconv icu imagemagick introspection ipv6 java jpeg jpeg2k justify kde lcms libnotify lua lzma mad matroska milter mmx mng modules mp3 mpeg mudflap multilib mysql ncurses nls nptl nsplugin ogg opengl openmp pam pax_kernel pcre perl pfd png policykit postgres ppds pulseaudio python qt4 raw readline sdl semantic-desktop session speex spell sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff tk truetype udev unicode urandom usb v4l vdpau vim-syntax vorbis x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi krita sheets words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby18 ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-editors/emacs-24.3-r2 was built with the following:
USE="X alsa dbus games gconf gif gnutls gpm gtk gtk3 imagemagick jpeg libxml2 pax_kernel png sound svg tiff xft xpm -Xaw3d (-aqua) -athena -gsettings -gzip-el -hesiod -kerberos -livecd -m17n-lib -motif (-selinux) -source -toolkit-scroll-bars -wide-int"
Comment 1 Ulrich Müller gentoo-dev 2013-08-11 14:00:24 UTC

*** This bug has been marked as a duplicate of bug 456970 ***