Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 480194 - sys-apps/portage-2.1.12.13: pulling unnecessary dependencies during oneshot upgrade
Summary: sys-apps/portage-2.1.12.13: pulling unnecessary dependencies during oneshot u...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: AMD64 Linux
: Normal blocker (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2013-08-07 18:54 UTC by Paul Slinski
Modified: 2014-12-04 06:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix --backtrack=0 to work properly (see issue in comment #3) (backtrack_0.patch,873 bytes, patch)
2013-08-07 19:28 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Slinski 2013-08-07 18:54:47 UTC
Unable to oneshot upgrade portage-2.1.13.5 due to other dependencies being pulled in. 

Reproducible: Always

Steps to Reproduce:
1. emerge -pv --oneshot portage
2.
3.
Actual Results:  
heavy ~ # emerge -pv --oneshot portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/portage-2.1.13.5 [2.1.12.13] USE="(ipc) xattr -build -doc -epydoc (-pypy2_0) -python2 -python3 (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_2 -pypy1_9 -pypy2_0 -python2_6 -python3_1 -python3_3 (-python3_4)" 876 kB
[ebuild  NS    ] media-libs/gupnp-dlna-0.10.2:2.0 [0.6.6:1.0] USE="introspection" 307 kB
[ebuild     U  ] dev-util/gdbus-codegen-2.36.3 [2.34.3] PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 -python3_3" 6,472 kB
[ebuild     U  ] dev-libs/glib-2.36.3-r1:2 [2.34.3:2] USE="utils xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test}" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%" 0 kB
[ebuild     U  ] net-libs/libsoup-2.42.2:2.4 [2.40.3:2.4] USE="introspection samba ssl -debug {-test}" 716 kB
[ebuild  NS    ] net-libs/libgrss-0.5.0:0.5 [0.3.0:0] USE="-debug -examples" 430 kB
[ebuild   R    ] net-libs/libsocialweb-0.25.21  USE="gnome introspection vala* -connman -networkmanager" 0 kB
[ebuild     U  ] net-libs/gnome-online-accounts-3.8.2 [3.6.3] USE="gnome introspection -debug -kerberos" 631 kB
[ebuild     U  ] gnome-extra/evolution-data-server-3.8.4:0/40 [3.6.4:0/40] USE="gnome-online-accounts gtk%* introspection ipv6 ldap vala* weather -api-doc-extras -kerberos {-test}" 3,841 kB
[ebuild  r  U  ] app-emulation/wine-1.7.0 [1.6] USE="X alsa cups fontconfig gecko gphoto2 gstreamer jpeg lcms ldap mono mp3 ncurses nls openal opengl perl png prelink pulseaudio run-exes samba scanner ssl threads truetype udisks v4l xcomposite xinerama xml -capi -custom-cflags -dos -gsm -odbc -opencl -osmesa -oss (-selinux) {-test}" ABI_X86="32 64 (-x32)" LINGUAS="-ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 20,768 kB
[ebuild     U  ] app-misc/tracker-0.16.2:0/16 [0.14.5:0/14] USE="cue exif firefox-bookmarks flac gif gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf playlist rss thunderbird tiff upnp-av vorbis xml (-eds) -gsf -iptc -laptop -libsecret% -networkmanager {-test} -xine -xmp -xps (-applet%) (-flickr%*) (-gnome-keyring%*)" 5,845 kB
[ebuild     U  ] gnome-extra/nautilus-tracker-tags-0.16.2 [0.14.5] 0 kB
[ebuild     U  ] gnome-extra/zeitgeist-0.9.14 [0.9.12-r1] USE="datahub downloads-monitor extensions fts icu introspection nls telepathy -plugins -sql-debug (-dbus%*)" PYTHON_TARGETS="python2_7 -python2_6" 0 kB
[ebuild     U  ] dev-libs/folks-0.9.3:0/25 [0.8.0:0/25] USE="eds socialweb telepathy tracker utils vala zeitgeist%* -debug {-test}" 1,613 kB
[ebuild  r  U  ] net-im/empathy-3.8.3 [3.6.4] USE="geoloc gnome gnome-online-accounts map spell v4l -debug {-test} (-geocode%*) (-sendto%*)" 4,606 kB

Total: 15 packages (12 upgrades, 2 in new slots, 1 reinstall), Size of downloads: 46,099 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36.3:2 required by (dev-util/gdbus-codegen-2.36.3::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (dev-libs/glib-2.34.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

net-libs/gnome-online-accounts:0

  (net-libs/gnome-online-accounts-3.6.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnome-online-accounts-3.8.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/gnome-online-accounts-3.7.90 required by (gnome-extra/evolution-data-server-3.8.4::gentoo, ebuild scheduled for merge)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42:2.4 required by (net-libs/gnome-online-accounts-3.8.2::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.6.4::gentoo, installed) pulled in by
    =gnome-extra/evolution-data-server-3.6* required by (mail-client/evolution-3.6.4::gentoo, installed)

  (gnome-extra/evolution-data-server-3.8.4::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-extra/evolution-data-server-3.8.1:=[vala] required by (dev-libs/folks-0.9.3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

app-misc/tracker:0

  (app-misc/tracker-0.14.5::gentoo, installed) pulled in by
    >=app-misc/tracker-0.14:0/14= required by (gnome-base/nautilus-3.6.3::gentoo, installed)
    (and 2 more with the same problem)

  (app-misc/tracker-0.16.2::gentoo, ebuild scheduled for merge) pulled in by
    ~app-misc/tracker-0.16.2 required by (gnome-extra/nautilus-tracker-tags-0.16.2::gentoo, ebuild scheduled for merge)
    >=app-misc/tracker-0.16:= required by (dev-libs/folks-0.9.3::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Expected Results:  
Upgrade without dependency issues.

heavy ~ # emerge --info
Portage 2.1.12.13 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.17, 3.9.6-gentoo x86_64)
=================================================================
System uname: Linux-3.9.6-gentoo-x86_64-AMD_Phenom-tm-_II_X4_810_Processor-with-gentoo-2.2
KiB Mem:     4055312 total,    516108 free
KiB Swap:  311521620 total, 310546764 free
Timestamp of tree: Tue, 06 Aug 2013 21:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -msse3 -msse4a -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -msse3 -msse4a -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac aacplus aacs aalib acl acpi addns afp aften alsa amd64 amr ap apm applet appletalk archive artworkextra astrality attica autopid avahi avx bash-completion berkdb bluetooth bluray bogofilter bookmarks branding bs2b bufferevents bzip2 cairo caps cdda cddb cdparanoia cdr cli clutter connection-sharing conntrack consolekit contrast corefonts cracklib crypt cue cups curl cvs cxx daap dbus device-mapper dga dhcp dillo dirac dlna down-root download downloads-monitor dri dts dv dvb dvd dvdr eds emboss emoticon emotion encode equalizer exif extensions extras faac faad fam fat ffmpeg fingerprint firefox firefox-bookmarks fits flac flash flickr fontconfig fontforge fortran fping frei0r fuse gcdmaster gconf gcrypt gdbm gdu geonames gif gimp gles1 gles2 gme gnome gnome-keyring gnome-online-accounts googledrive gphoto2 gpm gps graphicsmagick graphviz grilo growl gsmloc gstreamer gtk gtk3 hfs hostip http httpd hyphenation iconv icq icu id3tag iec61883 ieee1394 image imlib infinality introspection ios ipod ipv6 irc jabber jack jai jpeg jpeg2k jruby karma kate kde lame lastfm lcms ldap lensfun libass libcaca libnotify libsamplerate lua lzma lzo mad map matroska md5sum media mercurial midi mjpeg mms mmx mmxext mng modules mp3 mp4 mpeg mplayer msn mtp mudflap multicore multilib musepack mysql nas nat-pmp nautilus ncurses network nfs nfsv3 nfsv4 nls nmap nmap-update nntp nominatim nping nptl nsplugin nss ntfs ntp nut nvidia offensive ogg omxil openal openexr opengl openmp openrc openvpn opus p2p pam pango passwordsave pch pcre pdf perl pidgin plasma playlist plazes plugins png pnm policykit portaudio postproc postscript ppds ppp prediction projectm pulseaudio python qt3support qt4 quicktime rar raw readline resolvconf rss rtmp rtsp ruby samba sasl sbsms scanner schroedinger script scrobbler sdl sdlgfx semantic-desktop sendto sensord session shine shout shx sip skins slideshow smbsharemodes smp sndfile socialweb soundtouch spamassassin spell sqlite sse sse2 sse3 sse4 ssh ssl ssse3 startup-notification subtitles subversion svg swat switcher taglib tcl tcpd telepathy tga theora threads thumbnail thunar thunderbird tiff tk tokyocabinet tools tor-hardening tracker truetype tty-helpers twolame udev udisks udisks2 ukit unicode upcall upnp upnp-av upower usb utilities utils v4l vaapi vamp vcd vcdx vdpau vlm vorbis vpx wavpack web webkit wifi winbind wma-fixed wmf wps wxwidgets x264 xanim xattr xcb xcomposite xface xinerama xml xorg xosd xpm xscreensaver xv xvid yahoo yahoo-geo zeitgeist zeroconf zlib zoran zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_CA" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby20 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nv v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Paul Slinski 2013-08-07 19:00:05 UTC
Apologies for the ugly cut/paste. Here's a pastebin of that emerge output: http://pastebin.com/ZnYSNXBh
Comment 2 Zac Medico gentoo-dev 2013-08-07 19:03:43 UTC
The issue is that it pulls in rebuilds for broken slot-operator dependencies. You can avoid that by adding --backtrack=0 to your options like this:

  emerge --oneshot --backtrack=0 portage
Comment 3 Paul Slinski 2013-08-07 19:15:36 UTC
Unfortunately, that results in nothing happening.
Comment 4 Zac Medico gentoo-dev 2013-08-07 19:24:05 UTC
(In reply to Paul Slinski from comment #3)
> Unfortunately, that results in nothing happening.

Please attach a debug log created as follows:

  emerge --oneshot --backtrack=0 portage --debug 2>&1 >debug.log
  xz -9 debug.log
Comment 5 Zac Medico gentoo-dev 2013-08-07 19:25:16 UTC
(In reply to Zac Medico from comment #4)
> (In reply to Paul Slinski from comment #3)
> > Unfortunately, that results in nothing happening.
> 
> Please attach a debug log created as follows:
> 
>   emerge --oneshot --backtrack=0 portage --debug 2>&1 >debug.log
>   xz -9 debug.log

Nevermind, since I see that you have portage-2.1.12.13 installed, you need this patch:

 http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=c6679936d162f35a330ce541ec4cd0567ccf76d8
Comment 6 Zac Medico gentoo-dev 2013-08-07 19:28:52 UTC
Created attachment 355368 [details, diff]
fix --backtrack=0 to work properly (see issue in comment #3)

Save as /tmp/backtrack_0.patch and apply as follows:

  patch /usr/lib/portage/pym/_emerge/depgraph.py /tmp/backtrack_0.patch
Comment 7 Paul Slinski 2013-08-07 20:13:20 UTC
Thanks, that did it. Now I can move on to scratching my head with the other issues.
Comment 8 Brian Dolbec gentoo-dev 2014-12-04 05:54:47 UTC
Zac, is this problem still an issue?  Or can we close it?