Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 480000 - www-servers/apache-2.2.24-r1: Invalid command 'LanguagePriority'
Summary: www-servers/apache-2.2.24-r1: Invalid command 'LanguagePriority'
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Apache Team - Bugzilla Reports
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-06 23:09 UTC by Martin Mokrejš
Modified: 2021-04-28 19:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2013-08-06 23:09:04 UTC
It seems the default /etc/apache2/modules.d/00_languages.conf is wrong.

# /etc/init.d/apache2 start
 * apache2 has detected an error in your setup:
Syntax error on line 71 of /etc/apache2/modules.d/00_languages.conf:
Invalid command 'LanguagePriority', perhaps misspelled or defined by a module not included in the server configuration
 * ERROR: apache2 failed to start
#


Maybe these are for 2.4 apache while NOT for 2.2 series? Too bad, I need mod_python and hence 2.2 series if I remember right.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2014-05-22 17:05:49 UTC
Perhaps a necessary module is missing. I've seen a similar message in 00_apache_manual.conf when negotiation_module was missing.
Comment 2 Pacho Ramos gentoo-dev 2018-03-20 13:54:14 UTC
is this solved in 2.4.x then? 2.2.x is end of life and with no new updates since Dec 2017...
Comment 3 Martin Mokrejš 2018-03-20 16:28:02 UTC
First of all, I do not know on which host I faced this issue.

I upgraded one now from www-servers/apache-2.2.29 to www-servers/apache-2.2.34 but the config file either did not change or 'etc-update' does not offer me any tweaks.

Well, the file was probably just during the upgrade silently replaced by www-servers/apache-2.2.34, see timestamp.

# ls -latr /etc/apache2/modules.d/00_languages.conf
-rw-r--r-- 1 root root 5040 Mar 20 17:03 /etc/apache2/modules.d/00_languages.conf

The above conf file calls the LanguagePriority .

Both
https://httpd.apache.org/docs/2.2/mod/mod_negotiation.html and https://httpd.apache.org/docs/2.4/mod/mod_negotiation.html
contain this directive, so I am puzzled. I not not skilled enough to find when they added this directive to 2.2 series.

I do not even have set APACHE2_MODULES in make.conf on this host which is good in this case because it would use a chance the deemed necessary module is not loaded. Either it is in defaults, or the issue was on another host.

# emerge --info
WARNING: One or more repositories have missing repo_name entries:

	/var/lib/layman/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.


Portage 2.3.6 (python 2.7.12-final-0, default/linux/amd64/17.0, gcc-6.4.0, glibc-2.25-r9, 4.14.13-default x86_64)
=================================================================
System uname: Linux-4.14.13-default-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.4.1
KiB Mem:    16404100 total,   7644580 free
KiB Swap:   15647296 total,  15647296 free
Timestamp of repository gentoo: Tue, 20 Mar 2018 16:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.4_p6-r1::gentoo, 1.5-r1::gentoo, 1.9.6-r3::gentoo, 1.10.3::gentoo, 1.11.6::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.28-r2::gentoo, 2.29.1-r1::gentoo
sys-devel/gcc:            4.3.5::gentoo, 4.4.7::gentoo, 4.5.4::gentoo, 4.6.3::gentoo, 4.7.4::gentoo, 4.8.5::gentoo, 4.9.3::gentoo, 4.9.4::gentoo, 5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 0

haskell
    location: /var/lib/layman/haskell
    masters: gentoo
    priority: 1

x-layman
    location: /var/lib/layman
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://ftp.fi.muni.cz/pub/linux/gentoo/ rsync://gentoo.mirror.dkm.cz/gentoo/ ftp://gentoo.mirror.web4u.cz/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en cs cz"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X accessibility alsa amd64 amr apache apache2 berkdb bzip2 cairo cgi cli cracklib crypt cups cxx dbus device-mapper dri encode ffmpeg flac fontconfig fortran gd gdbm geoip gnutls hal iconv id3tag innodb java jce jpeg jpg ladspa laptop mad maildir mmx modules mpi mpich2 multilib mysql ncurses nfs nls nptl nptlonly ogg opengl openmp openssl pam pcre perl php png policykit postfix procmail python readline seccomp server session sndfile spf sse sse2 ssl suexec svg syslog tcpd threads tiff truetype unicode usb wavpack xattr xml xorg xvfb zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS