Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479516 - gnome-base/gdm-3.8.4 with USE="-accessibility" results in orca-autostart.desktop errors USE="accessibility" depends unnecessarily on Xevie
Summary: gnome-base/gdm-3.8.4 with USE="-accessibility" results in orca-autostart.desk...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome-3.8
  Show dependency tree
 
Reported: 2013-08-02 13:33 UTC by Dieter Verfaillie
Modified: 2013-09-28 08:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Suggested fix (patch.txt,414 bytes, patch)
2013-08-23 14:45 UTC, Joachim Bartosik (RETIRED)
Details | Diff
Improved suggested fix (patch,373 bytes, patch)
2013-08-24 20:12 UTC, Joachim Bartosik (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Verfaillie 2013-08-02 13:33:52 UTC
pc ~ # journalctl --boot
...
Aug 02 14:48:30 pc gnome-session[314]: gnome-session[314]: WARNING: Could not parse desktop file orca-autostart.desktop or it references a not found TryExec binary
Aug 02 14:48:30 pc gnome-session[314]: WARNING: Could not parse desktop file orca-autostart.desktop or it references a not found TryExec binary
...

pc ~ # locate orca-autostart.desktop
/usr/share/gdm/greeter/autostart/orca-autostart.desktop

pc ~ # equery belongs /usr/share/gdm/greeter/autostart/orca-autostart.desktop
 * Searching for /usr/share/gdm/greeter/autostart/orca-autostart.desktop ... 
gnome-base/gdm-3.8.4 (/usr/share/gdm/greeter/autostart/orca-autostart.desktop)

pc ~ # emerge -pvt gdm

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] gnome-base/gdm-3.8.4  USE="audit fallback gnome-shell introspection ipv6 tcpd -accessibility -debug -fprint -plymouth (-selinux) -smartcard {-test} -xinerama" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Reproducible: Always
Comment 1 Joachim Bartosik (RETIRED) gentoo-dev 2013-08-23 14:45:02 UTC
Created attachment 356746 [details, diff]
Suggested fix

Confirming the problem exists. Suggested fix attached.
Comment 2 Joachim Bartosik (RETIRED) gentoo-dev 2013-08-23 14:59:44 UTC
The change removed error from logs but had rather disturbing side effect - invisible cursor. Will look into it tomorrow.
Comment 3 Pacho Ramos gentoo-dev 2013-08-24 07:24:13 UTC
(In reply to Joachim Bartosik from comment #1)
> Created attachment 356746 [details, diff] [details, diff]
> Suggested fix
> 
> Confirming the problem exists. Suggested fix attached.

It's much better to do it at src_install phase instead of pkg_*inst phase as they have sandbox disabled:
https://devmanual.gentoo.org/ebuild-writing/functions/pkg_preinst/index.html

Also, ${D} can be replaced by ${ED}:
http://www.gentoo.org/proj/en/gentoo-alt/prefix/techdocs.xml

Regarding the invisible pointer bug, maybe you are hitting:
https://wiki.gentoo.org/index.php?title=GNOME/3.8-upgrade-guide&redirect=no#Can.27t_see_the_mouse_pointer_after_login
Comment 4 Pacho Ramos gentoo-dev 2013-08-24 09:19:40 UTC
@gnome, Regarding all the "accessibility" USE flag in gdm ebuild, I doubt we should keep supplying it:
- Currently, an option with some accessibility stuff (like high-contrast) is still shown in gdm login screen.
- accessibility stuff is enabled/disabled at runtime depending on needed depends (orca and co.) being installed or not. Even this desktop file has this content (see autostart condition):
AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-reader-enabled
- xevie support should be disabled always (will wait for bug 482304 to confirm this)

I would then drop the USE flag completely
Comment 5 Joachim Bartosik (RETIRED) gentoo-dev 2013-08-24 20:12:17 UTC
Created attachment 356894 [details, diff]
Improved suggested fix
Comment 6 Joachim Bartosik (RETIRED) gentoo-dev 2013-08-24 20:19:40 UTC
(In reply to Pacho Ramos from comment #3)
> (In reply to Joachim Bartosik from comment #1)
> > Created attachment 356746 [details, diff] [details, diff] [details, diff]
> > Suggested fix
> > 
> > Confirming the problem exists. Suggested fix attached.
> 
> It's much better to do it at src_install phase instead of pkg_*inst phase as
> they have sandbox disabled:
> https://devmanual.gentoo.org/ebuild-writing/functions/pkg_preinst/index.html
> 
> Also, ${D} can be replaced by ${ED}:
> http://www.gentoo.org/proj/en/gentoo-alt/prefix/techdocs.xml

Thanks.

> Regarding the invisible pointer bug, maybe you are hitting:
> https://wiki.gentoo.org/index.php?title=GNOME/3.8-upgrade-
> guide&redirect=no#Can.27t_see_the_mouse_pointer_after_login

That was the issue.

(In reply to Pacho Ramos from comment #4)
> @gnome, Regarding all the "accessibility" USE flag in gdm ebuild, I doubt we
> should keep supplying it:
> - Currently, an option with some accessibility stuff (like high-contrast) is
> still shown in gdm login screen.
> - accessibility stuff is enabled/disabled at runtime depending on needed
> depends (orca and co.) being installed or not. Even this desktop file has
> this content (see autostart condition):
> AutostartCondition=GSettings org.gnome.desktop.a11y.applications
> screen-reader-enabled
> - xevie support should be disabled always (will wait for bug 482304 to
> confirm this)
> 
> I would then drop the USE flag completely

So should I work on dropping the USE flag? Use the patch I suggested (for now?) ?
Comment 7 Pacho Ramos gentoo-dev 2013-08-25 07:13:45 UTC
I would wait a bit more for other team members opinion:
1. Dropping accessibility completely for this is a bit more "deep"
2. The other bug is "minor" then, I am unsure it deserves the effort to commit the patch if we go for dropping accessibility the next week
Comment 8 Joachim Bartosik (RETIRED) gentoo-dev 2013-09-01 18:21:02 UTC
Unless there objections I'd like to drop accessibility USE flag on Tuesday. As enabling accessibility adds quite a bit of dependencies it'll install without them and instruct user (with elog) how to enable accessibility support.
Comment 9 Pacho Ramos gentoo-dev 2013-09-01 18:32:09 UTC
What kind of message are you willing to add? Looking to other distributions looks like that deps are not put at all :/
Comment 10 Gilles Dartiguelongue gentoo-dev 2013-09-01 18:52:19 UTC
I want to keep accessibility working out of the box when the use flag is turned on. If you remove the dependencies, that won't work.
Comment 11 Pacho Ramos gentoo-dev 2013-09-01 18:54:19 UTC
Please verify:
        accessibility? (
                app-accessibility/gnome-mag
                app-accessibility/gok
                app-accessibility/orca
                gnome-extra/at-spi:1 )

are really needed, that looks strange to me as some of them are really old and dead (like gok and at-spi:1)
Comment 12 Gilles Dartiguelongue gentoo-dev 2013-09-01 18:59:33 UTC
nowadays it's problably at-spi:2, orca and caribou but we need to check source code.
Comment 13 Pacho Ramos gentoo-dev 2013-09-01 19:07:45 UTC
Umm, looks like I found the upstream report tracking this old cruft:
https://bugzilla.gnome.org/show_bug.cgi?id=658429

I found it in opensuse's spec, that adds this comment because they also remove the old packages ;)

Per:
https://bugzilla.gnome.org/show_bug.cgi?id=658429#c5

Looks like gok and gnome-mag desktop files were dropped and, then, if they are still working, it's a bit "accidentally". Also, since all this stuff is related with fallback greeter and that greeter will be completely removed in 3.10 cycle, none of this bugs will be fixed by upstream (they have already closed some of them due this)

That probably explains why I am still seeing accessibility options even without that apps installed -> I use shell greeter
Comment 14 Joachim Bartosik (RETIRED) gentoo-dev 2013-09-02 10:59:15 UTC
(In reply to Gilles Dartiguelongue from comment #10)
> I want to keep accessibility working out of the box when the use flag is
> turned on. If you remove the dependencies, that won't work.

I thought the flag didn't affect build (so I wanted to drop the flag) but after re-checking it I might have been wrong. I'll check more carefully tomorrow.

I'd rather not keep USE flags that do not affect build process, but I don't have a good idea how to enable accessibility without it. I could add gnome-extra/gnome-accessibility meta package that would pull in all dependencies needed, but this seems somewhat clumsy.
Comment 15 Pacho Ramos gentoo-dev 2013-09-02 18:34:43 UTC
I would wait to have this more think between us before committing anything ;)
Comment 16 Gilles Dartiguelongue gentoo-dev 2013-09-02 21:58:43 UTC
We don't _usually_ have flags for non-build time dependencies. This would be an exception. We have a few like this in the team.
Comment 17 Joachim Bartosik (RETIRED) gentoo-dev 2013-09-05 18:58:07 UTC
I checked and currently accessibility USE flag affect build results. I guess this means we should keep it.
Comment 18 Pacho Ramos gentoo-dev 2013-09-06 19:06:55 UTC
Well, at least Xevie should be disabled always as explained in bug #482304

Regarding the deps: looks like upstream are were not caring at all about accessibility support with fallback greeter. This greeter is the only one that was still using old stuff (gok and gnome-mag). The gnome-shell greeter doesn't look to need them. From my point of view, I would simply drop the deps and don't care about fallback accessibility support (as upstream was doing, since they wasn't even sure if it was still working at all), and the rest of distributions are doing). Other option would be to move that depends under "fallback? (accesibility? ...)", but I don't think it deserves the effort as all fallback will die in 3.10 cycle and didn't look to have much attention
Comment 19 Joachim Bartosik (RETIRED) gentoo-dev 2013-09-19 18:20:20 UTC
Seems there is no discussion. I'd like to apply the patch and open a new bug for removing unnecessary dependencies. Any objections :?
Comment 20 Gilles Dartiguelongue gentoo-dev 2013-09-19 21:38:18 UTC
I am ok with always disabling Xevie since it's been broken since xorg-1.6 anyway. For dependencies, strip them if you will, I still think it's a loss for our user who need accessibility, especially if we make it harder by removing desktop files that would autostart relevant tools.
Comment 21 Joachim Bartosik (RETIRED) gentoo-dev 2013-09-20 20:56:04 UTC
(In reply to Gilles Dartiguelongue from comment #20)
> I am ok with always disabling Xevie since it's been broken since xorg-1.6
> anyway. For dependencies, strip them if you will, I still think it's a loss
> for our user who need accessibility, especially if we make it harder by
> removing desktop files that would autostart relevant tools.

After checking more carefully I want to keep accessibility USE flag working - it does affect build result and does something useful.

I just want to remove orca-autostart.desktop when accessibility flag is disabled (it causes errors otherwise) and drop unnecessary / broken dependencies.
Comment 22 Pacho Ramos gentoo-dev 2013-09-21 07:43:56 UTC
(In reply to Joachim Bartosik from comment #21)
[...] 
> After checking more carefully I want to keep accessibility USE flag working
> - it does affect build result and does something useful.

How does it exactly affect?
Comment 23 Pacho Ramos gentoo-dev 2013-09-28 08:37:03 UTC
+*gdm-3.8.4-r1 (28 Sep 2013)
+
+  28 Sep 2013; Pacho Ramos <pacho@gentoo.org> +gdm-3.8.4-r1.ebuild:
+  >=openrc-0.12 and xdm init.d script from >-x11-base/xorg-server-1.14.3-r1
+  supports gdm-3.8 restarting (#463784 by Ian Stakenvicius, Chí-Thanh
+  Christopher Nguyễn, Alexander Vershilov, William Hubbs...). Handle
+  accessibility in a different way (#479516): xevie support disabled as it's
+  obsolete and broken, drop deps not needed for a long time due upstream
+  progressively dropping their support, remaining deps are only for fallback
+  greeter. Regarding orca.desktop autostart, it will only be started (confirmed
+  by me just now) when screen-reader-enabled gsetting is true.
+