Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479274 - sys-apps/systemd-206 - The filesystem mounted at /dev/md125 does not appear to be a valid /, try again
Summary: sys-apps/systemd-206 - The filesystem mounted at /dev/md125 does not appear t...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo systemd Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-31 14:02 UTC by Juergen Rose
Modified: 2013-10-18 19:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-07-31 14:02:40 UTC
After installation of systemd the booting process fails with Kernel panic:

[   23.599634] EXT3-fs (md125): mounted filesystem with writeback data mode
!! The filesystem mounted at /dev/md125 does not appear to be a valid /, try again
!! Please file a bug report with this message
[ 23.631248] kernel panic - not syncing: Attempted to kill init! exitcoode=0x00000100


The default kernel is 3.10.4-gentoo. If I switch with grub to an other kernel I get the same error. All kernel are installed with 'genkernel --oldconfig all'



Following http://wiki.gentoo.org/wiki/Systemd I set in /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="domdadm dolvm real_init=/usr/lib/systemd/systemd"
and following http://wiki.gentoo.org/wiki/GRUB2_Quick_Start I set 
GRUB_CMDLINE_LINUX_DEFAULT="domdadm dolvm init=/usr/lib/systemd/systemd"
in /etc/default/grub .

Booting fails in both cases with the same error.

Booting with systemrescuecd-3.7.0 and mounting of /dev/md125 on /mnt/gentoo, /dev/md124 on /mnt/gentoo/boot, /dev/mapper/vg1-usr on /mnt/gentoo/usr and 'chroot /mnt/gentoo' works like a charm.

I have created /etc/hostname and /etc/locale.conf, but not /etc/vconsole.conf and /etc/machine-info.



Reproducible: Always
Comment 1 Juergen Rose 2013-07-31 14:09:19 UTC
BTW. /dev/md125 has an ext3 filesystem. there is neither a current /var/log/dmesg file nor a current /var/log/messages  file.
Comment 2 Jeroen Roovers gentoo-dev 2013-07-31 14:10:11 UTC
That's genkernel's linuxrc script telling you that.

1) Please post your `emerge --info sys-kernel/genkernel' output in a comment.
Comment 3 Juergen Rose 2013-07-31 14:24:05 UTC
(In reply to Jeroen Roovers from comment #2)
> That's genkernel's linuxrc script telling you that.
> 
> 1) Please post your `emerge --info sys-kernel/genkernel' output in a comment.

After 'chroot /mnt/gentoo /bin/bash' form systemrescuecd:


root@sysresccd:/(2)# emerge --info sys-kernel/genkernel
Portage 2.1.13.2 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.4.47-std370-amd64 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.4.47-std370-amd64-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     6674808 total,   6220156 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 31 Jul 2013 09:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x11 science sunrise lordvan local x-cpan g-octave
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo rsync://gd.tuwien.ac.at/opsys/linux/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo http://gentoo.oregonstate.edu"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage_condor"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/lordvan /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli cmake consolekit cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp openvg pam pango pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline real reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb userlocales utempter v4l vaapi vala valgrind vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" DVB_CARDS="tda10045 tda10046lifeview" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-kernel/genkernel-3.4.47 was built with the following:
USE="crypt (multilib) -cryptsetup (-ibm) (-selinux)" ABI_X86="64"
Comment 4 Juergen Rose 2013-08-01 05:57:02 UTC
The /usr, /var, /tmp and /var/tmp partitions are logical volumes. lvm2-2.02.98 was now compiled without the static-libs USE flag. Could that be the reason that the filesystem mounted at / is not recognized as a valid filesystem?
Comment 5 Juergen Rose 2013-08-03 06:56:16 UTC
The next system, where I tried to boot with systemd, fails almost with the same error, something like:

!! The filesystem mounted at /dev/sda3 does not appear to be a valid /, try again
!! Please file a bug report with this message
[ *****] kernel panic - not syncing: Attempted to kill init! exitcoode=0x00000100

Again /usr, /var, /tmp and /var/tmp partitions are logical volumes. Systemd is now systemd-206-r1.

Is there anybody, who could boot with systemd and who is using a logical volume for the /usr partition?
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-08-04 20:51:36 UTC
Do you have proper init= / real_init= / whatever your initramfs is using set?
Comment 7 Mike Gilbert gentoo-dev 2013-08-04 21:11:15 UTC
Bug 479730 is possibly related.
Comment 8 Mike Gilbert gentoo-dev 2013-08-04 21:18:26 UTC
Definitely related. To summarize, genkernel's linuxrc checks to see if /usr/lib/systemd/systemd is executable before it has mounted /usr.
Comment 9 Juergen Rose 2013-08-04 21:50:49 UTC
Without systemd I booted in the past succesfully with:

GRUB_CMDLINE_LINUX_DEFAULT="domdadm dolvm" 

in /etc/default/grub. Now I added real_init=/usr/lib/systemd/systemd or init=/usr/lib/systemd/systemd to GRUB_CMDLINE_LINUX_DEFAULT

root@sysresccd:/(43)# grep init /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="domdadm dolvm init=/usr/lib/systemd/systemd"

root@sysresccd:/(44)# ll /usr/lib/systemd/systemd
-rwxr-xr-x 1 root root 1039560 Aug  2 07:59 /usr/lib/systemd/systemd*

root@sysresccd:/(49)# grep linux.*init /boot/grub2/grub.cfg | head -n3
        linux   /kernel-genkernel-x86_64-3.10.4 root=UUID=da1664df-139b-4f90-9ddd-e01cbc55ea2b ro  domdadm dolvm init=/usr/lib/systemd/systemd
                linux   /kernel-genkernel-x86_64-3.10.4 root=UUID=da1664df-139b-4f90-9ddd-e01cbc55ea2b ro  domdadm dolvm init=/usr/lib/systemd/systemd
                linux   /kernel-genkernel-x86_64-3.10.1-gentoo root=UUID=da1664df-139b-4f90-9ddd-e01cbc55ea2b ro  domdadm dolvm init=/usr/lib/systemd/systemd


Is there any other place other place, where I had configure initramfs with respect to init? As I said in the description of this bug the initramfs was created with 'genkernel --oldconfig all'.
Comment 10 Pacho Ramos gentoo-dev 2013-09-21 13:53:28 UTC
Are you still hitting this with genkernel-next?
Comment 11 Pacho Ramos gentoo-dev 2013-10-18 17:10:14 UTC
(In reply to Pacho Ramos from comment #10)
> Are you still hitting this with genkernel-next?
Comment 12 Juergen Rose 2013-10-18 19:17:10 UTC
(In reply to Pacho Ramos from comment #10)
> Are you still hitting this with genkernel-next?

For the systems with systemd I merged / and /usr partition, then I was able to boot with systemd. And I now generated all kernel and initramfs with genkernel-next.