Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 478648 - app-office/libreoffice-4.1.0.4 - EPS export fails with 'Graphics filter not found'
Summary: app-office/libreoffice-4.1.0.4 - EPS export fails with 'Graphics filter not f...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Low normal with 1 vote (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard: Fixed-in: 4.1.2.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 11:59 UTC by Tolga Dalman
Modified: 2013-09-23 19:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
libreoffice dialog when exporting an ODG to EPS. (libreoffice-graphics-filter-error-dialog.png,5.59 KB, image/png)
2013-07-29 11:59 UTC, Tolga Dalman
Details
emerge --info (emerge.info,4.57 KB, text/plain)
2013-07-29 12:00 UTC, Tolga Dalman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tolga Dalman 2013-07-29 11:59:37 UTC
Created attachment 354498 [details]
libreoffice dialog when exporting an ODG to EPS.

I recently upgraded libreoffice to 4.1. I remember that exporting an ODG to EPS was no problem (I think imagemagick's convert was used then). However, that does not work. I get 'Graphics filter not found', however I don't know how to fix it. I can't find any use flags or libreoffice extensions. Any idea ?
Comment 1 Tolga Dalman 2013-07-29 12:00:07 UTC
Created attachment 354500 [details]
emerge --info
Comment 2 Carl Michal 2013-07-30 22:45:54 UTC
I see this too. But (even worse?), it also can't import eps, same error message.
Comment 3 Carl Michal 2013-08-13 00:58:50 UTC
There is an upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=67602
that makes this sound like a packaging problem.

Apparently the Ubuntu PPA version has the same problem and Suse as well:
https://bugzilla.novell.com/show_bug.cgi?id=834374
Comment 4 Tolga Dalman 2013-09-01 20:13:53 UTC
Libreoffice 4.1.1.2 still doesn't work (btw, thanks for reporting upstream, Carl).
Comment 5 Carl Michal 2013-09-03 20:55:27 UTC
After rebuilding LO a few times, I've found that removing --enable-mergelibs from the configure command makes this problem go away.

I will report it upstream, but is there a good reason not to remove this option from the ebuild?
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 10:17:11 UTC
This will be fixed in next release. Yay :-)
Comment 8 Tolga Dalman 2013-09-23 19:44:37 UTC
Thanks.