Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478458 - dev-python/pypy-1.9-r2 fails to build with gcc-4.8?
Summary: dev-python/pypy-1.9-r2 fails to build with gcc-4.8?
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2013-07-28 11:32 UTC by Justin Lecher (RETIRED)
Modified: 2013-11-10 08:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

pypy-1.9-r2:20130728-100449.log.xz (pypy-1.9-r2:20130728-100449.log.xz,40.70 KB, application/x-xz)
2013-07-29 20:02 UTC, Justin Lecher (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher (RETIRED) gentoo-dev 2013-07-28 11:32:46 UTC
Don't know what it is.

$ einfo =dev-python/pypy-1.9-r2
Portage 2.2.0_alpha190 (default/linux/amd64/13.0, gcc-4.8.1-asneeded, glibc-2.17, 3.9.11-lh x86_64)
                        System Settings
System uname: Linux-3.9.11-lh-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16345160 total,   4286836 free
KiB Swap:    3987452 total,   3986980 free
Timestamp of tree: Sun, 28 Jul 2013 08:00:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.6.8-r2, 2.7.5-r1, 3.1.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/ccache:          3.1.9-r1::science
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.4.7, 4.5.4, 4.6.4, 4.7.3, 4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo sunrise bicatali betagarden dummy Neurogeek science Raspberry-Pi-Overlay last-hope g-ctan
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g -Wimplicit-function-declaration"
CONFIG_PROTECT="/etc /usr/lib/systemd/system /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /var/lib/hsqldb /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g -Wenum-compare"
EMERGE_DEFAULT_OPTS=" -vt --keep-going --autounmask-write --autounmask --quiet-build=n"
FCFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g"
FEATURES="assume-digests binpkg-logs buildsyspkg candy ccache collision-protect compressdebug distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j12 -l9"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/local/overlays/sunrise-reviewed /local/overlays/bicatali /local/overlays/betagarden /local/overlays/dummy /local/overlays/neurogeek /local/overlays/sci /local/overlays/gen2pi /local/overlays/lh-overlay /local/overlays/g-ctan"
USE="X acl alsa amd64 avx bash-completion berkdb branding bzip2 cairo caps cli cracklib crypt cxx dbus dri fortran gdbm gif gmp gnome gnome-keyring gpm gstreamer gtk iconv icu ipv6 jpeg jpeg2k mmx mmxext modules mudflap multilib ncurses network-cron nls nptl nsplugin numa opengl openmp pam pcre pgo png pulseaudio qt3support raw readline session smp sse sse2 sse2_4way sse2check sse3 sse4 sse41 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification systemd tcpd threads tiff truetype unicode vaapi vdpau xattr xinerama zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport scripting-javascript wiki-publisher nlpsolver" LINGUAS="en" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi stub_status" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_6 python2_7 python3_1 python3_2 python3_3 pypy1_9 pypy2_0" QEMU_SOFTMMU_TARGETS="i386 x86_64 arm armeb" QEMU_USER_TARGETS="i386 x86_64 arm armeb" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.6 2.7 3.1 3.2 3.3 2.7-pypy-1.9 2.7-pypy-2.0"

                        Package Settings

dev-python/pypy-1.9-r2 was built with the following:
USE="bzip2 jit ncurses sqlite ssl xml -doc -examples -sandbox -shadowstack"
CFLAGS="-pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration -O3 -pipe -Wimplicit-function-declaration"
CXXFLAGS="-pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wenum-compare -O3 -pipe -Wenum-compare"
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-07-28 20:46:29 UTC
I'm sorry but where's the build log?
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2013-07-29 09:43:41 UTC
(In reply to Michał Górny from comment #1)
> I'm sorry but where's the build log?

Good question. :/ Will upload it later
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2013-07-29 20:02:50 UTC
Created attachment 354550 [details]

Comment 4 Mike Gilbert gentoo-dev 2013-07-29 20:37:13 UTC
[translation:ERROR]     Traceback (most recent call last):
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 2023, in <module>
[translation:ERROR]         tracker.process(f, g, filename=fn)
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 1916, in process
I ran into this over the weekend as well. I believe it is gcc-4.8 related.

[translation:ERROR]         tracker = parser.process_function(lines, filename)
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 1431, in process_function
[translation:ERROR]         table = tracker.computegcmaptable(self.verbose)
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 58, in computegcmaptable
[translation:ERROR]         self.findframesize()
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 269, in findframesize
[translation:ERROR]         self.walk_instructions_backwards(walker, insn, 0)
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 354, in walk_instructions_backwards
[translation:ERROR]         for prevstate in walker(insn, state):
[translation:ERROR]       File "/var/cache/portage/tmpdir/portage/dev-python/pypy-1.9-r2/work/pypy-1.9/pypy/translator/c/gcc/", line 260, in walker
[translation:ERROR]         "inconsistent frame size at instruction %s" % (insn,))
[translation:ERROR]     AssertionError: inconsistent frame size at instruction InsnSetLocal(%rax, ()) --- None
Comment 5 Mike Gilbert gentoo-dev 2013-07-29 20:38:38 UTC
My comment again:

I ran into this over the weekend as well. I believe it is gcc-4.8 related.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-11-10 08:21:57 UTC
1.9 no longer in the tree.