Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478058 - app-text/calibre-0.9.40 - /usr/bin/install: cannot stat '/tmp/portage/app-text/calibre-0.9.40/image/usr/etc/bash_completion.d/calibre': No such file or director
Summary: app-text/calibre-0.9.40 - /usr/bin/install: cannot stat '/tmp/portage/app-tex...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 477380
  Show dependency tree
 
Reported: 2013-07-24 23:44 UTC by Jason Lamb
Modified: 2017-05-21 22:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-text/calibre-0.9.40 build log (calibre-0.9.40-build.log,70.93 KB, text/plain)
2013-07-24 23:45 UTC, Jason Lamb
Details
emerge --info (emerge-info.log,6.16 KB, text/plain)
2013-07-24 23:45 UTC, Jason Lamb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Lamb 2013-07-24 23:44:55 UTC
app-text/calibre-0.9.40 Setting up completion failed with error: cannot stat '/tmp/portage/app-text/calibre-0.9.40/image/usr/etc/bash_completion.d/calibre': No such file or directory

Reproducible: Always
Comment 1 Jason Lamb 2013-07-24 23:45:29 UTC
Created attachment 354136 [details]
app-text/calibre-0.9.40 build log
Comment 2 Jason Lamb 2013-07-24 23:45:45 UTC
Created attachment 354138 [details]
emerge --info
Comment 3 tarek 2013-08-05 01:47:01 UTC
The hint is in the warning. 

"Failed to load ImageMagick"

Fix this problem and you will resolve your build issue. 

A re-emerge imagemagick may work but it would be best to perform a revdep-rebuild to resolve your issue.

Just had similar symptoms (in may case 0.9.42), but with the pillow PIL library after a libjpeg upgrade.

Regards

Tarek
Comment 4 Jason Lamb 2013-08-05 15:20:16 UTC
Thanks..

I missed that reference to imagemagick in the build log. For the record, I don't get this error any more when emerging the most recent app-text/calibre-0.9.42, (thinking that it had been fixed). However, re-emerging imagemagick doesn't address this because it's likely related to the opencl imagemagick issue reported at;

https://bugs.gentoo.org/show_bug.cgi?id=472766

What's funny is that while I don't now have any issue emerging the latest app-text/calibre-0.9.42, I still have the same issue reported in bug report 472766, when trying to emerge the latest media-gfx/imagemagick-6.8.6.1 and media-plugins/kipi-plugins-3.2.0.
Comment 5 Jeroen Roovers gentoo-dev 2013-08-25 12:29:45 UTC
*** Bug 482294 has been marked as a duplicate of this bug. ***
Comment 6 Jonas Stein gentoo-dev 2017-05-21 22:13:14 UTC
0.9 is not in the tree since a while, should we close this ticket?