Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477918 - net-nds/openldap-2.4.30 - In member function 'virtual void DefaultSaslInteractionHandler::handleInteractions(const std::list<SaslInteraction*>&)': SaslInteractionHandler.cpp:56:27: error: 'STDIN_FILENO' was not declared in this scope
Summary: net-nds/openldap-2.4.30 - In member function 'virtual void DefaultSaslInterac...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-23 15:32 UTC by Guido Winkelmann
Modified: 2013-07-25 18:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,408.19 KB, text/plain)
2013-07-23 15:32 UTC, Guido Winkelmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Winkelmann 2013-07-23 15:32:47 UTC
Created attachment 354026 [details]
build.log

Emerging net-nds/openldap-2.4.30 fails with the following messages for me:

======
/bin/sh ../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.   -I../../include  -I/usr/include/db4.8 -DLDAP_CONNECTIONLESS -I../../../include   -march=corei7 -O2 -pipe -ggdb -D_GNU_SOURCE -MT SaslInteractionHandler.lo -MD -MP -MF .deps/SaslInteractionHandler.Tpo -c -o SaslInteractionHandler.lo SaslInteractionHandler.cpp
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include -I/usr/include/db4.8 -DLDAP_CONNECTIONLESS -I../../../include -march=corei7 -O2 -pipe -ggdb -D_GNU_SOURCE -MT SaslInteractionHandler.lo -MD -MP -MF .deps/SaslInteractionHandler.Tpo -c SaslInteractionHandler.cpp  -fPIC -DPIC -o .libs/SaslInteractionHandler.o
SaslInteractionHandler.cpp: In member function 'virtual void DefaultSaslInteractionHandler::handleInteractions(const std::list<SaslInteraction*>&)':
SaslInteractionHandler.cpp:56:27: error: 'STDIN_FILENO' was not declared in this scope
SaslInteractionHandler.cpp:67:27: error: 'STDIN_FILENO' was not declared in this scope
SaslInteractionHandler.cpp:85:23: error: 'STDIN_FILENO' was not declared in this scope
make[2]: *** [SaslInteractionHandler.lo] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30/contrib/ldapc++/src'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30/contrib/ldapc++/src'
make: *** [all-recursive] Fehler 1
emake failed
======

Output of emerge --info '=net-nds/openldap-2.4.30':

======
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.15-r3, 3.8.13-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_W3530_@_2.80GHz-with-gentoo-2.2
KiB Mem:    24687636 total,  17705832 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 23 Jul 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5, 3.2.5-r1, 3.3.2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage-local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Oracle-BCLA-JavaSE AdobeFlash-10.3 AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"                                                     
CXXFLAGS="-march=corei7 -O2 -pipe -ggdb"                                                                                                                                                                 
DISTDIR="/usr/portage/distfiles"                                                                                                                                                                         
FCFLAGS="-O2 -pipe"                                                                                                                                                                                      
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"                                                                                                                                               
FFLAGS="-O2 -pipe"                                                                                                                                                                                       
GENTOO_MIRRORS="http://gentoo.tiscali.nl/ http://de-mirror.org/distro/gentoo/ http://gentoo.mneisen.org/"                                                                                                
LANG="de_DE.UTF-8"                                                                                                                                                                                       
LC_ALL="de_DE.UTF-8"                                                                                                                                                                                     
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                                                        
PKGDIR="/usr/portage/packages"                                                                                                                                                                           
PORTAGE_CONFIGROOT="/"                                                                                                                                                                                   
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                                                                                                                   
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                                                                
PORTDIR="/usr/portage"                                                                                                                                                                                   
PORTDIR_OVERLAY="/usr/local/portage-local"                                                                                                                                                               
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                                                                                                                                           
USE="X a52 aac acl acpi aiglx alsa amd64 apache2 apng arts berkdb bluetooth branding bzip2 cairo cdda cdr chipcard cli consolekit cracklib crypt ctype cups curl cvs cxx cycles dbus ddate declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran ftp gd gdbm gif gnutls gpm graphviz gtk hash hbci iconv icu id3tag idn imlib ipv6 jabber java jpeg jpeg2k kde kdehiddenvisibility kdepim kipi kpathsea lastfm lcms ldap libkms libnotify mad matroska mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nfs nls nptl nsplugin offensive ogg opengl openldap openmp pam pango pcap pcre pdf perl phonon php plasma png policykit postscript ppds pulseaudio python qemu qt qt3 qt3support qt4 rbd rdesktop readline samba sasl sdl semantic-desktop session spell spice sql sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification subversion suexec svg tcpd theora tiff truetype udev udisks unicode upower usb virt-network vorbis webkit wmf wxwidgets x264 xcb xcomposite xine xinerama xml xorg xscreensaver xterm xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de nds jp" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa vga mga nv r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-nds/openldap-2.4.30 was built with the following:
USE="berkdb crypt cxx gnutls icu ipv6 (multilib) perl samba sasl ssl syslog tcpd -debug -experimental -iodbc -kerberos -minimal -odbc -overlays (-selinux) -slp -smbkrb5passwd"
CFLAGS="-march=corei7 -O2 -pipe -ggdb -D_GNU_SOURCE"
CXXFLAGS="-march=corei7 -O2 -pipe -ggdb -D_GNU_SOURCE"
======

Output of emerge -pqv '=net-nds/openldap-2.4.30':

======
[ebuild   R   ] net-nds/openldap-2.4.30  USE="berkdb crypt cxx gnutls icu ipv6 perl samba sasl ssl syslog tcpd -debug -experimental -iodbc -kerberos -minimal -odbc -overlays (-selinux) -slp -smbkrb5passwd"
======
Comment 1 needle 2013-07-24 20:17:14 UTC
[ebuild   R   ] net-nds/openldap-2.4.30  USE="berkdb crypt cxx gnutls icu ipv6 perl samba sasl ssl syslog tcpd -debug -experimental -iodbc -kerberos -minimal -odbc -overlays (-selinux) -slp -smbkrb5passwd"

Try removing either gnutls OR ssl from USE flags. 
Rebuild openldap
Comment 2 Guido Winkelmann 2013-07-25 18:27:54 UTC
I tried with

"net-nds/openldap -ssl"

and

"net-nds/openldap -gnutls"

(first one, then the other) in /etc/portage/package.use. Neither solved the problem.

"net-nds/openldap -cxx"

does solve it, but obviously that means broken functionality (i.e. the included C++ wrapper library is not available).