Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477894 - net-misc/openssh-6.4_p1-r1 and =net-libs/ldns-1.6.16 stabilization request
Summary: net-misc/openssh-6.4_p1-r1 and =net-libs/ldns-1.6.16 stabilization request
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 488814
  Show dependency tree
 
Reported: 2013-07-23 12:09 UTC by Michael Weber (RETIRED)
Modified: 2014-03-23 09:46 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weber (RETIRED) gentoo-dev 2013-07-23 12:09:12 UTC
Any chance to stable a openssh version wich utilizes sshd.rc6.4, which no longer rc_need's net if the sshd_config binds to any network addresses aka no one network in particular? It's a big ease setting up new hosts if the sshd service just uses it's wildcard bind potential and just starts, regardless of any temporary or to-be-set-up networking config.

Thanks in advance
Comment 1 Tim Harder gentoo-dev 2013-08-05 20:00:22 UTC
Personally I think we should just wait another couple weeks and stabilize openssh-6.2_p2-r3.
Comment 2 SpanKY gentoo-dev 2013-10-15 16:35:56 UTC
Tim: we good with 6.2_p2-r4 ?  you've done all the real work of late.
Comment 3 Johannes Huber gentoo-dev 2013-10-18 08:51:03 UTC
In bug #481616 users reporting that with enabled hpn useflag for -r4 stfp does not work, compared to -r3 where it seems working.
Comment 4 Andrew Hamilton 2013-11-08 04:26:13 UTC
OpenSSH 6.2 should not be stablized due to Bug 490728.
Comment 5 Tim Harder gentoo-dev 2013-11-08 05:18:13 UTC
(In reply to SpanKY from comment #2)
> Tim: we good with 6.2_p2-r4 ?  you've done all the real work of late.

If we want to stabilize the 6.2 series we'll need to apply the aes-gcm patch applied to 6.3_p1-r1 (fixes bug #490728 as mentioned by comment #4) on an -r5 and stabilize that.

With regards to the hpn issues, it's been hit and miss all throughout the openssh-6* series and the bugs are generally not easy to track down. I can't reproduce this specific issue, but I don't run KDE either.
Comment 6 Pacho Ramos gentoo-dev 2013-12-09 09:36:36 UTC
Any updates here? :/

Thanks a lot
Comment 7 Tim Harder gentoo-dev 2013-12-10 08:55:06 UTC
Arches, please stabilize:
=net-misc/openssh-6.4_p1-r1
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2013-12-10 10:39:01 UTC
I get the following error with USE="kerberos ldap skey X509":

 * ERROR: net-misc/openssh-6.4_p1-r1::gentoo failed (install phase):
 *   !!! newins: openssh-lpk_openldap.schema does not exist
Comment 9 Tim Harder gentoo-dev 2013-12-11 09:37:32 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #8)
> I get the following error with USE="kerberos ldap skey X509":
> 
>  * ERROR: net-misc/openssh-6.4_p1-r1::gentoo failed (install phase):
>  *   !!! newins: openssh-lpk_openldap.schema does not exist

Fixed in the tree for all versions, ldap and X509 can't be enabled at the same time.
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2013-12-11 15:36:34 UTC
Stable for HPPA.
Comment 11 Pacho Ramos gentoo-dev 2013-12-19 22:13:01 UTC
Looks like a test is interactive and keeps waiting for:
make[1]: Entering directory `/var/tmp/portage/net-misc/openssh-6.4_p1-r1/work/openssh-6.4p1/regress'
run test putty-transfer.sh ...
Enter passphrase to save key: 


Probably should be skipped
Comment 12 Agostino Sarubbo gentoo-dev 2013-12-21 19:14:44 UTC
This stable request can't be completed because of the following repoman's error(s):

   net-misc/openssh/openssh-6.4_p1-r1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) 
['net-libs/ldns[ecdsa,ssl]', 'net-libs/ldns[-ecdsa,ssl]', 
'net-libs/ldns[ecdsa,ssl,static-libs(+)]', 'net-libs/ldns[-ecdsa,ssl,static-libs(+)]']


In case you are the maintainer of the needed package(s), please authorize the stabilization and edit the summary of this bug.
In case you are not the maintainer of the needed package(s), please open the necessary bug(s) and make a block for this bug.

To find the full list, feel free to follow this article: http://blogs.gentoo.org/ago/2012/07/06/repoman-check-before-file-stable-request
Comment 13 Agostino Sarubbo gentoo-dev 2013-12-24 13:01:51 UTC
x86 stable
Comment 14 Markus Meier gentoo-dev 2013-12-25 09:36:38 UTC
arm stable
Comment 15 Lars Wendler (Polynomial-C) gentoo-dev 2014-01-02 12:06:37 UTC
amd64 stable
Comment 16 Joe Jezak (RETIRED) gentoo-dev 2014-01-23 04:58:41 UTC
Marked ppc/ppc64 stable, also marked ldns as a dep.
Comment 17 Agostino Sarubbo gentoo-dev 2014-01-26 12:07:07 UTC
sparc stable
Comment 18 Akinori Hattori gentoo-dev 2014-02-14 15:49:41 UTC
ia64 stable
Comment 19 Agostino Sarubbo gentoo-dev 2014-03-23 09:46:27 UTC
alpha will continue in bug 505066