Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477798 - app-benchmarks/phoronix-test-suite: missing dependencies
Summary: app-benchmarks/phoronix-test-suite: missing dependencies
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard: Pending removal: 2016-09-21
Keywords: PMASKED
: 477812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-22 19:58 UTC by genfool
Modified: 2016-10-01 07:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description genfool 2013-07-22 19:58:20 UTC
This package app-benchmarks/phoronix-test-suite-4.6.1
It installs and works fine. Then on first startup, it ask you accept license agreement which is fine, then it ask if you want to share your test results and ask if it can write home.
Then when you run the first test it ask this.

	

    The following dependencies are needed and will be installed:
     
    - media-libs/freeimage
     
    This process may take several minutes.
    Please enter your root password below:
    Password:

Is it acceptable for a 3rd party app that wants to write home, ask for your root password and make modifications to your gentoo machine?

I can never see a reason for a 3rd party app in the portage tree ask for my root password.
I ask that the app be removed from the tree until is rewritten in a more sensible manner.
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2013-07-22 21:03:11 UTC
*** Bug 477812 has been marked as a duplicate of this bug. ***
Comment 2 Chris Reffett gentoo-dev Security 2013-07-22 22:58:21 UTC
Let's slow down a little here. Poking at the source code reveals a file named gentoo-packages.xml, which has a list of our names for several packages and even has emerge listed as "package manager." Then there's a file in the "scripts" dir named install-gentoo-packages.sh, which consists of the following:
#!/bin/sh
 
# Gentoo package installation

echo "Please enter your root password below:" 1>&2 
su root -c "emerge -v $*"
exit

It's prompting for your root password to install missing dependencies. This does bring up the important question of why these aren't in DEPEND/RDEPEND (and so I'm CCing maintainers to have a look), but there's nothing nefarious going on here as far as I can tell.
Comment 3 genfool 2013-07-22 23:18:42 UTC
Chris, if there is anything I can offer let me know.
I while testing, found the phoronix suiete.
For testing purposes, let me know ... otherwise this is being removed.
Comment 4 genfool 2013-07-23 16:01:51 UTC
I did remove it, everything we have been taught as linux users, and teach others.
Use the package manager to install packages!
I feel phoronix-test-suite should tell me the list of missing dependencies, and then try the test again.

I could not help myself and installed it again. Look at this list of packages it wants to install. Several packages like libpng, libsdl, curl, libstdc++, I already have installed.
I can see how maybe 1 binary package like freeimage may be harmless, but look at this list. You can see I chose test 51, pts/graphics I could go down the whole list of 54 test, see how many packages in total it wants to install, I see that as pointless.

49: pts/processor
50: pts/disk
51: pts/graphics
52: pts/memory
53: pts/network
54: pts/other
Select Suite: 51

The following dependencies are needed and will be installed: 

- app-arch/p7zip
- media-libs/libpng
- media-libs/libsdl
- media-libs/sdl-net
- media-libs/sdl-image
- media-libs/lib3ds
- media-libs/freeimage
- media-libs/imlib2
- app-shells/tcsh
- virtual/libstdc++-3.3
- dev-util/ftjam
- dev-util/scons
- net-misc/curl

This process may take several minutes.
Please enter your root password below:
Password:
Comment 5 genfool 2013-07-23 21:05:18 UTC
here in debian, they actually have it marked as critical
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717536
Comment 6 Pacho Ramos gentoo-dev 2016-01-27 21:37:52 UTC
CCing treecleaners as, apart of needing to be bumped, I also see no reason on a package polluting world file for the long term because of missing dependencies
Comment 7 Pacho Ramos gentoo-dev 2016-10-01 07:57:04 UTC
removed