Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477778 - X freeze on X start with radeon kms
Summary: X freeze on X start with radeon kms
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Team Anniversary
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-22 17:51 UTC by Manuel Ullmann
Modified: 2017-02-02 18:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Corrupted wallpaper Gentoo-Linux-Flowers-1600.png (Gentoo-Linux-Flowers-1600.png,423.65 KB, image/png)
2013-07-22 18:05 UTC, Manuel Ullmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Ullmann 2013-07-22 17:51:51 UTC
On the current LiveDVD-20121221, X freezes for my system, which is RS780M (AMD Radeon HD3200 mobile). The screen is black with big white lines. Magic sysrq is not working (well, sysrq+e added another line); getting to console is impossible. Booting with nox is working, so radeondrmfb works and I'm dropped to tty. A workaround is to use the gentoo-nofb kernel, but I'm missing the full screen resolution. However X starts this way.

Reproducible: Always

Steps to Reproduce:
1. Start LiveDVD with default options on a system with RS780M.
2. Wait until X is started.

Actual Results:  
X start freezes most likely kernel (e.g. sysrq is not working)

Expected Results:  
X should start in full screen resolution and don't freeze the kernel.

I searched the kernel bugzilla for similar bugs, but there are none (closed or open), where the freeze is at X start and radeondrmfb is working. I think 3.6.8 was stable once and I had no issues in december on my hard drive-Gentoo. So I'm dropping this to you guys ;-). I will test this on other radeon machines and report back. I think emerge --info is irrelevant, as you should know, how it is configured on your LiveDVD. I checked the iso before burning, but I have found a wallpaper, which seems to be broken. I'll attach it. Could be a sign for a damaged iso or a not well checked LiveDVD-iso ;-).
Comment 1 Manuel Ullmann 2013-07-22 18:05:25 UTC
Created attachment 353900 [details]
Corrupted wallpaper Gentoo-Linux-Flowers-1600.png

It seems that the most installed image viewers refuse to open the wallpaper, but gpicview and kde file selection dialog display it. According to gwenview it has corrupted metadata.
Comment 2 Manuel Ullmann 2013-07-23 19:40:16 UTC
On a desktop PC with Trinity APU the LiveDVD shows the 4 Tux logos and basically does nothing for some time. The initial loading is quite short there is no output until the DVD begins to load and the screen changes to a corrupted image. At least SysRq works. So no framebuffer on APUs. I might test eventually another PC with Trinity APU.
Comment 3 Manuel Ullmann 2013-07-25 15:24:47 UTC
The other Trinity is behaving the same. It gets to the Gentoo splash screen before freezing and replacing it by corrupted screen. Probably the low IO load at the beginning is the keymap selector.
Comment 4 Ben Kohler gentoo-dev 2017-02-02 18:28:22 UTC
I don't believe this affects any of the last few livedvd releases, please reopen if it does