Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477586 - sci-visualization/spyview : _FORTIFY_SOURCE reports presence of overflow
Summary: sci-visualization/spyview : _FORTIFY_SOURCE reports presence of overflow
Status: RESOLVED DUPLICATE of bug 431114
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: fortify-source
  Show dependency tree
 
Reported: 2013-07-21 09:51 UTC by Agostino Sarubbo
Modified: 2013-12-20 22:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-07-21 09:51:01 UTC
In file included from /usr/include/string.h:642:0,
                 from /usr/include/fltk-1/FL/fl_utf8.h:43,
                 from /usr/include/fltk-1/FL/Fl.H:39,
                 from ImageWindow.H:6,
                 from ImageWindow.C:5:
In function 'char* strncpy(char*, const char*, size_t)',
    inlined from 'void ImageWindow::exportLinecut()' at ImageWindow.C:2087:33:
/usr/include/bits/string3.h:121:71: warning: call to char* __builtin___strncpy_chk(char*, const char*, long unsigned int, long unsigned int) will always overflow destination buffer [enabled by default]
In function 'char* strncpy(char*, const char*, size_t)',
    inlined from 'void ImageWindow::exportLinecut()' at ImageWindow.C:2089:34:
/usr/include/bits/string3.h:121:71: warning: call to char* __builtin___strncpy_chk(char*, const char*, long unsigned int, long unsigned int) will always overflow destination buffer [enabled by default]
Comment 1 Andreas K. Hüttel gentoo-dev 2013-12-20 22:51:18 UTC
Yes I know.

*** This bug has been marked as a duplicate of bug 431114 ***