Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477182 - sci-libs/fftw-3.3.3-r2 stable request
Summary: sci-libs/fftw-3.3.3-r2 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: gcc-4.7-stable 478608
  Show dependency tree
 
Reported: 2013-07-17 07:15 UTC by Ryan Hill (RETIRED)
Modified: 2013-09-26 17:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hill (RETIRED) gentoo-dev 2013-07-17 07:15:34 UTC
The current stable version fails to build with GCC 4.7.  Thanks.
Comment 1 Christoph Junghans gentoo-dev 2013-08-01 20:47:53 UTC
Version 3.3.3-r2 looks good to me.

Targets: alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86

@sci: Please speak up in the next week, otherwise I will add archs.
Comment 2 Pacho Ramos gentoo-dev 2013-08-25 08:46:28 UTC
(In reply to Christoph Junghans from comment #1)
> Version 3.3.3-r2 looks good to me.

Maybe -r1 and -r2 would need to wait for stabilization of some multilib stuff (looks like it is blocking the sets but I see no new dep)
Comment 3 Christoph Junghans gentoo-dev 2013-08-25 23:59:14 UTC
(In reply to Pacho Ramos from comment #2)
> (In reply to Christoph Junghans from comment #1)
> > Version 3.3.3-r2 looks good to me.
> 
> Maybe -r1 and -r2 would need to wait for stabilization of some multilib
> stuff (looks like it is blocking the sets but I see no new dep)
I think fftw-3.3.3-r2 is fine, the only lib dependency is virtual/mpi, but it is questionable if this will become multilib soon or ever.

However I would maybe rework
REQUIRED_USE="amd64? ( abi_x86_32? ( !mpi !quad ) )"
into disabling mpi and quad inside src_configure for abi_x86_32 on amd64, so that mpi and quad can be enabled together with abi_x86_32 as e.g. sci-physics/mpb needs fftw[mpi].
Comment 4 Pacho Ramos gentoo-dev 2013-09-05 19:17:25 UTC
As soon as this DEPEND is present:
        abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
                                        !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"


I don't think it can go to stable without either we stabilizing newer emul set revisions (that will need to also stabilize many more packages) or use.masking the USE flag in stable profiles :/
Comment 5 Alexis Ballier gentoo-dev 2013-09-05 19:40:49 UTC
(In reply to Pacho Ramos from comment #4)

I won't have time to contribute much for at least 1 month; so, unless someone wants to relay me in "agressively converting packages to multilib eclasses", I think it'd be a good time to stabilize what we have atm by:
- stabilizing packages one by one and package.stable.use.mask'ing abi_x86_32 for them
- once all are done, at least on amd64, stabilize latest revisions of emul-libs and remove the use.masks
Comment 6 Pacho Ramos gentoo-dev 2013-09-07 09:04:54 UTC
# Pacho Ramos <pacho@gentoo.org> (07 Sep 2013)
# It requires newer emul sets to be stabilized (#477182#c5)
~sci-libs/fftw-3.3.3 abi_x86_32

Should be ready to CC arches now
Comment 7 Christoph Junghans gentoo-dev 2013-09-07 22:35:44 UTC
I added fftw-3.3.3-r3 to science overlay for testing, this one comes without REQUIRED_USE, but has other problems (<https://github.com/FFTW/fftw3/pull/6> and especially #483758), so fftw-3.3.3-r2 is a better stable candidate.

What was the reason to block quad on abi_x86_32 in the first place? It builds fine on my Core i7.
Comment 8 Pacho Ramos gentoo-dev 2013-09-07 22:43:33 UTC
I don't know, but this is what ChangeLog has related with this:
*fftw-3.3.3-r2 (10 Mar 2013)

  10 Mar 2013; Justin Lecher <jlec@gentoo.org> fftw-3.3.3-r1.ebuild,
  +fftw-3.3.3-r2.ebuild:
  Multibuild for the precision builds, thanks mgorny to prepare the patch;
  restrict USE=quad for x86 as there are to less registers


Looks like quad won't work ok for x86 building then :/
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-07 22:52:05 UTC
(In reply to Christoph Junghans from comment #7)
> I added fftw-3.3.3-r3 to science overlay for testing, this one comes without
> REQUIRED_USE, but has other problems (<https://github.com/FFTW/fftw3/pull/6>
> and especially #483758), so fftw-3.3.3-r2 is a better stable candidate.
> 
> What was the reason to block quad on abi_x86_32 in the first place? It
> builds fine on my Core i7.

If you run the tests, you'll notice that quad on x86 simply fails :). I don't remember the exact kind of error though, SIGILL, SIGSEGV or something like that.
Comment 10 Christoph Junghans gentoo-dev 2013-09-07 22:56:59 UTC
(In reply to Michał Górny from comment #9)
> (In reply to Christoph Junghans from comment #7)
> > What was the reason to block quad on abi_x86_32 in the first place? It
> > builds fine on my Core i7.
> 
> If you run the tests, you'll notice that quad on x86 simply fails :). I
> don't remember the exact kind of error though, SIGILL, SIGSEGV or something
> like that.
I see, shouldn't quad be masked on x86 then?
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-07 23:08:56 UTC
Yes, it should. Unless there's some other thing I don't recall now :).
Comment 12 Christoph Junghans gentoo-dev 2013-09-08 15:24:52 UTC
(In reply to Michał Górny from comment #9)
> (In reply to Christoph Junghans from comment #7)
> > I added fftw-3.3.3-r3 to science overlay for testing, this one comes without
> > REQUIRED_USE, but has other problems (<https://github.com/FFTW/fftw3/pull/6>
> > and especially #483758), so fftw-3.3.3-r2 is a better stable candidate.
> > 
> > What was the reason to block quad on abi_x86_32 in the first place? It
> > builds fine on my Core i7.
> 
> If you run the tests, you'll notice that quad on x86 simply fails :). I
> don't remember the exact kind of error though, SIGILL, SIGSEGV or something
> like that.
I can confirm that problem on my Intel Atom 330, the test fails for quad with "received signal 11". That of course leads to the question why gcc installs libquadmath.so on x86.
Comment 13 Pacho Ramos gentoo-dev 2013-09-08 15:41:47 UTC
(In reply to Christoph Junghans from comment #12)
[...]
> I can confirm that problem on my Intel Atom 330, the test fails for quad
> with "received signal 11". That of course leads to the question why gcc
> installs libquadmath.so on x86.

Will CC gcc maintainers for that then
Comment 14 Christoph Junghans gentoo-dev 2013-09-08 17:09:27 UTC
(In reply to Michał Górny from comment #11)
> Yes, it should. Unless there's some other thing I don't recall now :).
+  08 Sep 2013; Christoph Junghans <ottxor@gentoo.org> package.use.mask:
+  masked sci-libs/fftw[quad]
+
Comment 15 Pacho Ramos gentoo-dev 2013-09-08 19:42:57 UTC
I guess, arches can be CCed then?
Comment 16 Christoph Junghans gentoo-dev 2013-09-08 19:55:25 UTC
Yes, target keywords: alpha amd64 arm hppa ia64  ppc64 ppc sparc x86
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2013-09-09 18:09:34 UTC
Stable for HPPA.
Comment 18 Agostino Sarubbo gentoo-dev 2013-09-21 13:32:27 UTC
amd64 stable
Comment 19 Agostino Sarubbo gentoo-dev 2013-09-22 06:51:27 UTC
x86 stable
Comment 20 Agostino Sarubbo gentoo-dev 2013-09-22 08:58:01 UTC
ia64 stable
Comment 21 Agostino Sarubbo gentoo-dev 2013-09-23 17:25:41 UTC
alpha stable
Comment 22 Agostino Sarubbo gentoo-dev 2013-09-23 17:45:11 UTC
ppc64 stable
Comment 23 Agostino Sarubbo gentoo-dev 2013-09-23 19:23:02 UTC
sparc stable
Comment 24 Agostino Sarubbo gentoo-dev 2013-09-25 17:31:52 UTC
ppc stable
Comment 25 Agostino Sarubbo gentoo-dev 2013-09-26 17:32:50 UTC
arm stable. Last arch, closing