Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 476594 - media-tv/tvbrowser-3.4 version bump
Summary: media-tv/tvbrowser-3.4 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Johannes Huber
URL:
Whiteboard:
Keywords:
: 486704 (view as bug list)
Depends on: 480922 504626 504628 504630
Blocks:
  Show dependency tree
 
Reported: 2013-07-11 23:20 UTC by Heiko Baums
Modified: 2014-07-14 19:20 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tvbrowser-3.3.3.ebuild (tvbrowser-3.3.3.ebuild,4.71 KB, text/plain)
2014-03-14 19:43 UTC, Small_Penguin
Details
jgoodies-common-1.8.0.ebuild (jgoodies-common-1.8.0.ebuild,1.03 KB, text/plain)
2014-03-14 19:45 UTC, Small_Penguin
Details
jgoodies-forms-1.8.0.ebuild (jgoodies-forms-1.8.0.ebuild,1.17 KB, text/plain)
2014-03-14 19:46 UTC, Small_Penguin
Details
jgoodies-looks-2.6.0.ebuild (jgoodies-looks-2.6.0.ebuild,1.30 KB, text/plain)
2014-03-14 19:48 UTC, Small_Penguin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Baums 2013-07-11 23:20:37 UTC
Version 3.3.1 has been released on http://www.tvbrowser.org.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2013-10-03 13:16:48 UTC
*** Bug 486704 has been marked as a duplicate of this bug. ***
Comment 2 Small_Penguin 2014-03-14 19:34:42 UTC
I have managed to update tvbrowser to the current version 3.3.3. It requires modifications to the existing ebuild and some dependencies. I will attach files here and describe what needs to be done.
Comment 3 Small_Penguin 2014-03-14 19:43:04 UTC
Created attachment 372668 [details]
tvbrowser-3.3.3.ebuild

tvbrowser-3.3.3 needs newer versions of jgoodies-{common,forms,goodies} and commons-lang-3.1 (available in the current portage tree). I decided to update jgoodies to the newest versions available and use the available slots. No other ebuilds on my system used jgoodies. If you use other slots, the ebuild needs to be updated to reflect this, which would only be a minor change.

Apart from that, some class paths needed to be adapted for commons-lang3 and maybe for jgoodies, and a library no longer needs to be installed because it is no longer included.

The build file in ${FILESDIR} used for previous versions of tvbrowser can be used as-is but has to be renamed to tvbrowser-3.3.3-build.xml.
Comment 4 Small_Penguin 2014-03-14 19:45:10 UTC
Created attachment 372670 [details]
jgoodies-common-1.8.0.ebuild

I've blatantly copied this from dmol's overlay (accessible via layman) and modified it for 1.8.0 and to fit the slots.
Comment 5 Small_Penguin 2014-03-14 19:46:57 UTC
Created attachment 372672 [details]
jgoodies-forms-1.8.0.ebuild

Same as jgoodies-common. Not sure tvbrowser needs this newer version, but since I updated jgoodies-common, this was an obvious step to be taken.
Comment 6 Small_Penguin 2014-03-14 19:48:08 UTC
Created attachment 372674 [details]
jgoodies-looks-2.6.0.ebuild

And finally, an up-to-date version of jgoodies-looks, tvbrowser requires at least 2.5.2 IIRC. Thanks to dmol for providing the initial ebuild.
Comment 7 Johannes Huber gentoo-dev 2014-03-14 19:54:02 UTC
Thanks for your work, but i dont be the maintainer for the jgoodies stuff. So you have to create bugs for each of them and make them block this.
Comment 8 Heiko Baums 2014-05-27 20:16:19 UTC
Is there a chance that tvbrowser will be updated anytime soon? The bug is open since almost a year now, the latest version was released about half a year ago.

And the current verion in the portage tree doesn't really work anymore, since the progam table gets very distorted when scrolling it horizontally, so that it can't be read anymore until it is scrolled vertically.
Comment 9 Walter Trautner 2014-06-24 23:59:52 UTC
Installed the tvbrowser ebuild and the three additional ebuilds from Small_Penguin some days ago and they're working fine for me.
Although I may to suggest to update the jgoodies-* to EAPI=5.
Comment 10 Johann Schmitz (ercpe) (RETIRED) gentoo-dev 2014-07-12 07:50:35 UTC
+  12 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +files/3.4-build.xml.patch,
+  +files/3.4-remove-registrykey.patch, +tvbrowser-3.4.ebuild:
+  Version bump of tvbrowser (bug #476594); based on work of Jeroen Roovers


I've bumped the tvbrowser package to 3.4.
Note that i have dropped the themes part entirely because from the website it isn't clear that the themes are licensed under the same license as skinlf (or have a license at all) and these are skinlf themes - they do not belong into the tvbrowser ebuild.

Thanks to everyone who contributed.
Comment 11 Jeroen Roovers gentoo-dev 2014-07-12 11:00:30 UTC
> +  Version bump of tvbrowser (bug #476594); based on work of Jeroen Roovers

I don't think I deserve that mention.
Comment 12 Jeroen Roovers gentoo-dev 2014-07-14 19:20:14 UTC
I removed that bit and added Small_Penguin.