Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 476074 - net-print/cups-filters[zeroconf] requires net-dns/avahi[dbus]
Summary: net-print/cups-filters[zeroconf] requires net-dns/avahi[dbus]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-07 11:16 UTC by Ronald
Modified: 2013-07-07 17:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald 2013-07-07 11:16:57 UTC
If the above requirement is not fullfilled, the following happens:

- pkgconfig/avahi-client.pc is not generated
- $as_echo "#define HAVE_AVAHI /**/" >>confdefs.h will not happen
- cups-browsed says: "Remote support for DNSSD not supported"

This is a silent requirement. Rebuilding avahi with mdnsresponder works as well, but that is because the ebuild will silently enable dbus under that circumstance.

Reproducible: Always
Comment 1 Andreas K. Hüttel gentoo-dev 2013-07-07 17:17:29 UTC
Fixed, thanks.